Skiftade <> och §° knappar MX Keys

Tråden skapades och har fått 3 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Hallsberg
  • 2020-06-25 17:48

Tjena!

Har skaffat mig ett Logitech MX Keys men har ett litet problem med att tangenterna som gör <> och §° är skiftade. De är "normala" när jag kör mot min jobb-pc men på macen så är de skiftade. Hittar bara inställningar för att mappa om modifier-knapparna i mac-os. Någon som vet hur man gör för att lösa detta?

  • Medlem
  • Göteborg
  • 2020-06-25 19:37

Troligen har macen felaktigt tolkat tangentbordet som ANSI när det är ISO. (ANSI-tangentbord är amerikansk standard som helt saknar fysisk knapp mellan Shift och Z)

Se om du fått upp en knapp i Systeminställningar > Tangentbord om att byta tangentbordstyp.
macOS Användarhandbok: Ange tangentbordstyp

Alternativt starta KeyboardSetupAssistant via Terminal eller slänga en plist-fil + omstart, enligt instruktioner på denna sida. (gammalt inlägg på i övrigt uppdaterad sajt, se även sista kommentaren om ett Logitech-tangentbord på mojave)

  • Medlem
  • Göteborg
  • 2020-06-25 20:36

Om du har flera språk-layouter installerade så finns det ett relativt okänt kortkommando för att växla mellan dem. Håll ned CTRL + mellanslag ganska länge, sedan kan du stega mellan språken med mellanslag.

Senast redigerat 2020-06-25 23:29
  • Medlem
  • Hallsberg
  • 2020-06-25 20:50
Ursprungligen av IngoX:

Troligen har macen felaktigt tolkat tangentbordet som ANSI när det är ISO. (ANSI-tangentbord är amerikansk standard som helt saknar fysisk knapp mellan Shift och Z)

Se om du fått upp en knapp i Systeminställningar > Tangentbord om att byta tangentbordstyp.
macOS Användarhandbok: Ange tangentbordstyp

Alternativt starta KeyboardSetupAssistant via Terminal eller slänga en plist-fil + omstart, enligt instruktioner på denna sida. (gammalt inlägg på i övrigt uppdaterad sajt, se även sista kommentaren om ett Logitech-tangentbord på mojave)

Stort tack! Det lustiga är att jag var tvungen att köra det som ANSI för att det skulle funka, med ISO blev det som jag beskrev tidigare. Trots att den sa ISO när jag körde den där grejen när man ska trycka på knappen bredvid shift.

Men åter igen, STORT TACK! Det där höll på att göra mig galen

1
Bevaka tråden