Finder fryser vid TM-backup

Tråden skapades och har fått 25 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Norrköping
  • 2009-02-17 08:49

Problem: Har anslutit en firewire-disk till en iMac 24 och ställt in Time Machine att köra backup mot den. Efter ca. ett dygn slutar säkerhetskopieringen att fungera (TM fastnar vid Preparing...)

Provade då att stoppa/starta TM, men då fastnar programmet vid Stopping... istället. Testade sedan att starta om Finder, men då hänger sig "programmet" helt och hållet och det går därefter inte alls att tvångsavsluta/starta om Finder (not responding). Det enda som hjälper tycks vara att starta om datorn... Vad kan man göra?

  • Medlem
  • Norrköping
  • 2009-02-18 07:59

Upptäckte att även System Preferences processen slutar svara, så jag testade att dödade den. Efter det gick det dessvärre inte att starta den igen. När jag tittar i listan över applikationer att Tvångsavsluta ser jag dock att den finns kvar där och av någon anledning går det inte att få bort den därifrån

Någon som har en aning om vad det är frågan om här?

Senast redigerat 2009-02-18 08:12
  • Medlem
  • Norrköping
  • 2009-02-19 12:35

Alltså... Är det något problem med kombinationen firewire-disk och Time Machine? Nu har jag provat med en annan FW-disk och jag får samma fel där (den första fullständiga säkerhetskopieringen går bra, men vid påföljande backup'er fastnar systemet vid Preparing...)

Det går problemfritt att köra TM mot en partition på den interna disken, men så vill man ju inte riktigt ha det

Kör TimeMachine i en ny iMac 24" med en 500 GB LaCie disk via FW 800. Den har gått några veckor nu helt problemfritt.

Ursprungligen av lensv:

Alltså... Är det något problem med kombinationen firewire-disk och Time Machine? Nu har jag provat med en annan FW-disk och jag får samma fel där (den första fullständiga säkerhetskopieringen går bra, men vid påföljande backup'er fastnar systemet vid Preparing...)...

Har du även provat med en annan kabel?

Har ditt HD-chassi även USB2? Om du inte får samma fel med USB kan du ringa in felet till FW.

Annars kan det vara någon enskild fil som det hänger sig på. Nedanstående är från en gammal post på MacFixit. Kan vara värt att testa (fråga mig inte exakt hur)

"...In other cases, Time Machine becomes inexorably stuck in the "preparing" phase, never continuing with the backup process.

The most effective fix we've discovered for this issue so far: check the system log. Launch Console, located in /Applications/Utilities, then inspect the system log while Time Machine is running. You may find that it is getting stuck on a specific file or directory. Remove that offending item and re-attempt the backup...."

  • Medlem
  • Norrköping
  • 2009-02-19 14:49

Okej, inget generellt problem alltså. Finns det någon som har några tips på hur man ska felsöka här?

  • Medlem
  • Österbybruk
  • 2009-02-19 16:02

Får disken tillräckligt med ström? Har du en AC-adapter inkopplad. Kom att tänka på det spontant.

  • Medlem
  • Norrköping
  • 2009-02-19 16:50

Disken har en AC-adapter, men om den får nog med kräm vet jag faktiskt inte. Den verkar ju iaf. funka som den ska under de första backup-sessionerna (inkl. den initiala kopieringen som tar rätt många timmar)... Men men, hur kontrollerar jag om disken får tillräckligt med ström?

  • Medlem
  • Österbybruk
  • 2009-02-19 16:55

Har du AC-adaptern i så borde inte vara någon fara. Då tar ju disken ström från den. Då måste det vara något annat.

Funkar FW disken om du kör som vanligt mot den??

Vi hade några LaCie FW diskar som backup där det var för liten nätdel så den räckte inte till. Jag fick nya större nätdelar från LaCie. Är det LaCie??

  • Medlem
  • Norrköping
  • 2009-02-20 08:07

Nix, de här diskarna är från Maxtor...

Ang. frågan om de funkar vid vanlig användning så är svaret ja.

  • Medlem
  • Gävle
  • 2009-02-20 09:23

Kör två WD My Book som TM diskar, dom kan ibland få för sig att "somna" vilket för att hela Finder tvärnitar ända tills man fysiskt rycker FW kabeln. Du kan ju prova det.

Ursprungligen av Creops:

Kör två WD My Book som TM diskar, dom kan ibland få för sig att "somna" vilket för att hela Finder tvärnitar ända tills man fysiskt rycker FW kabeln. Du kan ju prova det.

Det är den mest troliga orsaken. Ser man till att disken inte går i vila så brukar det inte vara något problem.

  • Medlem
  • Norrköping
  • 2009-02-20 10:01

Mja, Finder funkar fint tills man börjar döda processer etc. Att rycka disken känns inte riktigt som en lösning... Ska dock testa att avaktivera "Put the hard disk(s) to sleep when possible" och se ifall det blir någon skillnad...

  • Medlem
  • Norrköping
  • 2009-02-23 08:19

Njet... Inte heller avaktivering av "disk sleep" gjorde någon nytta. Backup'en fastnar fortfarande efter några körningar vid Preparing... Vad ska man göra?

Vad säger loggfilerna?

Öppna Systemmeddelanden och läs vad det står där när Finder fryser.

  • Medlem
  • Norrköping
  • 2009-02-24 09:59

Det enda Finder-relaterade meddelande som jag kan hitta i systemloggen är detta (vad det nu betyder):

/System/Library/CoreServices/Finder.app/Contents/MacOS/Finder[1586]: StatusMonitor::volumesChangedCallBack returned -47(Error) LSOF: File

Sedan finns det en hel radda med entries av följande typ, som verkar ha med Spotlight att göra...

/Volumes/Extern/.Spotlight-V100/Store-V1/Stores/B39FF55C-C4F6-4092-A4B5-16CF8E469643/0.indexDirectory' (fd=49) left open on device 234881030

Här är några andra entries som jag tycker verkar suspekta...

disk1s2: I/O error
Backup failed with error: 18
failed to unlink old log file
KernelEventAgent[37]: tid 00000000 received unknown event (256)
/System/Library/CoreServices/backupd[593]: Event store UUIDs don't match for volume: Macintosh HD

Det första meddelandet av dessa tyder på att det existerar någon form av diskfel, men då jag har testat med två olika enheter känns det mera sannolikt att det har med just firewire att göra... Frågan är bara VAD som är fel?

Kör hårdvarutest!

In med start DVDn och håll ner D. Kör testet!

  • Medlem
  • Norrköping
  • 2009-02-24 12:39

Bra idé, men testas verkligen extern hårdvara när man kört AHT?

  • Medlem
  • Norrköping
  • 2009-02-25 10:13

Nu har jag kört ett komplett hårdvarutest och det visade inga fel, men jag är som sagt osäker på om AHT verkligen kollar externa diskar...

De enheter som jag använder har endast firewire-gränssnitt, så jag kan tyvärr inte testa USB. Jag har dock provat med en annan FW-kabel, men det blir tyvärr ingen skillnad

Jag tror inte att det är någon fil ed. som spökar här, för när jag kör TM mot lokal disk går allt felfritt...

AHT testar Firewire men inte USB.

Fler med samma problem:
http://discussions.apple.com/message.jspa?messageID=7867121

  • Medlem
  • Norrköping
  • 2009-02-27 08:41

Sweet... Tack för länken!

Jag hittade något där om Spotlight och det verkar faktiskt som at det är indexeringen som ställer till det. Efter att ha exkluderat den externa disken (i Spotlight-inställningarna) har Time Machine rullat på utan fel, än så länge... Håller tummarna för att problemet är borta "på riktigt" nu

Ursprungligen av lensv:

Sweet... Tack för länken!

Jag hittade något där om Spotlight och det verkar faktiskt som at det är indexeringen som ställer till det. Efter att ha exkluderat den externa disken (i Spotlight-inställningarna) har Time Machine rullat på utan fel, än så länge... Håller tummarna för att problemet är borta "på riktigt" nu

Kul det var rätt lösning! Berätta hur det går om en vecka eller så!

  • Medlem
  • Norrköping
  • 2009-03-03 16:17

Nu har jag kört utan indexering påslagen i några dagar och visst har Time Machine uppfört sig betydligt bättre. Dock har backup'en hängt sig vid ett par tillfällen, så tyvärr är det nog flera faktorer inblandade trots allt

Tänkte bumpa upp den här tråden. Jag har googlat mig trött på detta ämne och hittar ingen bra lösning. Har testat ALLT (typ); stängt av all spotlight, låtit den ta sin tid (gav upp efter 5 dygn) m.m.m.

Jag har t.o.m. blåst hela datorn (en halvgammal mac pro) och timemachinat den samt en extern disk till en helt nyformatterad 1TB USB-disk med GUID-tjosan. Då gick det att göra EN time machine backup. (c:a 300 GB). När den ska försöka igen nästa gång står den på "preparing" igen... I dygn!

Jag lyckas verkligen inte lösa det, oerhört enerverande. Har någon ett färskare tips på lösning eller tips på bättre backupprogram?

  • Medlem
  • Gävle
  • 2010-07-03 19:55

Crashplan, kör mot en extern HD. Har aldrig sett tillbaka...

1
Bevaka tråden