Problem med inläsning av sidor i Safari

Tråden skapades och har fått 22 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Karlskoga
  • 2020-08-12 10:07

Sedan uppdatering till Catalina har Safari blivit riktigt dålig tycker jag. Många sidor visar ingen eller bara begränsad info jämfört med Firefox/Chrome.
T ex denna:
https://www.tesla.com/sv_SE/inventory/new/ms?...
Fel på min installation eller får ni samma resultat?

---
Rubrik utbytt från ”Safari suger” till nuvarande. /Moderator

Senast redigerat 2020-08-14 08:17
Ursprungligen av kenjon:

Sedan uppdatering till Catalina har Safari blivit riktigt dålig tycker jag. Många sidor visar ingen eller bara begränsad info jämfört med Firefox/Chrome.
T ex denna:
https://www.tesla.com/sv_SE/inventory/new/ms?...
Fel på min installation eller får ni samma resultat?

Jag vet inte hur det ”borde” se ut så jag postar en dump. Det ser likadant ut i Chrome för mig.

  • Medlem
  • 2020-08-12 11:20

Det är nog Safari som strular. När jag loggade in på min ISPs sida så saknades det massor av funktioner, b la kunde jag inte logga ut.
Jag fick ringa till kundtjänst för att få hjälp med saker som jag egentligen (borde) kunnat ordna på deras sida. När jag förklarade för supporten att knapparna inte existerade så trodde dom nog att jag var helt blind, eller korkad.

  • Medlem
  • Karlskoga
  • 2020-08-12 12:15

På min Safari ser jag enbart översta raden med menyval, inunder är det helt vitt.
Bara att installera macOS igen då. Ska testa Combo först.

  • Medlem
  • Göteborg
  • 2020-08-12 12:37
Ursprungligen av kenjon:

På min Safari ser jag enbart översta raden med menyval, inunder är det helt vitt.
Bara att installera macOS igen då. Ska testa Combo först.

Kolla först att du inte har några bortglömda och ej uppdaterade tillägg till Safari installerade.

Har haft extremt lite problem med Safari de senaste åren.

Tesla-sidan ser exakt likadant ut för mig i Safari, Firefox, Chrome och Opera.

Ta bort dina Safari-inställningar, töm Cache, tillägg, etc.

/$0,02

  • Medlem
  • Karlskoga
  • 2020-08-12 13:07

Tillägg borta, Innehållsblockerare AV och Combo installerad, ingen skillnad.

Flytta ut allt som har med Safari att göra från Bibliotek och mappen Library/Internet.

Rensa även enligt denna: http://utanvirus.se/hur-aterstaller-man-safar...

Du kan ju även prova att gå in med en annan användare på samma dator för att se om problemet är låst till din användare, eller datorns operativsystem.

PS. Ladda även om sidan med Option + Refresh-knappen. (då läser den in sidan från noll igen). DS.

  • Medlem
  • Karlskoga
  • 2020-08-12 18:33

Testade länken ovan, utom Method 4, ingen skillnad. Ska testa den också....
Annan användare, samma resultat.

I mappen root/Library/Internet plugins finns en del skit som kan ställa till det. Testa släng ut den på skrivbordet och starta om.

Nästa alternativ är ju en ominstallation av macOS.

Mer troligt att problemet är sidor som är skrivna för Internet Explorer 6... eller Chrome skulle jag ju säga.

Ursprungligen av marcushedenstrom:

Mer troligt att problemet är sidor som är skrivna för Internet Explorer 6... eller Chrome skulle jag ju säga.

...bortsett från att det funkar perfekt för mig och Zeugma... 🤦‍♂️

Senast redigerat 2020-08-13 06:56
  • Medlem
  • Karlskoga
  • 2020-08-13 01:29

Och efter Supplement update som kom nu funkar det!

  • Medlem
  • Karlskoga
  • 2020-08-13 01:31
Ursprungligen av carlsson:

I mappen root/Library/Internet plugins finns en del skit som kan ställa till det. Testa släng ut den på skrivbordet och starta om.

Nästa alternativ är ju en ominstallation av macOS.

Tack, där fanns det ett par som jag kunde rensa bort.

Såg detta på twitter i morse. Det är bara en rant, inget förslag till lösning...

BTW: Teslasidan fungerar för mig, bra att det löste sig. Det är så irriterande med sådana där problem

Älskar Safari.
Gillar inte Chrome.
Bra med konkurrens.

Det roliga var att jag hade problem med av de sidor som mitt företag producerar... Och givetvis var det för att jag öppnade den i Safari. Den fungerade i Vivaldi (chromium)...

  • Medlem
  • Göteborg
  • 2020-08-13 12:35

Safari är en fin och snabb webbläsare. Om den hade haft fler tillägg och varit lite öppnare tillgänglig för utvecklare så hade jag nog använt den mer.

Jag har använt de flesta webbläsarna. Tidigare använde jag Firefox, men efter att Firefox dödade sitt ekosystem när de bytte teknik/API för plugins (från NPAPI till WebExtension) så bytte jag till Chrome. Nu har nog Firefoxs plugins vuxit till sig igen, men jag har boat in mig i Chrome.

Jag lånar den här tråden istället för att starta en ny...

Jag har precis slutat med Chrome (tycker det är läskigt att Google ska veta ALLT om mig!) och kör Safari på Mac och Edge på PC:n. Allt frid o fröjd och jag saknar egentligen inte Chrome.

Men... Instagram funkar inte. Eller det funkar som det ska men det går inte att läsa in inkorgen i meddelande-delen? Har andra samma problem?

Versioner
Safari 14.0.1
macOS 10.15.7 (Catalina)

Jag gör som iTiger och lånar/fortsätter på tråden, med problem och tyvärr ingen lösning på ovanstående,
då det gäller samma version av Safari: 14.0.1
Skulle lägga in en annons på Blocket och kunde plötsligt (efter uppdatering till 14.0.1) inte lägga in bilder i annonsen.
När jag klickade på ”Välj bild” i Blocket hände ingenting alls.
Men det funkar perfekt via Chrome, Firefox och Opera.
Har rensat cache för just Blocket i Safari, men det hjälpte inte.
Så nånting är inte 100 med Safari...

Ett tips är kanske att ändra användaragent. Se dump.

  • Medlem
  • Göteborg
  • 2020-11-25 14:46
Ursprungligen av Bapelsinmannen:

Skulle lägga in en annons på Blocket och kunde plötsligt (efter uppdatering till 14.0.1) inte lägga in bilder i annonsen.
När jag klickade på ”Välj bild” i Blocket hände ingenting alls.
Men det funkar perfekt via Chrome, Firefox och Opera.
Har rensat cache för just Blocket i Safari, men det hjälpte inte.
Så nånting är inte 100 med Safari...

Fler som har problem att bifoga filer på vissa websidor med 14.0.1
https://discussions.apple.com/thread/25205181...

Tillägg:
Drag-och-släpp funkar för filuppladdning på websidor som stöder den metoden.

För den som själv underhåller en websida med uppladdningsfunktion finns en abrovinsch tills Apple fixat Safari-bugen
https://stackoverflow.com/questions/64843459/...

Senast redigerat 2020-11-25 15:17

Tack både Zeugma och IngoX!
Eftersom det verkar vara ett känt fel kommer det nog en uppdatering inom kort.

1
Bevaka tråden