Får alltid upp amerikanskt tangentbord

Tråden skapades och har fått 24 svar. Det senaste inlägget skrevs .
1

Kör en iMac 5k med senaste os. Har läst allt som går att läsa och prövat alla föreslagna åtgärder, tror jag, men efter omstart har jag amerikanskt tangentbord igen istället för svenskt. När jag loggar in står det svenskt pro längst upp i högra hörnet men när datorn öppnar så är det amerikanskt. Någon enstaka gång har den öppnat med svenskt. Finns det någon klok människa som har en hanterbar lösning på detta ?

Ursprungligen av LordWellington:

Kör en iMac 5k med senaste os. Har läst allt som går att läsa och prövat alla föreslagna åtgärder, tror jag, men efter omstart har jag amerikanskt tangentbord igen istället för svenskt. När jag loggar in står det svenskt pro längst upp i högra hörnet men när datorn öppnar så är det amerikanskt. Någon enstaka gång har den öppnat med svenskt. Finns det någon klok människa som har en hanterbar lösning på detta ?

Med risk för att nämna något som ryms inom ”prövat alla föreslagna åtgärder” så föreslår jag en säker start. Håll nere skifttangenten vid omstart, logga in och starta sedan om normalt igen.

Ursprungligen av Alix:

Med risk för att nämna något som ryms inom ”prövat alla föreslagna åtgärder” så föreslår jag en säker start. Håll nere skifttangenten vid omstart, logga in och starta sedan om normalt igen.

Tack har även testa det men tyvärr......

Ursprungligen av LordWellington:

...prövat alla föreslagna åtgärder, tror jag...

Ursprungligen av LordWellington:

...har även testa det...

Berätta gärna vad du har provat. Annars riskerar tråden att bara bli en massa "Har redan testat det", vilket kan bli lite frustrerande för alla parter.

Senast redigerat 2017-04-11 12:46
  • Medlem
  • Örnsköldsvik
  • 2017-04-11 16:54

Se till att du bara har en tangentbordslayout i Settings>Keyboard>Input Sources

Ursprungligen av mattiL:

Se till att du bara har en tangentbordslayout i Settings>Keyboard>Input Sources

Jag testade det nu, resultatet blev att amerikanska flaggan dök inte upp men när jag provskrev tangentbordet var det amerikanskt igen. Det lustiga är att när, efter omstart, inloggningsfönstret kommer upp står det svenskt pro uppe till höger i listen så långt är det ju OK men efter att jag skrivit in inlogget och tryckt ok hoppar det över till amerikanskt igen.

  • Medlem
  • Karlskoga
  • 2017-04-11 18:27

Den inställningen ligger i din användarmapps bibliotek. Logga in som en annan användare och se om det blir svenskt då.

  • Medlem
  • Göteborg
  • 2017-04-11 22:48

Detta känns bekant, tror det har varit uppe förut i någon tråd. Inte säker om det är denna tråd jag tänker på, för den handlar om blandade språk i dialogrutor. Men problemet och orsaken är nog besläktad, nämligen att man har flera användarkonton, kanske två som är adminkonton, och att den inställning som gjorts först för att ställa in det globala huvudspråket inte överenstämmer med det man vill.

Kolla språk- och tangentbordsinställningar i alla dina användarkonton. Det finns också terminalkommando för att fixa rätt språk i inloggniningsfönstret, se länk nedan. Kolla även det sista angående tangentbordslayout.
Ändra språket som används i inloggningsfönstret på din Mac

  • Medlem
  • Göteborg
  • 2017-04-11 23:53

Inställningen för tangentbordslayout sparas i varje användarkontos dolda biblioteksmapp:
~/Library/Preferences/com.apple.HIToolbox.plist

Dessutom finns en plistfil i systemets egen biblioteksmapp direkt under Macintosh HD:
/Library/Preferences/com.apple.HIToolbox.plist
Därifrån hämtas inställningen innan du loggat in på ett användarkonto.

Hos mig står det Swedish-Pro på båda ställena. Du har antagligen olika.

Skärmdumpar båda

Ursprungligen av IngoX:

Inställningen för tangentbordslayout sparas i varje användarkontos dolda biblioteksmapp:
~/Library/Preferences/com.apple.HIToolbox.plist

Dessutom finns en plistfil i systemets egen biblioteksmapp direkt under Macintosh HD:
/Library/Preferences/com.apple.HIToolbox.plist
Därifrån hämtas inställningen innan du loggat in på ett användarkonto.

Hos mig står det Swedish-Pro på båda ställena. Du har antagligen olika.

Här är skärmdumpar av båda kanske någon som begriper kan kommentera innehållet.

Skickar skärmdumpar båda igen som en bild

Ursprungligen av LordWellington:

Här är skärmdumpar av båda kanske någon som begriper kan kommentera innehållet.

En bild på båda här.

Det är en komprimerad plist-fil. Använd Quicklook i Finder eller exvis BBedit för att läsa korrekt!

  • Medlem
  • Karlskoga
  • 2017-04-13 13:31

Första stycket sista raden säger ju US. I min dator säger den Swedish på båda platserna.

Båda biblioteken igen kompletta

Ursprungligen av LordWellington:

En bild på båda här.

OK tack här kommer en mer komplett utskrift av filerna. Någon som kan spåra något fel utifrån detta ?

  • Medlem
  • Göteborg
  • 2017-04-15 10:59

Enklaste lösningen är att bara slänga plist-filerna och starta om datorn. Det skapas nya och jungfruligt rena inställningsfiler när de behövs.

Ursprungligen av LordWellington:

OK tack här kommer en mer komplett utskrift av filerna. Någon som kan spåra något fel utifrån detta ?

Tja, plist-filen för ditt användarkonto innehåller för strängen AppleCurrentKeyboardLayoutInputSourceID fortfarande US. Jag gissar att detta sätts av det för tillfället inkopplade tangentbordet. Om du har ett svenskt tangentbord nu så är det fel, antingen på plist-filen (korrupt fil?) eller på tangentbordet. Vidare har din plist-fil under /Library ett avsnitt med AppleInputSourceHistory, det saknas helt hos mig, annars identiskt.

Men som sagt, ingen idé att grotta ner sig i hur plist-filer är uppbyggda, det enklaste är att systemet får göra nya. Jag testade att radera på båda ställena och behövde inte ens välja någon inställning vid omstart. För användarkontot skapades ny plist-fil utifrån det för närvarande inkopplade tangentbordet. Och under /Library har det ännu inte skapats någon ny, sker kanske först när jag börjar växla mellan olika användarkonton inställda för olika språk, eller haft något annat tangentbord inkopplat.

Testat på 10.11.6, iMac7,1 med trådat svenskt apple-tangentbord.

Ursprungligen av IngoX:

Enklaste lösningen är att bara slänga plist-filerna och starta om datorn. Det skapas nya och jungfruligt rena inställningsfiler när de behövs.

Tja, plist-filen för ditt användarkonto innehåller för strängen AppleCurrentKeyboardLayoutInputSourceID fortfarande US. Jag gissar att detta sätts av det för tillfället inkopplade tangentbordet. Om du har ett svenskt tangentbord nu så är det fel, antingen på plist-filen (korrupt fil?) eller på tangentbordet. Vidare har din plist-fil under /Library ett avsnitt med AppleInputSourceHistory, det saknas helt hos mig, annars identiskt.

Men som sagt, ingen idé att grotta ner sig i hur plist-filer är uppbyggda, det enklaste är att systemet får göra nya. Jag testade att radera på båda ställena och behövde inte ens välja någon inställning vid omstart. För användarkontot skapades ny plist-fil utifrån det för närvarande inkopplade tangentbordet. Och under /Library har det ännu inte skapats någon ny, sker kanske först när jag börjar växla mellan olika användarkonton inställda för olika språk, eller haft något annat tangentbord inkopplat.

Testat på 10.11.6, iMac7,1 med trådat svenskt apple-tangentbord.

Slängde filerna men problemet återskapades/är kvar. Ska testa samma idé med annat tangentbord tror någon var inne på det.

Ursprungligen av CekariYH:

Har du rätt sortering i Språk och Region?

https://c1.staticflickr.com/3/2870/33272911674_7b6a0acca7_o.jpgSpråk och Region by CekariYH, on Flickr

Ja den har svenska primärt.

Ursprungligen av LordWellington:

Ja den har svenska primärt.

Ok, va bara ett långskott, så återstår väl bara att test ett annat tangentbord kanske...

Har precis samma problem på min Imac men det verkar som att ingen vet hur denna irriterande bug ska fixas.

  • Wisserbesser
  • Uddevalla
  • 2018-11-11 15:02

Tror det är root-kontot som är fast på US. Aktivera, logga in, byt språk. Se om det funkar.

Ok, tack för svar - men hänger inte riktigt med...vad är det jag ska aktivera? Mitt användarkonto?

  • Inte helt 100
  • Storbritannien
  • 2018-11-12 18:20

Ett annat alternativ kan vara att ta bort en gömd fil som talar om att installationen av OSet är klart. Då får man välja om tangentbord och lite annat. Se till att ha en backup bara! Se http://www.theinstructional.com/guides/how-to...

Ursprungligen av Massez:

Ok, tack för svar - men hänger inte riktigt med...vad är det jag ska aktivera? Mitt användarkonto?

Systeminställningar > Användare och grupper > Inloggning > Nätverkskontoserver: Anslut... > (Katalogverktyg) Redigera > Aktivera rotanvändare > Ange lösenord för detta > Logga ut ur ditt konto > Välj kontot Annan... > Skriv användarnamnet ”root” och lösenordet du valde > Se till att alla språk är på svenska > Logga ut och logga in på din vanliga användare > Systeminställningar > Användare och grupper > Inloggning > Nätverkskontoserver. Anslut... > (Katalogverktyg) Redigera > Avaktivera rotanvändare. (Ovan anges inte de eventuella lösenord och hänglås du måste låsa upp). Jag kan ha glömt något...

ok, super - "so far so good"- vi får se hur länge det håller...tack!

1
Clean my mac!
Bevaka tråden
Clean my mac!
Clean my mac!