Eclipse som universal binary?

Tråden skapades och har fått 12 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2006-04-03 21:54

Finns den skriven för intelMac än? eller när kommer det att släppas en sådan version i så fall?

Jag har försökt googla efter svar, men hamnar här till slut. Bristen på bra träffar är just för att Eclipse inte är skrivet som universal binary än kanske?

Vad tror ni?

Eclipse är skrivet i Java, så det viktiga är att själva Java JVM som Eclipse kör i är snabb. Jag vet inte hur snabb Java är på X86-macar, dock.

Själva Eclipse är inget problem utan det är SWT som behöver kompileras som universal binary. Tror inte att det kommer att göras så mycket åt 3.1, men det är tydligen redan fixat i betan 3.2 M5.

Eclipse innehåller två grejer som är plattformsberoende, SWT (grafikpaketet) och launchern. Från version 3.2M5 kompilerar man för Universal, men det går jättebra att fixa 3.1.2 själv! Läs mer här, och följ bara instruktionerna: http://www.martinkahr.com/2006/03/07/macbook-developer-machine-with-eclipse-31/

Jag har själv fixat Eclipse 3.1.2 enligt Martins instruktioner och Eclipse är *mycket* snabbare nu. Rekommenderas!

  • Oregistrerad
  • 2006-04-04 12:53

Är inte det här forumet så jädrans bra, eller vad tror ni!!!

Toktack. Jag hoppas verkligen att de snart släpper 3.2 M5 snart,
men innan dess så har jag nog inte kunnat hålla mig, och kommer nog alltjämt att ha följt instruktionerna i länken.

Tack för det extremt bra svaret!

  • Oregistrerad
  • 2006-04-04 13:00

Måste installera Developer Tools på maskinen dock för att göra Eclipse till Universal Binaries.

Jag som är flash/php utvecklare tror inte jag egentligen behöver klottra ned min burk med Developer Tools, även om man nån gång kanske vill utveckla något för Mac OS X.

Vet inte så mycket om Developer Tools, men xCode är ju i sig 800mb stort, så jag undrar om hela paketet är än större -för då blir det ju lite too much, bara för att kompilera om Eclipse

Men det finns 3.2M6 att ladda ned också, sen några dagar. Om du bara använder Eclipse i sig, och inte en massa tredjepartsplugin:er och Eclipse Webtools, så kan du köra med M6, den funkar bra. Jag har även testat Subclipse (SVN-plugin) ihop med M5 och det gick fint, däremot inte samtidigt som man har Webtools installerat.

Måste också tillägga att min MacBook Pro är en suverän utvecklingsmaskin för Java. Med en intelmac-anpassad Eclipse så flyger saker och ting fram. Att bygga ett multiproject med Maven (drygt 20 subprojekt) går 7 gånger så snabbt som på min PowerBook 1.67:a! Starta JBoss från terminal är minst 5 gånger snabbare... Livet leker.

  • Oregistrerad
  • 2006-04-04 13:19

om jag inte använder en massa 3dje-parts-pluginer.. dock EN plugin. kan man ta 3.2M6 ändå? Jag är ju ingen systemutvecklare eller så.. men flash/php görs ju bra i Eclipse med har jag hört.

Per, du verkar ha fått en på-nytt-födelse av din MacBook Pro. Tyvärr var den för dyr för mig, en iMac fick räcka denna gång. men man drömmer ju om den bärbara

/ martin

  • Oregistrerad
  • 2006-04-04 13:21

ser ut som att Eclipse släpper en 3 releaser per år på sitt verktyg. Så snart borde det väl släppas en universal-version

Ja, 3.2 blir (är redan) universal. Vad är det för plugin du använder? Jag kan testa mot M6:an om du vill.

  • Oregistrerad
  • 2006-04-04 14:22

Det skulle vara oerhört uppskattat om du kunde testa det åt mig!

http://fdt.powerflasher.com/flashsite/flash.htm
Tryck på Install, och där står det hur -är en full fungerande demo -men det borde duga.

Om detta tar dig mer än 3-4 minuter så kan jag testa till veckan själv annars, men stort tack för allt! (även i andra trådar där jag sett dig i idag)

vad jag menade med förra inlägget var att det snart borde släppa en universal-build som en public release. inte som en test-build -eller vad nu jargongerna är för er riktiga utvecklare

Testade och det såg ok ut till jag försökte öppna en .fla-fil, då fick man en feldialog utan innehåll. Så det kanske är tryggast att fixa en intelkompilerad 3.1.2 och köra på den.

  • Oregistrerad
  • 2006-04-04 16:02

japp, får göra det. Får dra hem hela Developer Tools också bara, så är det nog lätt att fixa till den. Tack!

1
Bevaka tråden