Flash finfint i safari 2 men helfel i Safari 1, hjälp!

Tråden skapades och har fått 8 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Sollentuna
  • 2006-03-08 16:03

Hej Mac-vänner!

Jag håller på att bygga en site som till stora delar bygger på ett flash-baserat bildgalleri. I Safari 2 så fungerar det precis som det är tänkt. I Pc-miljö likaså med IE, Firefox och Netscape. Men med Safari 1.2 så blir det helfel, trots att min användarreferens har flash 8 installerat med Safari 1.2.

Hjälp! Jag har ingen aning om var jag skall börja felsöka och att leta efter tips via googling och annat har inte gett något.

Vad skiljer mellan Safari 1 och Safari 2 vad gäller hanteringen av Flash? Är det några speciella taggar, sniffers, anpassningar eller annat som kan göras för att det skall fungera i Safari 1? Och vad kan anledningen vara? Det ser ju så fint ut i Safari 2..

test sida där galleriet finns:

http://vol.silenius.se/

  • Medlem
  • 2006-03-08 17:26

Vad är det som är fel? Kör Safari 1 och det ända eventuella felet jag ser är att bilderna inte centreras konsekvent. Har Shockwave Flash 8.0 r22.

  • Medlem
  • Sollentuna
  • 2006-03-09 09:34
Ursprungligen av SirN:

Vad är det som är fel? Kör Safari 1 och det ända eventuella felet jag ser är att bilderna inte centreras konsekvent. Har Shockwave Flash 8.0 r22.

Hej SirN,
menar du att allt flyter fint? Exakt vilken Safari 1 kör du, vilket Mac OS? Uppkoppling? Det låter ju helt fantastiskt? Det klagas mycket på att det tar jättelång tid att ladda galleriet, bilderna hackar in, när man klickar på "nästa bild" pilen väntar man i en evighet tills nästa bild hackande kommer in, texten ser helt konstig ut etc. och hos mig ser allt fint ut (bilderna flyter fint in, även i tex via 3G-uppkopplng). [

B]Din feedback är ovärderlig![/B]

Kolla gärna om det är någon skillnad på http://www.vol.se

det är den "officiella" siten där man upptäcker problemen. Är det okej hos dig eller helknasigt? Klicka på valfri fotograf för att komma till galleri (samma galleri fast någon version tidigare än det jag jobbar vidare på just nu)

om du skulle ha möjlighet att återkomma med feedback på de båda gallerierna i din Safari 1 så är jag evigt tacksam!!!!

Senast redigerat 2006-03-09 09:47
  • Medlem
  • Karlstad
  • 2006-03-08 18:00

Det är nog inte flashen det är fel på. Den ska ju se likadan ut oavsett webbläsare.
Jag tror du ska kolla html-koden RUNT flashen istället.
Till att börja med saknas korrekt doctype. Läs mer här:
http://www.alistapart.com/articles/doctype/
Sen får du gå igen alla taggar i tur och ordning. Bl.a. undrar jag om du inte ska komplettera script-taggen med nåt mer (sorry, jag är ingen javascriptfantom)
Dessutom kanske din CSS strular till saker å ting.

  • Medlem
  • Sollentuna
  • 2006-03-09 09:30
Ursprungligen av Danne V:

Det är nog inte flashen det är fel på. Den ska ju se likadan ut oavsett webbläsare.
Jag tror du ska kolla html-koden RUNT flashen istället.
Till att börja med saknas korrekt doctype. Läs mer här:
http://www.alistapart.com/articles/doctype/
Sen får du gå igen alla taggar i tur och ordning. Bl.a. undrar jag om du inte ska komplettera script-taggen med nåt mer (sorry, jag är ingen javascriptfantom)
Dessutom kanske din CSS strular till saker å ting.

Jag har doctype iofs, men det saknades http-adress till loose.dtd, fixad. Har rensat upp koden nu. Men kan det verkligen vara anledningen till att bilderna hackar vid inglidning?

kolla gärna igen (glöm inte att rensa cachen): http://vol.silenius.se

vill även säga; tack så hemskt mycket för att ni hjälper till och tar er tid. jag vet inte hur jag skall ta mig fram annars, helt ovärderligt. Ni är helgon!

  • Medlem
  • Karlstad
  • 2006-03-09 09:50
Ursprungligen av cenneth:

Jag har doctype iofs, men det saknades http-adress till loose.dtd, fixad. Har rensat upp koden nu. Men kan det verkligen vara anledningen till att bilderna hackar vid inglidning?

kolla gärna igen (glöm inte att rensa cachen): http://vol.silenius.se

vill även säga; tack så hemskt mycket för att ni hjälper till och tar er tid. jag vet inte hur jag skall ta mig fram annars, helt ovärderligt. Ni är helgon!

Är inte DTD:n korrekt, så är det samma sak som att inte ha nån alls. Den MÅSTE vara exakt för att funka.
Nä, det är inte html-kodens fel att filmen hackar. Men du skrev ju inte VAD det var för fel, dvs att det hackade. Det var lite svårt att gissa.
Men dels så kräver ju faktiskt filmen en del eftersom det är en stora bilder som glider in ganska snabbt. Har man kanske en maskin med några år på nacken, så kan det mycket väl hacka.
Och dels så är ju Mac OS X jäkligt dålig på att hantera flash, pinsamt mycket sämre än Windows.

Håller med DanneV.. Jag jobbar som Flashutvecklare, och flashpluginen på Mac är ofantligt mycket segare än på PC, speciellt med video och mycket rörlig grafik.. Så det är nog boven. Testa samma webbläsare på en snabbare burk, eller optimera flashen lite Kör du Flash 8 ger "cache as bitmap"-inställningen väldigt stor hastighetsökning om det är mycket som rör på sig samtidigt, testa med den.

  • Medlem
  • Sollentuna
  • 2006-03-09 11:48
Ursprungligen av Kermit:

Håller med DanneV.. Jag jobbar som Flashutvecklare, och flashpluginen på Mac är ofantligt mycket segare än på PC, speciellt med video och mycket rörlig grafik.. Så det är nog boven. Testa samma webbläsare på en snabbare burk, eller optimera flashen lite Kör du Flash 8 ger "cache as bitmap"-inställningen väldigt stor hastighetsökning om det är mycket som rör på sig samtidigt, testa med den.

Jag får helt enkelt optimera flashen så mycket jag bara kan helt enkelt, jag har satt "cache as bitmap" också, tack för tipset!! Tyvärr så letar jag lite i blindo, har inte daglig tillgång till en segare burk så jag verkligen kan felsöka, så all feedback jag fått från er är helt fantastisk. Tyvärr kan jag ju inte heller säga till alla besökare att köpa nya mac:ar

Kunde jag ge betyg så skulle ni alla få en hel famn med stjärnor.

Kan man ladda ned Safari 1 och köra samtidigt som OSX med Safari 2? Om det är burkens prestanda som är problemet så borde väl iofs Safari 1 på min mac mini fungera lika fint som i Safari 2 och inte ge så mycket för felsökning, eller skiljer det mycket? Många frågor

om någon av er har lust att surfa på test-siten och nya siten med ettan och säga om ni upplever det hackligt och hemskt, i båda eller någon av dem, så är jag oerhört tacksam.

Fan det här forumet är verkligen kalas!

(säg till om jag kan göra något i gengäld mot er hjälp)

Inte för att vara elak på något sätt, men jag tycker problemet är lite överdimensionerat

Om man ska ha en site och den måste vara i flash samt ha helskärmsbilder med grafik som rör sig, så får man helt enkelt räkna med att den går segt på äldre datorer. Vill man ha en snabb sida är det bättre att göra en enkel i html. Det är litegran det man får försöka få kund/besökare med stenåldershårdvara att förstå, det är klart enklaste approachen.

Visst kan man optimera massor, men det gör sällan någon större skillnad. Om flashen nu MÅSTE fungera bra även på segare datorer kan du t ex ta bort animeringarna (eller byta ut mot enklare toningar), bygga en speciell version av sidan som visas om man har seg dator etc.. Men enklast är att från början speca vilka webbläsare / operativsystem / Mhz sidan är anpassad för.

1
Bevaka tråden