Kodningsproblem

Tråden skapades och har fått 7 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Luleå
  • 2006-02-15 23:51

Hej!
Jag håller på att lära mig html-kodning. Nu har jag kommit till ett litet problem. Jag ska skriva in en liten text precis under en bild. Både bilden och texten ska vara länkar till ett annat html-dokument. Nu har det krupit sig in ett streck mellan bild och text. Fånigt och skitjobbigt. Jag kan se detta på mac, men ej på pc. Tar jag bort texten försvinner även det jobbiga stecket. Men kan jag ta bort strecket utan att ta bort texten?

Om ni vill se eländet så surfa in på nedanstående adress. Ni kan inte missa vad jag menar.

http://www.paceraiser.se/Produkter.html

mvh
KOL

  • Oregistrerad
  • 2006-02-16 02:25

Olika webb-läsare parsar html-kod olika. Firefox visar den blåa raden på PC och MAC.

Du kan komma runt detta genom att använda styles. Du kan då skriva något i stil med:

<a style="a, a:visited, a:hover { text-decoration:"none"; }" href="länk"><img src="bild">Hej hej</a>

då kommer dock inte texten i länken att vara understruken... men det kanske du kan leva utan?

  • Oregistrerad
  • 2006-02-16 08:39

<a style="text-decoration:none" href="länk"><img src="bild" alt="">Hej hej</a>

  • Oregistrerad
  • 2006-02-16 21:51
Ursprungligen av palb:

<a style="text-decoration:none" href="länk"><img src="bild" alt="">Hej hej</a>

there you go.. knasig syntax.. tack!

  • Medlem
  • Karlstad
  • 2006-02-16 22:13
Ursprungligen av palb:

<a style="text-decoration:none" href="länk"><img src="bild" alt="">Hej hej</a>

Du glömde ett semikolon efter "none", va?
Ska väl vara
<a style="text-decoration:none;" href="länk">

  • Medlem
  • Luleå
  • 2006-02-16 13:47

Tack för hjälpen!

mvh
KOL

  • Medlem
  • Mölndal
  • 2006-02-16 22:22

Enligt standarden ja, och den bör man följa. Men det funkar lika bra utan.

  • Medlem
  • Höganäs
  • 2006-02-16 23:34

Skoterdelar i eloxerad aluminium är coolare än alla datorer i världen...

1
Bevaka tråden