åäö funkar inte i iWebb

Tråden skapades och har fått 44 svar. Det senaste inlägget skrevs .
  • Oregistrerad
  • 2006-01-28 13:48

Hallå allesammans!

Har precis börjat använda iWebb och det är riktigt kul. Det är dock en sak som blir fel för mig. ÅÄÖ i webbläsaren blir fel, det blir bara massa konstiga tecken. I iwebb ser det dock ok ut. Men i safari så blir det jätte konstigt. Dock inte när jag öppnar det från min lokala mapp utan bara när jag har laddat upp den. Jag använder mig av bredbandsbolagets server, den man får med när man har ett bredbandsabbonemang. För att ladda upp filerna använder jag mig av Captain FTP. Hjälp mig snälla så att det blir någon ordning på min hemsida. O.B.S. jag är bara en glad amatör och vill gärna ha en enkel lösning.

tack

Låter som om du har fel encoding på texten.

  • Medlem
  • Karlstad
  • 2006-01-28 15:19

Har inte testat iWebb.
Men det måste ju gå att öppna dokumentet med t.ex. TextEditor och ändra alla konstiga tecken till å, ä och ö i koden.
(För stor bokstav: Å, Ä och Ö

Senast redigerat 2006-01-29 10:53
  • Medlem
  • Solna
  • 2006-01-28 23:28

En kompis till mig har haft samma problem. Tydligen säger HTML-koden i filen att den är UTF-8-kodad. Men hans server på högskolan sa att det var ISO-8859-1 (vilket inte är stanardinställning, utan något någon hade ändrat på eget bevåg)... Uppenbarligen var Apache felinställt. I hans fall hjälpte det att lägga in inställningar i en fil vid namn .htaccess som overrideade inställningen i Apache...

Kan det tänkas vara det som är problemet här med?

Ursprungligen av TERdON:

En kompis till mig har haft samma problem. Tydligen säger HTML-koden i filen att den är UTF-8-kodad. Men hans server på högskolan sa att det var ISO-8859-1 (vilket inte är stanardinställning, utan något någon hade ändrat på eget bevåg)... Uppenbarligen var Apache felinställt. I hans fall hjälpte det att lägga in inställningar i en fil vid namn .htaccess som overrideade inställningen i Apache...

Kan det tänkas vara det som är problemet här med?

Ja. Se till att besökarnas webbläsare får rätt teckenkodningsinformation så kommer problemet att försvinna. Lägg in den här raden i en .htaccess-fil som du lägger i din webbplats rotkatalog:

AddCharset UTF-8 .html

Om det inte fungerar (om ditt webbhotell ignorerar .htaccess-filer) får du se till att dina html-dokument innehåller en meta-tagg som sätter rätt Content-Type, men prova med .htaccess-filen först.

  • Medlem
  • Solna
  • 2006-01-30 02:21

kan meddela att det inte är säkert att meta-taggar hjälper. De finns med i filerna som default faktiskt (precis som det borde vara), trots det hade min kompis problem. apache.conf overridear visst vad som står i själva HTML-filen. En .htaccess var precis det sätt han också löste det på.

  • Oregistrerad
  • 2006-02-02 17:28

Ringde Bredbandsbolager idag och frågade vad det var som kunde vara fel. De påstod att man skall byta ut alla åäö mot någon tecken kombination. Skall försökat att testa detta och se om det hjälper.

Ursprungligen av Masterboy:

Ringde Bredbandsbolager idag och frågade vad det var som kunde vara fel. De påstod att man skall byta ut alla åäö mot någon tecken kombination. Skall försökat att testa detta och se om det hjälper.

Har just själv upptäct detta problem med iWeb och bredbandsbolaget, ingen som hittat någon bra enkel fungerande lösning på detta?

Har mest lekt med iWeb, gick över till att göra sidan på engelska i stället för allt strul med att sitta och editera html koden för hand..men det känns inte som någon kul lösning när mina föräldrar inte kan ett ord engelska (jo sidan är mest tänkt som en samlingsplats för familjen)

Alla bra enkla tips mottages tacksamt, eller någon som kan det här bra som kan hjälpa till att skriva ett "standard-brev" som vi alla kan skicka in till bredbandsbolaget?

mvh
/gusten68

  • Oregistrerad
  • 2006-05-16 10:59

Engelska "Comments" i svenska iWeb

Har uppdaterat iWeb till 1.1 och gillar möjligheten att låta besökarna lägga till kommentarer.

Några minus dock:

- Språket i kommentarlänkar är på engelska - "Add a comment" osv. och tycks inte kunna ändras.

- Man borde ju självklart kunna göra en gästbok utan att gå omvägen över bloggfunktionen.

Någon som har tips på lösningar?

  • Oregistrerad
  • 2006-05-17 07:34

Är det fortfarande problem med åäö ni som uppdaterat ?

Ursprungligen av Dan:

Är det fortfarande problem med åäö ni som uppdaterat ?

iWeb kör UTF-8, som är en modern teckenstandard för Internet. En del servrar använder ISO standarden, vilket gör att hemsidor kodade med UTF-8 blir fel. Servrarna kodar alltså om sidorna efter en annan teckenstandard, även fast hemsidan innehåller information som ställer in UTF-8! Webbläsaren läser "UTF-8" från hemsidan och ställer in UTF-8, även fast servern har ändrat till ISO. Så webbläsaren snackar UTF-8 och servern snackar ISO och då blir svenska tecken, och andra icke engelska tecken, fel.

Man kan givetvis tycka att Apple borde ha en funktion i iWeb där man kan välja teckenstandard, å andra sidan kan man samtidigt tycka att webbhotellen inte ska styra över vilken teckenstandard som deras kunder använder.

Jag har kört iWeb mot Spray och One.com som webbhotell. Alla har fungerat utan problem med sidor från iWeb. Jag har inte kört mot Bredbandsbolagets servrar så jag har ingen åsikt om dem.

Hälsar
R

å = &aring
ä = ä
ö = ö
Å = Å
Ä = Ä
Ö = Ö

som Danne V skrev ovan

  • Medlem
  • Solna
  • 2006-02-02 22:58

Det ska förvisso fungera även utan att använda den funktionen, om man ställt in allt till att ange rätt teckentabeller. I alla fall med alla webbläsare som har någon som helst marknadsandel idag...

  • Medlem
  • International user
  • 2006-02-07 10:05

Hur har det gått, löste du det och i så fall hur?

Har precis samma problem...

Fast första sidan, välkommen sidan har korrekt teckenkodning med åä och ö.
De andra sidorna blir fel.... vad tråkigt, ville ju bara slippa en massa meckande med sånt här nu när iWeb kom...

iWeb skapar en index.html fil samt en katalog som i sin tur innehåller resten av sidan, även där finns en index.html fil.

Var och hur skulle man lägga en sådan där htaccess fil någonstans?
Om den skall ha en punkt framför, .htaccess så blir den väl dold? Kan man då se den i finder... eller i Transmit....

  • Medlem
  • Stockholm
  • 2006-02-07 15:13
Ursprungligen av Pgreen:

Var och hur skulle man lägga en sådan där htaccess fil någonstans?
Om den skall ha en punkt framför, .htaccess så blir den väl dold? Kan man då se den i finder... eller i Transmit....

Du ska lägga den i webbrooten. För att se "osynliga filer" i Transmit, gå in under menyn "Show" och välj "Show invisible files".

  • Avstängd
  • Stockholm
  • 2006-02-07 10:23

Aha...iWeb har seriösa buggar. Då väntar jag med iWeb.

  • Oregistrerad
  • 2006-02-07 11:04

Jag har inte hunnit mecka så mycket med det men jag har inte fått det att fungera ännu

  • Medlem
  • International user
  • 2006-02-07 14:50

Mina sidor fungerar bra om man sparar dem lokalt och tittar på dem med ex. Safari.

Problemet med teckenkodningen blir när man laddar upp dem till webservern (i mitt fall bredbandsbolaget). Men första sidan blir ok... skumt tycker jag...

Ahh... dessa teckenkodningar... struligt...

  • Medlem
  • International user
  • 2006-02-07 19:49

La dit en .htaccess fil och fick föjande resultat:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Apache/1.3.33 Server at hem.bredband.net Port 80

Jag har också haft enorma problem med å, ä och ö. Dessutom har jag haft problem med citationstecken och bindestreck som blir helknasiga. Om inte det var nog så skapas ett Å så fort man gör ett radbryt? Nu har jag lyckas lösa det mesta.

Följande tecken skapar iWeb i sina publicerade .html-filer istället för våra svenska:

å = Ã¥
ä = ä
ö = ö
Å = Ã…
Ä = Ä
Ö = Ö

Citat-tecknen skriver iWeb ut som: �

För att rätta min sida gjorde jag följande:

Jag öppnade alla .html-dokument i den publicerade mappen med en texteditor.
Sedan gjorde jag "Sök och ersätt alla" och gick igenom alla tecken enligt "Johan S"-formula. (se ett par inlägg ovan)

Exempel:
För att få ett korrekt å så sökte jag alla Ã¥ och ersatte med å
sedan gjorde jag likadant med resten av alla tecken.

Inte speciellt smidigt eller användarvänligt, men det kommer förhoppningsvis en uppdatering som korrigerar detta inom kort.

Om någon vet varför radbrytning ger ett Å så får ni gärna förklara hur man får bort det.
Om någon vet hur man får citationstecken istället för ” så vill jag också hemskt gärna veta hur man fixar det.

Min sida: http://www.easedrop.com

Ursprungligen av Martin Pettersson:

Följande tecken skapar iWeb i sina publicerade .html-filer istället för våra svenska:
...

Ser ut som unicode.

Som sagt, så länge webbläsaren får rätt teckenkodningsinformation från webbservern fungerar det, och då behöver man inte ta till html-specialtecken. Specialtecknen är att se som en nödlösning, bättre då att se till att fixa en .htaccess-fil eller prata med systemadministratören så man får webbservern att leverera unicode redan från början. Då har man i princip löst teckenkodningsproblemen för all framtid, och då slipper man ta till nittiotalslösningar eller dribbla med olika teckenkodningar hit och dit så fort man ska presentera innehåll på ett annat språk än engelska. Som jag ser det är det den enda vettiga lösningen i långa loppet.

Ursprungligen av TERdON:

kan meddela att det inte är säkert att meta-taggar hjälper. De finns med i filerna som default faktiskt (precis som det borde vara), trots det hade min kompis problem. apache.conf overridear visst vad som står i själva HTML-filen. En .htaccess var precis det sätt han också löste det på.

Stämmer, HTTP-huvudena servern skickar ut har företräde, och det ska de ha eftersom metataggarna finns till som en workaround för att simulera http-trafik när webbläsaren hämtar en fil som ligger lokalt på hårddisken. Hade faktiskt glömt bort att det var så, fel av mig...

Ursprungligen av Samuel K:

Ser ut som unicode.

Som sagt, så länge webbläsaren får rätt teckenkodningsinformation från webbservern fungerar det, och då behöver man inte ta till html-specialtecken. Specialtecknen är att se som en nödlösning, bättre då att se till att fixa en .htaccess-fil eller prata med systemadministratören så man får webbservern att leverera unicode redan från början.

Hur ska jag formulera denna förfrågan till mitt webhotell?

  • Oregistrerad
  • 2006-02-13 12:43

jag vet inte vad det är för problem men jag får det inte att funka. När jag öppnar de sparade html filerna i dreamweaver så är å ä ö rätt och ändrar jag de till den texten som Johan S. Då ser man man bara den textkombinationen. När jag tittar på hemsidan utan att ha gjort denna förändring så ser jag precis som Martin säger de tecken som han säger men jag ser inte dessa när jag öppnar html filerna. Kan det vara så att när jag överför dem till serven så ändras dom? När jag tittar på hemsidan lokalt så ser den ju ok ut.

vad detta inlägg förvirrande så är det inget mot vad jag är.

Det verkar som att iWeb-sidor trivs bäst på Mac-servrar. Jag testade att lägga upp min "ofixade" på en Mac OS X Server och där visas å, ä och ö rätt. Men min easedrop.com domän kör linux och där måste jag manuellt fixa å, ä och ö.

  • Medlem
  • Solna
  • 2006-02-13 20:47

Antagligen är det så att Mac OS X-servrar oftare är inställda på att INTE använda något annat än UTF-8. På övriga operativsystem borde ISO-8859-1 vara väldigt vanligt, och uppenbarligen är det så att Apache har någon inställning som tyvärr defaultar allting till vad den nu står på. Även om något annat är korrekt specifierat i filen själv (som i iWebbs fall). Som sagts ovan är det enklaste sättet att lösa det om man använder Apache som webbserver att ladda upp en lämplig .htaccess.

Naturligtvis borde alla vanliga konstiga tecken, i alla fall i Västeuropa, ersättas med sin &-escapesekvens. Dessutom borde alla vettiga webbredigeringsprogram någonstans ha en inställning för teckenkodning...

  • Medlem
  • Skara
  • 2006-02-16 23:48

En helt annan sak..
Jag har svenska iLife, men vill skapa hemsidor på engelska.
Alla knappar man kan lägga in (t.ex. "Skapad på en mac" blir på svenska..
Kan man byta defaultspråket?

Ursprungligen av Kalam:

En helt annan sak..
Jag har svenska iLife, men vill skapa hemsidor på engelska.
Alla knappar man kan lägga in (t.ex. "Skapad på en mac" blir på svenska..
Kan man byta defaultspråket?

Välj programmet i Finder > Visa info > Språk. Bocka bort svenska.

  • Medlem
  • Skara
  • 2006-02-17 20:13
Ursprungligen av Björn Leander:

Välj programmet i Finder > Visa info > Språk. Bocka bort svenska.

Wunderschön!

  • Medlem
  • 2006-02-18 12:17

Jag har samma problem med BBB och iWeb.
Problemet kan de lösa, om de vill, men icket!
BBB´s server TVINGAR din webläsare att visa sidan som den gör, istället för att låta webläsaren välja själv.

Jag har haft kontakt med BBB men får svar att:
-Vi ändrar inte.
"Bredbandsbolaget har valt att använda ISO-8859-1
som standard då besökare till de hemsidor som ligger på Bredbandsbolagets
kunders hemsidesutrymmen oftast är vana vid latinska tecken"

Allt de behöver göra är att:
Ändra raden "AddDefaultCharset ISO-8859-1" till "AddDefaultCharset Off" på deras server, så skulle det ej va ngt problem.

  • Medlem
  • Örebro
  • 2007-09-02 02:10
Ursprungligen av Maffe:

Jag har samma problem med BBB och iWeb.
Problemet kan de lösa, om de vill, men icket!
BBB´s server TVINGAR din webläsare att visa sidan som den gör, istället för att låta webläsaren välja själv.

Jag har haft kontakt med BBB men får svar att:
-Vi ändrar inte.
"Bredbandsbolaget har valt att använda ISO-8859-1
som standard då besökare till de hemsidor som ligger på Bredbandsbolagets
kunders hemsidesutrymmen oftast är vana vid latinska tecken"

Allt de behöver göra är att:
Ändra raden "AddDefaultCharset ISO-8859-1" till "AddDefaultCharset Off" på deras server, så skulle det ej va ngt problem.

Och så skulle alla websidor gjorda av idioter som inte sätter charset inte visa några åäö längre ...

Bevaka tråden