ssh och grafik

Tråden skapades och har fått 10 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2006-01-18 21:36

Tja,

Har så dålig koll på detta så det har varit svårt att veta vart jag ska börja läsa in mej....

Problemet är att jag vill ansluta till en dator på mitt universitet för att kunna utföra saker hemifrån. Jag kan logga in via ssh så det funkar bra, problemet ligger i att jag skulle vilja ha de grafiska menyerna i emacs.
Man skall köra X11 och inte vanliga terminalen vad jag vet, sen trodde jag att ssh -X gjorde så att man fick upp grafik men verkar inte funka.
Någon som vet något eller har några tips på vart jag kan läsa in mej på ämnena X11, ssh och allt annat som jag bör veta?

/johan

  • Medlem
  • Stockholm
  • 2006-01-18 22:19

Jag antar att datorn på universitetet inte är en Mac utan en?? Linux???

Själv går det bra att köra emacs på en Linuxserver från min Mac. Vad händer hos dig då du försöker? Får du några felmeddelanden?

En del andra program fungerar inte så bra för mig med Macens X11-implementation dock.

  • Medlem
  • Sollentuna
  • 2006-01-18 22:35

Det kan också vara som så att dina sysadm har stängt av den funktionen. Det går nämligen att göra så i (typiskt) /etc/sshd_config.

Du kan prova en gång med ssh -Y och se om det går bättre, har hjälpt mig någon gång.

Jag använder ssh -l användarnamn adress -X i X11 om jag vill öppna fönster och program från universitetet hemma.

  • Oregistrerad
  • 2006-01-18 23:16
Ursprungligen av Niklas Brunberg:

Jag använder ssh -l användarnamn adress -X i X11 om jag vill öppna fönster och program från universitetet hemma.

Testade det men fick det första felmedelandet jag skrev när jag försökte starta emacs.

Unix dator visst:
Sun Microsystems Inc. SunOS 5.10

/j

  • Oregistrerad
  • 2006-01-18 23:12

Jag antar att det är någon Linux/Unix dator.

när jag startar emacs (-X) så händer detta (samma för emacs &):
<23:06>~/emacs
X protocol error: BadWindow (invalid Window parameter) on protocol request 3
<23:06>~/

När jag testade med -Y så fungerade det nästan: Error in init file: error: "Invalid face", font-lock-string-face
Det verkar fungera nästan som sagt, fast det är seeegt.

/johan

Glömde säga en sak: Aktivera helskärmsläget via inställningarna och därefter via menyn X11 > Använd helskärmsläge (kortkommando ALT + KRINGLA + A är viktigt att komma ihåg för att komma ut från det läget).

Sen borde du kunna logga in med både -X eller -Y, vilket du nu känner för. Man får ett felmeddelande, men i praktiken fungerar det som det ska.

Hoppas det löser ditt problem Johan!

  • Medlem
  • Stockholm
  • 2006-01-19 10:38
Ursprungligen av Niklas Brunberg:

Sen borde du kunna logga in med både -X eller -Y, vilket du nu känner för. Man får ett felmeddelande, men i praktiken fungerar det som det ska.

För mig fungerar endast -Y i de flesta fall.

  • Oregistrerad
  • 2006-01-19 12:11

Har du testat något annat än emacs ? Testa xterm exempelvis. Fungerar inte det heller så är det inget fel på emacs iaf.

Fråga admin om dom stängt av något. Om du har konto på någon annan server (Exempelvis nån polare) så kan du ju testa det.

För mig fungerar det fint, även om Mac X11 inte är speciellt stabilt..

  • Oregistrerad
  • 2006-01-20 01:10

vet inte vad ja gjort riktigt men det verkar fungera ok nu.
Kör med: ssh -Y login@server.....
Nu får jag även upp grafiken även om det går lite slööött.

/Johan

1
Bevaka tråden