Nybörjarproblem med asp...

Tråden skapades och har fått 4 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Malmö
  • 2006-01-07 19:39

Jag läser en kurs nu där vi håller på med lite asp-programmering.
Jag har förstått från lite olika trådar på lite olika forum att mac och asp inte är bästa vänner,
men man måste väl ändå kunna titta på en "asp-fil" som ligger på en server med macen?
Eller går inte ens det?

Jag har skrivit ett enkelt asp-script, lagt upp det på en server och tänkte nu titta på det,
men varken safari eller firefox verkar särskilt sugna på det, de vill bara ladda hem filen...
Är det jag som gör något fel kanske?

Hjälp uppskattas väldigt mycket!
Tackar på förhand! / Gustav

  • Medlem
  • Malmö
  • 2006-01-07 20:05

ASP koden måste interpreteras av någon mjukvara på servern. På windows sker detta genom att webservern känner igen filen på filändelsen och skickar den till ASP-hanteraren och sedan skickas resultatet av detta till klienten.
Det är alltså inte webläsaren som är problemet. Det finns helt enkelt inte något på din server som tar hand om koden och kör den.

Jag vet inte om det finns någon väl fungerande lösning till mac. Det skulle nog vara någon form av insticksprogram till apache-servern.

Kolla på denna: http://www.apache-asp.org/ jag är dock inte säker på om den haterar vbscript

Är det ASP.NET du kör (aspx) så finns det något som heter mono som ska kunna fixa det... http://www.mono-project.com/

Jag har inte testa något av detta själv, men om du gör det så berätta gärna om det funkar bra.

Rent allmänt skulle jag nog kört tekniker som är mer hemma i mac på mac och köra windows-tekniker på windows, men är det en kurs du måste göra så har du kanske inte så mycket val..

  • Medlem
  • Malmö
  • 2006-01-07 20:14

Servern jag har lagt upp mina filer på är inte min,
den är "windows-baserad" (eller vad man säger) såvitt jag vet..
Då är det något annat som har gått fel?
Det ska funka då va? Tack för hjälpen i alla fall!!

  • Medlem
  • Malmö
  • 2006-01-07 20:23

Ja, om servern är windows så ska det fungera! Om den inte körs ordentligt så har det inget med webbläsaren att göra.

IIS (webservern) måste vara konfigurerad att köra ASP men jag tror att den ska vara det "out-of-the-box" nuförtiden, så det verkar konstigt.

  • Medlem
  • Malmö
  • 2006-01-07 20:37

Fick det att funka nu...
Lade upp det på en annan server så tydligen måste det ha varit den servern som
strulade på något sätt...
Tackar för hjälpen som sagt var!

1
Bevaka tråden