Svenska tecken i Unix

Tråden skapades och har fått 19 svar. Det senaste inlägget skrevs .
1

Jag har nu installerat Darwin 1.3.1 på min Power Macintosh 7300. Den startade upp med lite hjälp av XPostFacto. Allt fungerar fint, jag kommer in i systemet och så vidare. Men jag skulle behöva svenska tecken. Vet någon hur man gör det direkt i Darwin, dvs inte genom Terminal?

Jag kanske missuppfattat det hela. Men Darwin, är inte det själva kärnan i OS X och är inte just Darwin terminalbaserat?

Ursprungligen av pertoyra:

Jag kanske missuppfattat det hela. Men Darwin, är inte det själva kärnan i OS X och är inte just Darwin terminalbaserat?

Jo, det stämmer. Men det går också att starta i Darwin eftersom Darwin är ett operativsystem som kan köra utan resten av Mac OS X. Jo, Darwin är terminalbaserat.

"Vet någon hur man gör det direkt i Darwin, dvs inte genom Terminal?"

Är i så fall inte denna mening lite motsägelsefull? Eller är det fortfarande jag som inte hänger med?

Ursprungligen av pertoyra:

"Vet någon hur man gör det direkt i Darwin, dvs inte genom Terminal?"

Är i så fall inte denna mening lite motsägelsefull? Eller är det fortfarande jag som inte hänger med?

I Mac OS X så använder man programmet Terminal för att nå Darwins terminal. Men i datorn som jag kör enbart Darwin i finns inte programmet Terminal utan man kommer direkt till Darwins terminal.

Vanligtvis kan man göra en inställning i programmet Terminal som reglerar vilken teckentabell man använder. Gör man dessutom ett par förändringar i en del filer så får man möjlighet att använda svenska tecken. Men då jag saknar programmet Terminal så kan jag inte göra den inställningen.

Ursprungligen av Björn Leander:

I Mac OS X så använder man programmet Terminal för att nå Darwins terminal. Men i datorn som jag kör enbart Darwin i finns inte programmet Terminal utan man kommer direkt till Darwins terminal.

Vanligtvis kan man göra en inställning i programmet Terminal som reglerar vilken teckentabell man använder. Gör man dessutom ett par förändringar i en del filer så får man möjlighet att använda svenska tecken. Men då jag saknar programmet Terminal så kan jag inte göra den inställningen.

Jaja du menar så, då är jag på banan igen. Missuppfattade dig en aning.

Jag testade bara en sak på min burk nu för skojs skull där inte åäö fungerade i Terminalen. Körde en chansning och skapade ~/.inputrc och lade till raderna:

set meta-flag on
set input-meta on
set convert-meta off
set output-meta on

Detta ger mig fungerande åäö i Terminalen dock har jag ingen aning om det löser ditt problem. Anledningen till att jag överhuvudtaget testade är att jag provade detta på min FreeBSD maskin förut och fick det att funka. Vad det exakt gör kan jag inte säga!

Ursprungligen av pertoyra:

Jag testade bara en sak på min burk nu för skojs skull där inte åäö fungerade i Terminalen. Körde en chansning och skapade ~/.inputrc och lade till raderna:

set meta-flag on
set input-meta on
set convert-meta off
set output-meta on

Detta ger mig fungerande åäö i Terminalen dock har jag ingen aning om det löser ditt problem. Anledningen till att jag överhuvudtaget testade är att jag provade detta på min FreeBSD maskin förut och fick det att funka. Vad det exakt gör kan jag inte säga!

Detta funkade ju fint! Jag har försökt några gånger tidigare att få terminalen att visa åäö, men misslyckats varje gång.

Sen visade det sig tyvärr att åäö i fil/mappamn fortfarande visades konstigt (\xxx), och att jag inte kunde komma åt dessa filer/mappar med mina nya fina å ä och ö:n. Dessutom kunde jag inte skapa filer med åäö, t ex med touch. Så jag började ta bort rader från din .inputrc för att se om det var något av det som strulade till det. Det visade sig att terminalen nöjer sig med "set output-meta on" för att göra så att man kan skriva åäö. Jag vet inte vad de andra gör, och orkar inte sätta mig in i det så länge det funkar.

I vilket fall löste det inte problemet, men det fixade sig genom att ändra till Unicode under Fönsterinställningar->Skärmutseende->Teckenuppsättningskodning.

Nu verkar allt funka med åäö! Härligt! Tack pertoyra!

Sen tvivlar jag på att inställningar för bash eller tcsh har någon betydelse för hur OS X sköter teckenkodning i övrigt.

Tyvärr fungerade det inte.

Kan det ha något att göra med att jag kör tcsh på den?

.inputrc används bara av bash (eller rättare sagt biblioteket readline, som bash använder), så det funkar nog inte med tcsh. Vet tyvärr inte vad man behöver i tcsh för att få till samma sak.

Ja, jag kör som sagt bash på både macen och min freebsd burk.

Är inte bash standard shell i Terminalen när man installerar OSX? Varför skulle Darwin köra ett annat?

När man kör Mac OS X så ligger ju Darwin i botten. Nu när jag kollar så kör min iBook med Mac OS X 10.4.3 på Darwin 8.3.0. Om jag minns rätt så var tcsh standard fram till Panther då man övergick till bash.

Senast redigerat 2006-01-07 21:48

Jo, precis, och de som skapade sina konton innan dess och sedan har uppgraderat har tcsh. Anledningen att man länge körde med tcsh var att det är standardshell i FreeBSD, och Darwins userland hämtar till stora delar från de olika BSD-projekten, då främst FreeBSD, medan bash kommer från GNU.

  • Medlem
  • Luleå
  • 2006-01-19 15:17

Det här verkar vara ett problem för flera... Själv sitter jag med Panther på en gammal iBook, och där händer följande när jag kör i Terminal:

*Svenska tecken kan köras med rätt inställningar i "Förnsterinställningar". Det blir dock inte något systemet fattar, utan jag ser svenska tecken som sedan uppfattas som "\364" eller liknande. Det visar sig när jag står i kommandoraden, skriver in ex "åäö" och får som svar "\364\365\367 anknown command" /kanske inte exakt så här, men snarligt).

*Startar jag sedan emacs så fattar systemet ingenting när jag försöker skriva in ett "ö", det bara piper till.

*Lustigt nog kan jag starta ssh för att logga in på Unix-systemet på jobbet. Då fungerar allt perfekt! Samma Terminal, samma fönster, samma inställningar. Varför fungerar det då inte *innan* ssh startas?

Finns det någon vettig förklaring till detta? Och viktigare, kan man lösa det så att jag kan köra emacs på iBooken?

Robert

  • Medlem
  • Falun
  • 2006-01-19 17:07

Har du testat med;
setenv LC_CTYPE sv_SE.ISO8859-15
i filen ~/.cshrc ?

Vet inte om det kommer att fungera. Kör inte tcsh på någon av mina burkar, så jag kan inte testa själv.

Ok, tabbkomplettering funkar inte om första bokstaven som skiljer är å, ä eller ö verkar det som. Inte heller om man vill komplettera efter man redan skrivit dessa tecknen i filnamnet. Men det är i alla fall fler steg framåt än bakåt.

  • Medlem
  • Luleå
  • 2006-01-22 16:30

Fortfarande problem i emacs...

Jag försökte mig också på detta med ändringar i .inputrc, och lyckades få till det. I kommandoraden. När jag startar emacs vill det sig ändå inte, där blir det på sin höjd "?" av å, ä eller ö. Några förslag? Det verkar ju löjligt detta...

Robert

Ja jag har problem med nano också. Visserligen skriver den in åäö men efter varje svenskt tecken byter den rad och hoppar till slutet av filen.

  • Oregistrerad
  • 2006-07-10 23:58

Hej, jag vill bara bekräfta att en ~/.inputrc med
set output-meta on
hjälpte mig att få åäö på terminalen, men jag får heller inte till schysst beteende i (min favoriteditor) vi. Jag kan skriva åöö men ÅÄÖ blir något annat ( ?~E ?~D ?~V ). Däremot sparas det rätt och man kan catta filen normalt efteråt. Har någon hittat rätt inställning för vi?

Jag kollade på tipsen här http://macvim.org/OSX/index.php ( ändra .vimrc och sätta LC_CTYPE) utan att lyckas.

Vad gäller själva Terminalen, så tänkte jag delge vad jag har för inställningar för att få vettig funktion på Home, End och Delete i Terminalen. Sorry Mac-folk, men jag - som ny switcher - kommer inte anpassa mig till Apples tolkning av Home och End.
I Terminalens "Window Settings" och "Keyboard" har jag ställt in
Home = CTRL+a (\001)
End = CTRL+e (\005)
Delete = CTRL+f CTRL+d (\006\010)

(Ännu ett tangentbordstips, någon sa att höger-alt + ctrl + + blir backslash men i mitt fall är det höger-alt + ctrl + 7 för att skapa backslash)

Trist meck sån't här... det är precis sån't här fixande och trixande jag hoppades slippa med OSX!

Ursprungligen av anders5737:

Vad gäller själva Terminalen, så tänkte jag delge vad jag har för inställningar för att få vettig funktion på Home, End och Delete i Terminalen. Sorry Mac-folk, men jag - som ny switcher - kommer inte anpassa mig till Apples tolkning av Home och End.
I Terminalens "Window Settings" och "Keyboard" har jag ställt in
Home = CTRL+a (\001)
End = CTRL+e (\005)
Delete = CTRL+f CTRL+d (\006\010)

Det där behöver du väl inte ställa in? Så fungerar det redan i min Terminal utan att ovanstående finns med i listan! CTRL-a, CTRL-e, men även CTRL-k och CTRL-y fungerar nästan överallt i Mac OS, utan att du behöver röra ett finger!

  • Oregistrerad
  • 2006-07-11 19:37

Erik, ja CTRL+a och CTRL+e funkar och det är det jag utnyttjar när jag vill få till att Home och End ska bete sig likadant. Jag använder Home och End ofta, vilket jag märkt nu när jag skaffat Mac!

1
Bevaka tråden