apache problem

Tråden skapades och har fått 4 svar. Det senaste inlägget skrevs .
1

håller på att testa lite perl via CGI men jag lyckas inte få apache att exekvera script som finns i min katalog ~/Sites/cgi-bin/
trots att jag tycker mig ha ställt in allt nogrannt och fint httpd.conf
---
ScriptAlias /cgi-bin/ "/Users/filip/Sites/cgi-bin/"

<Directory "/Users/filip/Sites/cgi-bin/">
AllowOverride None
Options ExecCGI
Order allow,deny
Allow from all
</Directory>

---

Ngn som på rak arm kan tala om vad jag kan göra åt problemet?
Jag hittar inga bra tips på nätet, har sökt 99mac´s arkiv så jag tänkte att det kankse finns ngn som kan dela med sig av sina erfarenheter...

  • Medlem
  • 2002-01-09 23:00

har du satt execute biten på skriptet ?

%chmod +x script.pl
%chmod +x script.pl

--
Jepp. Tyvärr...
Jag tycker bara att det är skumt

[ 10-01-2002: Meddelandet ändrat av: Filip Wänström ]

Om jag inte minns helt fel måste man göra följande i /etc/httpd/httpd.conf

Kolla att följande existerar och är avkommenterat :
LoadModule cgi_module libexec/httpd/mod_cgi.so
AddModule mod_cgi.

Kolla att scriptaliaset är som det skall:
ScriptAlias /cgi-bin/ "/Users/filip/Sites/cgi-bin/"

<Directory "/Users/filip/Sites/cgi-bin/">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

Kontrollera att cgi:er får köras genom att avkommentera till:
AddHandler cgi-script .cgi

Sedan är det bara att sätt rätt behörighet på scriptet och starta om Apache.

//Mikael

Hmm...
Oki. Det stämmer överens men vad jag skrivit. Jag har dock inte satt på

[b]
AddHandler cgi-script .cgi

[/b]
globalt eftersom jag inte vill ha cgi hantering påslaget i alla kataloger. Men efter lite mupplande och letande här och där så fick jag det att fungera genom att skriva följande:

[b]
<Directory "/Users/filip/Sites/cgi-bin/">
        AllowOverride None
        Options ExecCGI
        Order allow,deny
        Allow from all
        AddHandler cgi-script .cgi
 </Directory>
 

[/b]
Så nu fungerar det om jag lägger script i katalogen ~/Sites/cgi-bin/ men ingen annanstans. nice

1
Bevaka tråden