index.html funkar inte i underkatalog

Tråden skapades och har fått 7 svar. Det senaste inlägget skrevs .
1

Alltså, jag har en G5 med mac os x server på! jag har lagt till index.html, index.htm, index.php som sk default index files. Så att starsidan kommer upp automatiskt på hemsidan, så långt fungerar allt väl.

Problemet är att jag nu har en underkatalog på hemsidan (typ: mincoolawebb.se/smygsidan) ...där ligger en index.html. Den kommer man inte in på om man inte skriver hela url'en (mincoolawebb.se/smygsidan/index.html)

måste hitta en lösning!

de funkar å skriva med slash på slutet, alltså: mincoolawebb.se/smygsidan/
Men seriöst, den sista slashen ska man inte behöva skriva jue....

(OBS: webbadressen är fejk, men problemet verkligt)

Jag har samma problem och det hjälper inte ens att skriva den sista slashen.

  • Oregistrerad
  • 2005-10-15 11:15
Ursprungligen av LongSunnyDay:

de funkar å skriva med slash på slutet, alltså: mincoolawebb.se/smygsidan/
Men seriöst, den sista slashen ska man inte behöva skriva jue....

(OBS: webbadressen är fejk, men problemet verkligt)

Det är så dom flesta webbservrar fungerar, och det är så dom SKA fungera.

IMHO så borde det finnas mindre saker man kan irritera sig på ?

  • Medlem
  • 2005-10-15 12:16
Ursprungligen av LongSunnyDay:

de funkar å skriva med slash på slutet, alltså: mincoolawebb.se/smygsidan/
Men seriöst, den sista slashen ska man inte behöva skriva jue....

I egentlig mening innebär ett anrop på "mincoolawebb.se/smygsidan" att servern letar efter filen "smygsidan" i roten, vilken naturligtvis inte finns. För att servern ska veta att "smygsidan" är en mapp så behövs slashet på slutet.

En vanlig åtgärd är dock att om filen inte finns, kolla om det finns en mapp med namnet, och sedan låta servern generera en "301 Moved Permanently" med adressen till mappen. Webbläsaren kommer då fråga efter denna adress istället.

Har dock ingen aning om hur man aktiverar detta i Apache...

Prova att stänga av performance cache om du har på det. Det gör att det strular ibland när man skippar sista slashet.

stängde av performance cahe och körde stop service på web i server admin, sen start service... ingen skillnad. Känner den av den ändringen direkt???

har slut på ideer nu, har läst en del i apachemanualen men det jag hittat hjälper mig inte!

  • Medlem
  • Neverland
  • 2005-10-14 11:48

Någon serverspecialist är jag inte, och jag har bara pillat lite i experimentsyfte med webservern (osx server 10.3).

Jag fick liknande problem, men precis tvärtom. "permission denied" i rooten, men inte i undermapp.

Detta löstes snabbt genom att stänga av det förinställda sajten (Settings > Sites).

1
Bevaka tråden