cgi-bin permission strul..

Tråden skapades och har fått 5 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • International user
  • 2002-05-10 11:43

tjena,

jag är ganska grön på både UNIX och cgi men har klarat mig hyfsat hittils med enklare grejer. Nu har jag dock ett problem som jag ej kan lösa.

En kund har bytt webbhotell och jag har flyttat siten som använder afm.cgi för kontaktformuläret. Det nya webhotellet (som kör linux/apache) hade cgi-bin breve htdocs i strukturen. Eftersom htdocs var webroot kunde jag givetvis inte komma åt cgi-bin via http överhuvudtaget. På min begäran skapades en ny cgi-bin (med permissions 755) katalog i htdocs (jag hade ej behörighet att telneta in och får ej heller chmoda via ftp.)

Denna katalog går dock ej heller att komma åt via http, får bara access denied hela tiden. Till slut tjatade jag till mig SSH access, men får trots att jag gjort om allt ingen access utifrån (även efter chmod 777).

Vad kan fela? Jag kan tyvärr inte få ngn support från webbhotellet, de är halvt inkompetenta...

//mattan

  • Medlem
  • International user
  • 2002-05-10 14:45

Det är inte meningen att cgi-bin ska ligga i htdocs. Jag kommer inte exakt ihåg hur det ska ställas in, men så här står det i min /etc/httpd.conf

Citat:

quote: #
# ScriptAlias: This controls which directories contain server scripts.
# ScriptAliases are essentially the same as Aliases, except that
# documents in the realname directory are treated as applications and
# run by the server when requested rather than as documents sent to the client.
# The same rules about trailing "/" apply to ScriptAlias directives as to
# Alias.
#
ScriptAlias /cgi-bin/ "/Library/WebServer/CGI-Executables/"

  • Medlem
  • International user
  • 2002-05-10 23:13
Citat:

quote:Skapades ursprungligen av: kent:
Det är inte meningen att cgi-bin ska ligga i htdocs.

Jag tror oxå det, dessutom så har man väl oftast inte htdocs överhuvudtaget på en Linux burk, de e väl bara NT...?

Saken är den eftersom webbrooten pekar på htdocs måste ju scriptet ligga där för att överhuvudtaget ses via http, eller?

//mattan

  • Medlem
  • International user
  • 2002-05-10 23:18
Citat:

quote:Skapades ursprungligen av: kent:

Citat:

quote: #
# ScriptAlias: This controls which directories contain server scripts.
# ScriptAliases are essentially the same as Aliases, except that
# documents in the realname directory are treated as applications and
# run by the server when requested rather than as documents sent to the client.
# The same rules about trailing "/" apply to ScriptAlias directives as to
# Alias.
#
ScriptAlias /cgi-bin/ "/Library/WebServer/CGI-Executables/"

hmm, kan lösningen vara att göra ett alias av den cgi-bin katalog som ligger breve htdocs inuti htdocs? Ngn som kan ge mig UNIX kommandot för det?

//mattan

  • Oregistrerad
  • 2002-05-13 13:15

Ställ dig i htdocs-katalogen och skriv "ln -s ../cgi-bin

Nu sitter jag inte vid min privata burk och kan inte kolla, och med dåligt minne kommer jag inte ihåg om du kanske måste ha ./cgi-bin/ som andra argument, prova att lägga till det om det första inte fungerar.

Men även om objekten i den cgi-bin-katalog de skapade i htdocs-katalogen är 755 så måste den väl ändå ha rättighet att execa skript.
Skapa en fil .htaccess i cgi-bin-katalogen i htdocs-katalogen och skriv

Options +ExecCGI

Prova det här senare innan du försöker skapa ett alias av den cgi-bin som ligger utanför.
Eventuellt tillåter de inte .htaccess eller kanske under ett annat namn, då kan du prova att aliasa.

  • Medlem
  • International user
  • 2002-05-13 19:20

Tack Kim!

testade bägge din förslag utan framgång. Jag kommer inte in i cgi-bin katalogen i htdocs utifrån överhvudtaget trots chmod 777. Måste vara ngn låsning på server nivå (vad vet jag inte).

Samma access denied när jag gjorde ett alias.

Har nu bett dem att flytta upp webrooten en nivå. htdocs mappen är ju ändå helt onödig och förhoppningsvis funkar den cgi-bin mapp som var default (men på fel ställe) som den skall...

//mattan

1
Bevaka tråden