Bäst firmware för Linksys WAG54G? / Varför dyker routerfunktionen?

Tråden skapades och har fått 21 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2005-10-02 21:51

Snott från en annan tråd:
http://www.99mac.se/forum/showthread.php?t=42214

Ursprungligen av Samuel K:

Tycker jag definitivt att du ska göra! Med standardfirmwaren är de som vilken tråkig Netgear eller D-Link som helst (bortsett från den utmärkta räckvidden), men installerar man Sveasofts firmware får man tillgång till massor av kul funktioner som inte Linksys utvecklare orkade/fick implementera. Den blir lite som en kombinerad miniserver (som man självklart kan ssh:a in till och leka med ) och en liten super-router med kraftfulla finesser som t.ex. traffic shaping. Firmwaren är lätt att installera, och du hittar den gratis hos Sveasoft:

http://www.sveasoft.com/modules/phpBB2/viewforum.php?f=6

Är det fortfarande detta som gäller eller finns det bättre alternativ?

Jag frågar för min Linksys WAG54G har börjat bete sig underligt. Den har inga problem med att hålla sig uppkpplad mot Telia, men det lägger ganska ofta ner routerfunktionen, både på LAN-portarna och trådlöst. I synnerhet när man surfar mot den med ganska svag AP-signal.

  • Medlem
  • Göteborg
  • 2005-10-02 22:37

Du har säkert varit där och kollat, men jag tipsar ändå: http://www.linksysinfo.org/

mvh
b0bben

  • Medlem
  • 2005-10-02 22:49

Jag var där och vänder tidigare men gick tillbaka ett varv efter ditt tips. Det ser ut som om det skulle kunna vara en bugg i brandväggen, men jag vet inte. Jag hittade svensk fw på annat håll men vet inte om jag vågar installera. Då står jag där med telefonmodem om det skulle skita sig...

  • Medlem
  • Göteborg
  • 2005-10-02 22:55

Vet inte om det hjälper dig, men jag har moddat en WRTG p.g.a den sket sig om man körde stora filer mellan trådlöst<>trådat.
Ganska vanligt bland hemma-routers att reboota sig o sånt vid just sån filöverföring.

Vad jag gjorde är att jag klockade CPUn till 200Mhz på linksysen och sen funkar det. Det var ett känt fel ifs.

En annan router jag kör med nu (netgear) har samma problem, dock så blir den för varm och dör, den har jag moddat med fläns/fläkt så nu funkar den fint

mvh
b0bben

  • Medlem
  • 2005-10-02 22:57
Ursprungligen av b0bben:

Vad jag gjorde är att jag klockade CPUn till 200Mhz på linksysen och sen funkar det. Det var ett känt fel ifs.

uuh, det där låter som nåt jag inte törs ge mig på! Men nu har jag ny firmware, så vi får se om problemet försvinner. Tack så länge!

Ursprungligen av Baron:

uuh, det där låter som nåt jag inte törs ge mig på! Men nu har jag ny firmware, så vi får se om problemet försvinner. Tack så länge!

Kör du med Sveasoft nu eller? Har också WAG54G och har velat testa den. Rapportera gärna i den här tråden om du märker några konstigheter.

Själv kör jag fortfarande med en gammal sveasoft-build, men egentligen borde jag ha slängt in något nördigare i stil med OpenWRT Men sveasoft-firmwaren verkar bäst för hobbyister, i och med att den är "batteries included" med bra webb-gui och enkel installation. HyperWRT är också ett alternativ, den lägger inte till just så mycket annat utöver originalfirmwaren än att man kan justera sändarstyrkan. Annars kan man alltid kolla in http://wrt54g.net där man hittar en bra förteckning över firmwares.

  • Medlem
  • 2005-10-03 12:34
Ursprungligen av Samuel K:

Annars kan man alltid kolla in http://wrt54g.net där man hittar en bra förteckning över firmwares.

Funkar samma fw till WRT54G som till WAG54G?

Ursprungligen av Baron:

Funkar samma fw till WRT54G som till WAG54G?

Ska jag vara ärlig så vet jag faktiskt inte. Den är ju i princip samma produkt som en wrt54g förutom adsl-modemet, men jag misstänker att just den biten skulle kunna orsaka en del problem. Har försökt googla fram något utan att hitta så mycket, så det kanske är bäst att vara på den säkra sidan och hålla sig till originalfirmwaren (kör du på senaste versionen förresten?).

  • Medlem
  • 2005-10-02 23:02

Jag fick ganska mycket snabbare uppkoppling med ny fw (eller för att brandväggen är avstängd). Jag testar med http://80.88.96.102/ lite snabbt och får nu 5,6-6 Mbps i st f runt 5 för 20 minuter sedan på en Telia ADSL 8 Mbps-lina.

(Jag är inte så hemma på sånt här, men gissar att brandväggen kan sega ner uppkopplingen. Stämmer det?)

Ursprungligen av Baron:

(Jag är inte så hemma på sånt här, men gissar att brandväggen kan sega ner uppkopplingen. Stämmer det?)

Japp, en router kan mycket väl slöa ner anslutningen.

  • Medlem
  • 2005-10-03 11:31

Sveasoft kostar pengar nu för tiden. Jag hittade en svensk dist via linksysinfo.org. Jag har inte hunnit utsätta den för några egentliga påfrestningar än.

  • Medlem
  • 2005-10-03 11:36

Sorry, det var inte alls via linksysinfo utan på ett forum nånstans. Jag kan kolla i historiken hemma i kväll.

Det är väl inga problem om man sedan vill tillbaka till original-firmware? Kan man skada något om man testar andra?

Aaargh! Min linksys har fungerat klanderfritt mot Spray ADSL, men nu har jag bytt till Glocalnet och nu kan inte modemet hitta PPPoE-servern. Funkar med ett annat modem så uppkoppling finns.

Har bara provat Linksys egna firmware 1.01.6 samt 1.02.7 men ingen funkar.
Har du filen för din svenska firmware, Baron? Du skulle väldigt gärna få skicka den till mig så jag kan testa.

johan.arvidsson (snabel-a) mac.se

Jag har inte vågat ladda in något som inte uttryckligen är för just WAG54G. WRT54G har ju som sagt inte ADSL-modem och det är ju just det jag har problem med. Min router-funktion är lika bra som alltid.

  • Medlem
  • 2005-10-05 23:08

Jag skickar genast. Men min erfarenhet är lite tvivelaktig... Jag har ännu sämre router nu än tidigare, måste starta om den en gång i timmen. Och jag har inga svenska menyer så jag vet inte vad som är svenskt. Men jag kanske måste resetta den helt först innan det tar skruv. Jag har hittat en annan som jag också ska testa. Jag mailar båda.

http://www.linksysinfo.org/modules.php?name=News&new_topic=68

Fick ditt mail, tack.
Tyvärr är det där Linksys egna som jag redan testat. Tack ändå.

Alla fw finns här:
ftp://ftp.linksys.com/international/firmware

  • Medlem
  • 2005-10-06 10:03

Trist. Har du nån bra fw du kan dela med dig av, eftersom jag inte har klanderfri funktion trots att jag har adsl (Telia)?

edit: tar bort e-postadress.

Senast redigerat 2005-10-06 12:41

Jag har sedan jag köpte min använt den förinstallerade Linksys 1.01.6 som finns på deras FTP. Den filen heter t.o.m. SE för Sverige så den är anpassad för vårt nät men jag får inte igång det. Har mailat Linksys om hjälp.

  • Medlem
  • 2005-10-06 21:08

Visst är det AnnexA man ska ha?

Ursprungligen av Baron:

Visst är det AnnexA man ska ha?

Japp. Det står det på min kartong i alla fall. Jag tror Annex-B är någon slags ISDN-variant.

Nu är det några dagar sedan jag mailade Linksys. Som vanligt så är det svårt att få någon reaktion på ett mail från större företag :(.

  • Medlem
  • Malmö
  • 2005-10-06 23:37

Jag skulle vilja passa på att rekommendera dd-wrt. Använder denna firmware på min wrt54g och den är verkligen kung!

Citat:

DD-WRT is also reported to work on the WAP54G, but your mileage may vary.

I senaste betan (v23 beta1 i skrivande stund) har man stöd för WPA2 och lite annat lullull. [ironi]Vad sägs om möjligheten att höja effekten på antennerna tillräckligt för att flyttfåglar ska börja flyga fel? [/ironi]

1
Bevaka tråden