Permissions Apache default directory...

Tråden skapades och har fått 10 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2003-01-30 01:40

Har inte lyckats hitta något sätt att lösa problemet att kunna serva mjuklänkade dirs på mac os x...

Verkar ju vara någon Apple special magi. Testade runt med en text fil. Alla permissions ok. lägger den i Webserver/Documents = Ok, skriver ex. > ln -s ~/Dev/test/ testar och lägger filen där resulterar i 403 permissions denied.

Detta verkar ju som sagt inte ha med apache att göra. Provade t.ex. att köra en ny Location alt. ett alias i httpd confen. Samma problem där...

Några idéer!?

  • Medlem
  • Stockholm
  • 2003-01-30 09:41

Jag är inte 100 på hur det här funkar, men i httpd.conf så börjar man ju med att blockera åtkomst till hela filsystemet, därefter öppnar man upp webb-roten och användarnas webbkataloger. Så det funkar väl inte att lägga filerna någon annanstans om man inte öppnar upp den platsen också på samma sätt.

  • Oregistrerad
  • 2003-03-17 17:27

tja,

<Directory />
Options FollowSymLinks

borde ju göra att man får ha länkar till andra dirs.

har groups.googlat en del men inte hittat något annat än folk med samma problem...

  • Oregistrerad
  • 2003-03-24 01:11

Inga tips!?

Har sökt utav bara katten på groups.google o.s.v. utan direkta lösningar.

  • Medlem
  • Stockholm
  • 2003-03-24 11:26

Har du kollat så att rättigheterna på katalogen och filen gör att apache kan komma åt filen?

/glemme

  • Oregistrerad
  • 2003-03-24 12:34

Rättigheterna är ok. Men borde får det inte att lira ändå. Borde iofs ha med någon rättighet att göra.

Tror faktiskt det måste vara något mystiskt apple special som gör att man inte kan konfa det enkelt...

Läste på nåt ställe att man var tvungen att använda sig av den netinfo manager. dock ingen lösning på hur..

glemme,

har du så att du kan köra utanför Webserver katalogen?

  • Oregistrerad
  • 2003-03-26 17:28

Har kört lite uteslutningsmetod nu.

skapade en mapp "test" direkt under os x hdn. alltså intill System, Users o.s.v.

[:/Library/WebServer/Documents] $ ln -s /test/ bosse

surfade in på localhost/bosse utan problem

men försöker man då samma mot en mapp i sitt hemdir
[:/Library/WebServer/Documents] $ ln -s /Users/snoken/Dev/test/ bosse2

så resulterar det i Forbidden i apachen...

börjar fundera om det är något magiskt Apple stuff som spökar. Typ att Users mappen egentligen bara är en mjuklänk i sig..

  • Medlem
  • Stockholm
  • 2003-03-27 11:44

Testa att lägga in följande i httpd.conf (efter <Directory "/Library/WebServer/Documents">...</Directory>):

<Directory /home/*/Sites>
  Options +FollowSymLinks
</Directory>

Kolla bara att du inte redan har någon aktiv <Directory /home/*/Sites>...</Directory>
Fast du har kanske redan testat?

  • Oregistrerad
  • 2003-03-27 12:01

vad gör plusset före FollowSymLinks?

jag frå ju mjuklänkar o funka överallt förutom i Users/username/* med undantag för den förspecade Sites...

Och Sites har ju inga andra rättigheter vad jag kan se. Så förstår inte varför det är så lurigt att göra en Dev mapp sida vid sida om sites i sitt home dir..

  • Medlem
  • Stockholm
  • 2003-04-02 01:55
Citat:

Skrevs ursprungligen av Snoken
vad gör plusset före FollowSymLinks?

Det betyder lägg till alternativet FollowSymLinks men ändra inga andra alternativ som eventuellt redan är satta. Det kanske inte var så relevant i det här fallet egentligen...

Snart dags för nån riktig Apache-guru att uttala sig tycker jag...

  • Oregistrerad
  • 2003-04-02 02:19

för å vara petig så behövs ju inte något plus såvida man inte vill blanda options, t.ex.
-FollowSymLinks +Indexes

Tror faktiskt inte det är något konfigurations trick i apache confen.. Jag får det ju funka med både Alias & mjuklänkar till alla paths utom sådana som finns i min hem-mapp...

ger mig tusan på att det är nåt med netinfo managern som ska till. verkar inte finnas några som helst instruktioner hur man ska använda denna, tips någon?

men det ligger iaf en hårdkodad path till Webserver mappen där i. Problemet är iofs att det är ens home-dir som behöver utökade rättigheter, men hur..

1
Bevaka tråden