Intrikat nätverksproblem

Tråden skapades och har fått 8 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2002-09-24 16:30

Har nyligen installerat ADSL Breband i ett nätverk. Windowsmaskinerna funkar utan problem men vår enda Mac har vissa uppkopplingsproblem.
Uppkopplingen går via en 10/100-switch till en kombinerad router/adslmodem (Surfinbird). Jag kör med ett internt svartnät med fasta ipadresser. Vid kontroll av bredbandet via tptest visar Macen endast 5-12 kbit på tcp-mottagning om det ens går att få nån anslutning där, dvs det är en hel del packetloss. Däremot får jag vid tcp sändning 600 kbit vilket är max för anslutningen. Sändning UDP ger 600 kbit och mottagning UDP ger 1000kbit.

TCP mottagning är alltså flaskhalsen vilken borde ligga optimalt på 1000kbit(det gör den på windowsmaskinerna). Vi kommer alltså kanppt ut på nätet alls via macen, surfa hämta epost osv.

Jag har kontaktat telia och routertillverkaren men båda säger sig inte veta något om problemet. Routertillverkaren känner heller inte till några inställnigar man skulle kunna göra i routern.

Någon som har förslag på var man kan börja felsöka? TCP/IP-inställningarna är rätt gjorda med routern som gateway osv.

Som ni säkert förstår så är jag inte direkt insatt i MacOS så all hjälp mottages tacksamt.

Datorn har MacOS 9.2 installerat.

Kan bli svårt att hitta felet, men för att börja någonstans:

Om det är en Mac med PCI-platser (alltså ingen bärbar eller iMac/eMac), kan det vara värt att sätta i ett tredje-parts nätverkskort och prova.

  • Medlem
  • 2002-09-24 19:14

Kan man då sätta i vilket PCI-nätverkskort som helst, bara man har drivrutiner?

Finns det ingenstans man kan ställa in half/full duplex och ändra andra värden på det inbyggda nätverkskortet?

Kom på att det finns nåt program "DAVE" installerat som kommunicerar med nätverksprintern. Kan det vara det som strular?

Hittar ju inte ens nån aktivitetshanterare där man kan stänga av igångkörda program etc.

Är som sagt helt ny på MacOS.

[ 24 September 2002, 19:19: Meddelandet ändrat av: Cmart ]

Ett vanligt problem är att tcp/ip inställningar "pajjar", du kan kasta dem och ställa in det på nytt, det kan lösa problemet - filen finns i program inställningar

/Johanw

"Kan man då sätta i vilket PCI-nätverkskort som helst, bara man har drivrutiner?"

Ja, om drivrutin finns för Mac OS.

"Finns det ingenstans man kan ställa in half/full duplex och ändra andra värden på det inbyggda nätverkskortet?"

Nej, det går inte, endast med vissa tredjepartskort.

"Kom på att det finns nåt program "DAVE" installerat som kommunicerar med nätverksprintern. Kan det vara det som strular? Hittar ju inte ens nån aktivitetshanterare där man kan stänga av igångkörda program etc."

Du kan ju prova att stänga av Dave (och annat som kan störa), genom att klicka på äpplet längst upp till vänster, välja Inställningar -> Tilläggskontroll. I rullgardinsmenyn, välj "Grundläggande MacOS", och starta om. Du kan behöva konfigurera om tcp/ip-inställningar igen, efter detta. Testa uppkopplingen, och se om det blir någon förbättring. För att återgå, välj "Min profil" i menyn, och starta om igen. Tilläggskontroll är en slags aktivitetshanterare, där man kan stänga av drivrutiner, mm.

[Edit: stavfel och dålig formulering. Trött idag :rolleyes: ]

[ 24 September 2002, 20:18: Meddelandet ändrat av: Mattias A ]

Visst går det att tvinga Ethernet farten i OS X. Man gör detta med ifconfig i terminalen.
Tyvärr försvinner inställningarna vid omstart. Det finns också en hel del andra problem med NIC och Switchar. Tumregeln är att datorn (NIC) och Switchen skall stå likadant. Övervakade switchar har ofta problem med detta.
Hur som helst, kolla manualen för ifconfig i terminalen.
Alltså, man ifconfig i terminalen

  • Medlem
  • 2002-09-25 14:36
Citat:

quote:Skapades ursprungligen av: johanw:
Ett vanligt problem är att tcp/ip inställningar "pajjar", du kan kasta dem och ställa in det på nytt, det kan lösa problemet - filen finns i program inställningar

/Johanw

Ajaj...nu var jag inne i systemmappen och tog bort en fil som heter tcp/ip och efter det finns inte tcp/ip-intsällningarna längre. Hur får man tillbaks dem?

  • Medlem
  • Bollnäs
  • 2002-09-25 16:21

Tror den här tråden ska ligga under Classic, men bortsett från det:

Allt som ligger i mappen "Inställningar" i systemmappen är separata program. Tar du bort ett sånt och kastar det så är det borta. Enda sättet att få tillbaks det är 1. Installera om systemet/uppdatera systemet 2. Kopiera filen från en annan mac med samma systemversion.

En sak som kan hända (jag har varit med om det när det gäller skrivare) är att nätverkskortet kan ha pajat. Gör det det så brukar det antingen spruta ut en massa skit på nätverket, och då kommer all nätverkstrafik att bli seg. Eller så kan farten minska drastiskt, men tapp av nätverkskontakten som följd.

Jag instämmer med tidigare talare att det är bra att testa med ett nytt nätverkskort. Kolla på tex www.macoteket.se vilka som har drivrutiner till mac.

  • Medlem
  • 2002-09-26 12:51

Ja, verkar som ni hade rätt. Det funkade inte i MacOS 10 heller på den burken så det måste helt klart vara något hårdvarufel. Testade med en inlånad powerbook och allt flöt fint.

Ny dator kommer i eftermiddag!

Tack för all hjälp.

1
Bevaka tråden