Kursiv text blir helt galen i Safari

Tråden skapades och har fått 18 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2005-07-29 00:12

Tittar jag på tex den här sidan ser jag väldigt konstiga kursiveringar. Varför?

http://www.renault.se/web-org/personbilar/bilhallen2.asp?b=9

Det är samma sak med citerad text på offtopic.se, fast inte här eller på 99mac.

edit: det fungerar fint med Firefox.

Det är nog dags att rensa fontcachen. Ladda hem Fontfinagler som gör detta bäst. Stäng av programmen, rensa och starta om datorn.

  • Medlem
  • 2005-07-29 18:43

Tack tack, det gjorde susen.

(Det ska förstås stå "bold.se" i stället för "99mac" i första inlägget.)

  • Medlem
  • 2005-07-29 21:59

Nu är problemet tillbaka. Kan man kasta alla filer i hd/Bibliotek/Caches/com.apple.ats utan vidare eller finns det nåt däri man måste spara?

  • Medlem
  • 2005-07-30 15:37

Nu har jag även gjort allt som Font Doctor föreslår, men problemet kommer lik förbannat tillbaka. Vad är detta?

Det kanske finns en konflikt med i bilden? Det är Helvetica Bold Oblique den ritar upp i min Safari (se bild) dvs båda dina bilder är fel. Din vänstra bild är fetkursiv med på carbonkratiska. Den högra är rätt språk men inte fetkursiv.

Om du kopierar texten till Texthanteraren. Hur ser den ut då och vilket typsnitt säger den att det är? Har du fler Helvetica installerade?

_

  • Medlem
  • 2005-07-30 15:55

Jag ska kolla alla användare så snart Cocktail har gjort sitt. Jag återkommer strax.

(Jag trodde Font Doctors förslag på utrensning av dubbla typsnitt skulle räcka...)

Det är hursomhelst något tokigt med kodningen av stilen på sidan. Webbläsarna visar den helt olika så vad som är rätt är svårt att säga. Safari verkar dock tycka att fetkursiv är rätt.

Firefox: kursiv
Netscape: kursiv

Safari: fetkursiv
Omniweb: fetkursiv

Opera: fet
iCab: fet

  • Medlem
  • 2005-07-30 16:31

Klistrar jag in texten i Textredigerare står det "Nya Renault Scénic" i Helvetica Bold Oblique, 20 p. Jag har kastat några varianter av Helvetica jag snubblade på, men lät dem i OS9:s systemmapp ligga kvar. De kan väl inte spöka här?

Helvetica oblique i citaten på Offtopic.se fungerar inte heller.

Svårt att svara på men gör så här. Ut med alla Helvetica utom en. Rensa fontcache och starta om. Funkar det då kan du börja plocka tillbaka typsnitt.

  • Medlem
  • Karlstad
  • 2005-07-30 21:31

Hela sidan är ett skämt, och den som gjort mästerverket borde få sparken.
För det första saknar den en Doctype declaration, för det andra character encoding. Därför vet inte webbläsarna hur fan dom ska tolka koden, och inte vilket character set (vad det nu heter på svenska) som ska användas. Tro på fasen att det blir skit i olika läsare.

Dessutom har klantarschlet stavat fel till "absolute", lagt kod norr om <html> plus en massa annat smått och gott.

Kolla CSS valideringen här och html valideringen här och kolla gärna in koden....

Så du ska nog inte behöve rensa fontcachar alls. Det är ju sidan som är fel.

  • Medlem
  • Karlstad
  • 2005-07-30 21:55

PS: För övrigt kan ni ju kolla in den javascript-drivna, överjävliga sniffern som är tänkt att leverera olika stylesheets till femtielva olika webbläsare. Jag kan knappast tro att den funkar särskilt bra, i synnerhet som man kan ställa om läsarnas user agent hur man vill nuförtiden...

Sidan är ett skämt. De där validatorerna bara öser ur sig felkod även på huvudsidan renault.se.

Jag tror ändå Baron har strul med typsnitten på något sätt eftersom han ser problem på andra ställen också.

  • Medlem
  • 2005-07-31 01:24

Jag har lokaliserat problemet och löst det åtminståne temporärt: det var några Helveticavarianter i OS9:s systemmapp som krånglade. Nu fungerar både renault.se och offtopic.se.

Men jag begriper inte varför hela systemet gjorde sig beroende av ett typsnitt i den systemmappen?! Och jag vet heller inte om det är fel på de aktuella typsnitten eller om det bara var en konflikt, även om jag inte kan hitta några dubletter av de aktuella Helveticafonterna.
Den som känner sig personligen intresserad kan hämta hem de fyra typsnittsfiler (packade i 1 st .stix à 188 kb) och kika på dem för att se om någon är korrupt.
www.ljunghall.nu/dayna/Helvet.sitx
Jag lyssnar gärna på den som tar reda på det, men är mycket nöjd med den hjälp jag har fått. Tack Anders!

Danne V, det var nog inte fontcachen, som du mycket riktigt säger, men jag hade ändå ett typsnittsproblem.

  • Medlem
  • Karlstad
  • 2005-07-31 11:23

Täpp, Baron:

Bra att orsaken var lokaliserad.
Baskat ofta typsnittproblem i Macen, tycker jag....

  • Medlem
  • 2005-07-31 12:29

Jag tror det är första gången jag har drabbats på allvar sedan jag började använda mac, typ innan multifinder fanns...

  • Medlem
  • Stockholm
  • 2005-10-12 13:00

Tar upp denna gamla tråd. Har samma problem i Safari i 10.4.2 (senaste uppdateringarna). Vissa sajters kursiver visas konstigt. Tex MacPro. Men om jag kopierar texten och klistrar in i tex Textredigeraren så blir den läslig direkt, trots att typsnittet ser likadant ut.

Har försökt följa råden. Ibland funkar det att avaktivera typsnitt (tex helvetica Neue) och rensa cachen, med tex Font Finagler men efter en dag eller två så är problemet tillbaka och verkar nu handla om ett annat typsnitt. Senast Helvetica Bold Oblique och Courier Oblique.

har dessutom hittat samma fel i html-sidor som kommit och visas i Mail. Fast där är det nu Courier som ger konstiga kursiver.

Har fått känslan att det kan ha med om programmen som läser använder Cocoa eller Carbon. Textredigeraren (där allt funkar) är väl helt Cocoa eller? Medans Safari och mail är nån sorts mix. Dessutom är det ju bara kodningen på vissa websidro som blir feltolkade. Tex ovan nämnda Renault-sida, och MacPro. Och inte i Textredigeraren eller Firefox. Antagligen är det en bug i nåt html-tolkningsbibliotek i systemet. jag kan ha fel, och det spelar egentligen ingen roll. jag vill ha en permanent lösning på symptomet. Nån som vet? Finns några referenser till detta fel på nån suppport eller apple-sida? Mer info? Tacksam för alla idéer!

  • Medlem
  • 2005-10-12 20:09

har du en classicmapp med typsnitt i? Zippa den och kasta originalet och se om det fortfarande krånglar. (Det hade iaf jag försökt.)

  • Medlem
  • Stockholm
  • 2005-10-19 13:50

OK men problemet är att jag har ett par program som bara funkar i Classic. Och som inte kommer att uppdateras.

1
Bevaka tråden