gcc 2.95 till tiger?

Tråden skapades och har fått 6 svar. Det senaste inlägget skrevs .
1

Hej,
har någon sett några paket för att installera gcc 2.95 på en ren tiger burk? De paket som följde med xcode 1.5 går inte att installera på 10.4 (av någon bra annledning anntar jag). Eller det är bara att tanka källkoden och ta en tupplur medans den kompilerar?

mvh, Mathias

  • Medlem
  • 2005-06-28 11:55

Fink kanske kan hjälpa dig

http://fink.sourceforge.net/
http://fink.sourceforge.net/pdb/package.php/gcc2.95

Du slipper antagligen kompilera iaf.

Kollade med både open darwin och fink utan någon framgång. Fink har ett paket men det är virtuellt paket (symlänkar?) till den gcc som följer(följde ) med apples verktyg.

  • Medlem
  • Mölndal
  • 2005-06-28 12:41

Är det just 2.95 du måste ha? Annars finns ju XCode 2.1 på ADC att ladda hem. Där följer med några olika gcc, men jag är osäker på numrena.

ja det är just 2.95 som är problemet, xcode 2.1 innehåller 3.1, 3.3 och 4.0 om jag minns rätt. Runt Tiger så gick de upp några versioner och skrottade den riktigt gammla 2.95. Jag har dock några symbian hack som kräver 2.95 för att kompilera tyvärr.

  • Medlem
  • 2005-06-28 15:01

Det verkar som att man kan installera det individuella paketet med 2.95 från xcode 1.5. Antar att du har koll på hur man gör det.

klippt från
http://www.microbiol.unimelb.edu.au/staff/mds/ARB_OSX/ARB_to_MacOSX.html
"There is a slight complication in that ARB requires gcc2.95.2 to compile, and this isn't installed on Tiger, and is an optional install on Panther. You either need to erase the gcc2 specification in the arb.info file (edit it out) or install gcc2.95.2. I did the latter by using the Xcodes disc from Panther, finding the gcc2 package installer, and individually installing that. You can check its presence in Terminal with the command 'gcc2 -v' and it should state the working version of gcc2 installed."

Jag försökte ett tag med just 1.5 paketet utan att lyckas, version 1.5 har en check om du har en os version över 1.3 och installerar inte programet därvid. Jag anntar att det bara är en fråga om att ändra versions nr i någon property list någonstans.

Däremot Behöver du inte göra något med installern som följer med 1.2. Nu återstår det att se om den fungerar ok med tiger

1
Bevaka tråden