Numlock?

Tråden skapades och har fått 7 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2002-03-08 20:20

Hej!

Är jag ensam om att ´Numlock´ inte fungerar i Terminalen??
(eller överhuvudtaget!).
Visst, lampan lyser upp på tangentbordet men ger ingen effekt.

Noterade detta när jag skulle spela nethack .
Det gick helt enkelt inte att styra @ med nummertangenterna
som man är van vid..

Hur aktiverar man numlock på riktigt eller är det fortfarande så att
terminalen i Mac OS X har massa obskyra buggar kvar(som ex. att ÅÄÖ _vägrar_ fungera i terminalen oavsett vilken tecken tabell man ställer in).
---
/Samuel

Numlock-problemet vet jag inte hur man ska lösa, det överlåter jag i all min lathet åt någon annan

Däremot vet jag varför svenska tecken inte fungerar. Det är inte alls någon bugg i terminalen, ingen skugga på Apple i detta fall, utan det beror på den variant av tcsh som finns i Mac OS X. Den varianten klarar nämligen bara 7-bits ASCII, så "konstiga" tecken som å, ä och ö får inte vara med. Märkligt nog är åäö inget problem på de flesta andra OS som använder tcsh, men det shellet finns förmodligen i ett otal varianter.

Jag har iofs inte provat att dra hem och kompilera upp en annan version av tcsh, men har man behov av att kunna skriva svenska tecken går det att byta shell (antingen tillfälligt eller permanent). OS X har två förinstallerade shell som klarar svenska tecken, nämligen sh och zsh. Prova att starta zsh och skriva lite svenska tecken så får du se!

[ 09 Mars 2002: Meddelandet ändrat av: Samuel Kvarnbrink ]

  • Oregistrerad
  • 2002-03-09 11:17

Tack för den..

Det verkar dock bara fungera ´sådär´.

Alltså starta nått av de skal som nämnts (zsh eller sh)
Starta ex. pico, spara en fil med ett namn som innehåller
ÅÄ(Ö fungerar inte av nån ugrundlig anledning) och filen
får ett skummt filnamn...

Egentligen fungerar ÅÄÖ i de ´program´ man kör i skalet
(ex. Telnet, Pico osv) men inte när man skall utfärda kommandon,
det är _det_ som jag stör mig på..

Får väl skippa ´nethack´ och köra ´dungencrawler´ istället för
den fungerar bättre och är inte så beroende av att ´numlock´ fungerar..
---
/Samuel

  • Medlem
  • Stockholm
  • 2002-03-09 15:03

Fråga...
Jag har en rc.mine-fil (Ok, jag har en del alias i den också), kan jag använda samma fil till de andra "shellen" om jag flyttar över dem till tex ~/library/init/sh/ ?
I min rc.mine-fil har jag skrivit in lite "kåd" (Vet inte exakt vad det heter) som förändrar utseendet av prompen. ex:
set prompt="%{33[0;1;32m%}[%{33[31m%}%P %n%{33[31m%}%{33[31m%} %c3%{33[32m%}]%{33[0m%}%# "

Ändra bara String Encoding i Terminal Preferences till ISO Latin 1.

  • Oregistrerad
  • 2002-03-09 17:26
Citat:

Skapades ursprungligen av: Patrik Skulski:
Ändra bara String Encoding i Terminal Preferences till ISO Latin 1.

Det hjälper inte!
Tydligen är det tcsh som inte har stöd för ÅÄÖ då det
funger sådär i zsh och sh..(Det blir rätt bokstäver i skalet
men ´Finder´ tolkar inte dem på rätt sätt).

ÅÄÖ fungerar som sagt i de ´program´ man kör i skalet(tcsh)
men inte annars..
---
/Samuel

Byt shell då.

Körde Bash ett tag själv, är vad vid det, men det visade sig att saker och ting inte riktigt funkade som det skulle då. Så jag bytte tillbaka till tcsh.

Har faktiskt inte ens märkt att ÅÄÖ inte funkar.

Kör amerikanskt system och använder knappt svenska i filnamn och dylikt.

  • Oregistrerad
  • 2002-03-09 20:27

Naah..

Byta skal orkar jag inte, har man vant sig vid ett skal
så är det svårt att byta.(Det är ungefär som att be
nån byta fönsterhanterare ex. från KDE till Gnome).

Jag har inte heller många filnamn med åäö i men
nog skall det fungera ändå tycker jag...

Att kopplingen skal<->finder inte är 100% är nästintill oförlåtligt..
Alltså har jag en mapp i finder som heter ´bös´ så skall det even
synas i skalet. istället för ´bo??s´
---
/Samuel

1
Bevaka tråden