XHTML: vit linje under bild i IE6

Tråden skapades och har fått 8 svar. Det senaste inlägget skrevs .
1

Jag håller på att konvertera en tabell-layout till XHTML och det har väl gått bra, men en underlig vit linje under vissa bilder syns i IE6 (funkar fint i Safari och Firefox Mac och Win).

Bild finns här.

Sidan kan beskådas här.

Jag vill minnas att den inte fanns där innan och jag har mig veterligen inte ändrat något i koden som borde påverka det.

Någon som har en idé om vad det kan bero på?

/Michael

  • Medlem
  • Stockholm
  • 2005-06-17 09:19
Ursprungligen av Michael Nord:

Jag håller på att konvertera en tabell-layout till XHTML och det har väl gått bra, men en underlig vit linje under vissa bilder syns i IE6 (funkar fint i Safari och Firefox Mac och Win).

Bild finns här.

Sidan kan beskådas här.

Jag vill minnas att den inte fanns där innan och jag har mig veterligen inte ändrat något i koden som borde påverka det.

Någon som har en idé om vad det kan bero på?

/Michael

Bilden har linjen men inte sidan hos mig ?

Och du tittar med IE6 (WinXP, SP2)?


Michael

  • Medlem
  • Stockholm
  • 2005-06-17 11:12
Ursprungligen av Michael Nord:

Och du tittar med IE6 (WinXP, SP2)?


Michael

Sry

- Safari 1, och Safari 2,

Läste inte hela inlägget, har tydligen hjärnan i en påse brevid skrivbordet

Om det verkligen är en border så kan du ju prova att lägga til ldetta i CSS:en

#submenu img {
	border: 0;
	text-decoration: none;
}

Men om det bara är ett tomrum under bilden (mer troligt) så skulle jag göra såhär:

#submenu {
	//position: relative;
	//float: right;
	position: absolute;
	// background: #fff; <- bort med den
	top: 0;
	//margin-right: 140px;
	left: 630px;
	width: 270px;
}
  • Oregistrerad
  • 2005-06-17 11:14

Byt

<div id="submenu">
  <img src="../images/img_business.jpg" alt="Business image" />
</div>

mot

<div id="submenu"><img src="../images/img_business.jpg" alt="Business image" /></div>

dvs fimpa radbrytningarna.

Tack för svaren! jag har testat att ta bort radbrytningarna för att komma förbi IEs whitespace bugg utan framgång. Ska jag ge mig på Kallibans varianter också. Det är lite mycket kod i CSS:en där, mest för att jag har testat olika varianter för att bli av med linjen...

jag tippar på att det räcker att ta bord raden

background: #fff;

i #submenu

lätt som en plätt

OK, problemet löst! Det var den gamla whitespace-buggen (på curve-divven). Jag var säker på att jag kollat det innan, men...

Tack för all hjälp!

1
Bevaka tråden