Serverlogistics PHP

Tråden skapades och har fått 2 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Simrishamn
  • 2005-05-28 08:49

Min tanke var att jag skulle utvidga mina kunskaper i PHP-programmering, och därför sätta upp en liten webserver i min iBook för "lokalt bruk". Jag installerade Apache2, MySQL och PHP genom serverlogistics paket. Apache fungerade utmärkt, men inte PHP. Det går helt enkelt inte att generera sidor m.h.a PHP. Testfilen lyder:

<?php
    phpinfo();
?>

... vilket ju tyder på att PHP-sidan inte genereras, och Apache tolkar den som en textfil.
Vadan detta? Jag installerade med installationspaketet. PHP4-mappen skapas, och en PHP-modul inne i Apache2-mappen. Vad jag dock fick lägga till själv var pekarna på PHP-modulen i httpd.conf. Kan det ha med det att göra? Om de inte lades till av sig själv var det kanske något som gick fel.
Kan det hela bero på att jag försökt installera nämnda paket tidigare, men med de "riktiga" installerarna, och därför inte riktigt fått bort dem?

I vilket fall, hjälp emottages med stor tacksamhet!

  • Medlem
  • Stockholm
  • 2005-05-28 09:59
Ursprungligen av HannesP:

Min tanke var att jag skulle utvidga mina kunskaper i PHP-programmering, och därför sätta upp en liten webserver i min iBook för "lokalt bruk". Jag installerade Apache2, MySQL och PHP genom serverlogistics paket. Apache fungerade utmärkt, men inte PHP. Det går helt enkelt inte att generera sidor m.h.a PHP. Testfilen lyder:

<?php
    phpinfo();
?>

... vilket ju tyder på att PHP-sidan inte genereras, och Apache tolkar den som en textfil.
Vadan detta? Jag installerade med installationspaketet. PHP4-mappen skapas, och en PHP-modul inne i Apache2-mappen. Vad jag dock fick lägga till själv var pekarna på PHP-modulen i httpd.conf. Kan det ha med det att göra? Om de inte lades till av sig själv var det kanske något som gick fel.
Kan det hela bero på att jag försökt installera nämnda paket tidigare, men med de "riktiga" installerarna, och därför inte riktigt fått bort dem?

I vilket fall, hjälp emottages med stor tacksamhet!

Observera att när du installerat ServerLogistics Apache2 så har du TVÅ versioner av Apache installerat, båda med sin egen httpd.conf.

Serverlogistics httpd.conf hittar du i /Library/Apache2/conf

"Apples" Apache 1.3-installtion har sin httpd.conf i /private/etc/httpd/httpd.conf

Vet inte om det är det som är problemet, men jag gissar ju bara Se också till att det är RÄTT version av Apache som körs, serverlogistics apache kan du starta och stoppa med tilläggspanelen, apples är det bara och slå på webdelning.

/Kalle

  • Medlem
  • Simrishamn
  • 2005-05-28 13:03

Tydligen så var inte instruktionerna i configfilen inlagda, men det fungerade inte ändå

1
Bevaka tråden