Nergraderade PHP - nu kan jag inte ansluta till MySQL...

Tråden skapades och har fått 10 svar. Det senaste inlägget skrevs .
1

Jag körde PHP 5 men måste gå ner till PHP 4 för ett projekt.
Sagt och gjort och kanske slarvigt installerade jag PHP 4 från entropy.ch.

Efter detta kan jag inte ansluta till MySQL databasen från PHP scripten längre.
Vad hände?

  • Medlem
  • Varberg
  • 2005-05-20 11:53

Use the logs Luke!
Utan felmeddelanden blir det svårt att gissa..

  • Medlem
  • 2005-05-20 12:14

Vilken version av MySQL? Det är inte så att du använt mysqli för att ansluta (vilket är att föredra om MySQL 4.1)?

MySQL är version 4.1.11

Problemet med att använda loggen är att detta bara sker när jag ska ansluta mot MySQL via PHP.
Ska leta lite i loggarna så får vi se...

Det enda loggen säger efter detta är:
[error] PHP Warning: mysql_connect(): Client does not support athetication protocol requested by server; consider upgrading MySQL client in /Library/WebServer/Docuements/Projects/inc/dbconnect.inc on line 2.

Det värsta är att jag känner igen detta fel men kan inte komma vad det är jag måste göra...

Ser man på jag hittade svaret...
Alltså måste jag nerdradera MySQL också. Jäklar.

--

mysql_connect(): Client does not support authentication protocol

SUMMARY

Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client ...
Could not connect: Client does not support authentication protocol requested by server; consider upgrading MySQL client

INFORMATION

As of MySQL 4.1 there is a new authentication protocol. This authentication protocol is only supported by PHP 5 or higher.

So what you need to do is upgrade your PHP engine to PHP 5 or higher.

NOTE: We have found that PHP 5.0.2 (on Windows) comes with the 3.23.x client API. Try... PHP 5.0.3 for MySQL 4.1.x

Ahhhh det finns hopp... jag kan säga åt MySQL 4.1 att använda det gamla systemet... nu ska jag bara hitta my.ini... men var finns den då?
när jag kör:
sudo find / -name my.ini
hittar jag bara två och dessa ligger i Adobe Creative mappen (!).

  • Medlem
  • Varberg
  • 2005-05-20 13:50

Du kanske inte har någon my.ini, om inte MySQL hittar den används default-värden.

Okej... kan jag ladda ner en my.ini från nånstans då som är default?

Jag sket i allt och nergraderade MySQL också...
Då fick jag lära mig lite nya saker som att ta en mysql dump osv. Skönt på en fredag.

  • Medlem
  • Stockholm
  • 2005-05-20 23:18
Ursprungligen av Mattias Hedman:

Jag sket i allt och nergraderade MySQL också...
Då fick jag lära mig lite nya saker som att ta en mysql dump osv. Skönt på en fredag.

Om du hade läst mysql-referensen för det aktuella felet hade du upptäckt att allt du behövt göra var följande:

SET PASSWORD FOR 'some_user'@'some_host' = OLD_PASSWORD('newpwd')

...så hade problemet lösts

/Kalle

  • Oregistrerad
  • 2005-05-21 20:09
Ursprungligen av kalleh:

Om du hade läst mysql-referensen för det aktuella felet hade du upptäckt att allt du behövt göra var följande:

SET PASSWORD FOR 'some_user'@'some_host' = OLD_PASSWORD('newpwd')

...så hade problemet lösts

/Kalle

Precis Jag kör MySQL 4.11 och PHP 4 utan som helst problem. Kommer ihåg att jag fnulade med lösenord på något sätt

1
Bevaka tråden