Bäst nätverkssetup: 2 100Mbps Macar+Airport?

Tråden skapades och har fått 8 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • International user
  • 2003-01-26 15:34

Skulle behöva lite hjälp med att få bästa setupen på mitt hemmanätverk nu när jag köpt ny burk. Det ser ut som följande:

1 kabelmodem utan hub
1 Airport-basestation
1 PMG4 med Airport+10/100 Ethernet
1 PBG4 med Airport+10/100/G-Ethernet

Jag äger ingen 100Mbps-hub och det är lite mekkigt att dra nätverkskabel från skrivbordet till kabelmodemet.

Jag sitter och jobbar på heltid PBn och Powermacen e dator åt frugan och server/lagringsutrymme åt mig.

Vad jag eftersträvar är att kunna köra 100 Mbps mellan datorerna för att det skall gå snabbt på med mina mountade serverHDs men samtidigt att bägge Macarna skall kunna nå Internet så snabbt som möjligt samt (helst inte) vara beroende av att den "andra" burken är påslagen/närvarande.

Just nu kör PBn Airport mot kabelmodemet och delar ut Internet via kabel till G4an. Två brister med det: G4ans lina till Internet blir lite segare och om jag stänger av PBn så går G4an över på Airport och måste manuellt ställas om till att använda Ethernet igen så att den syns på nätverket.

Går det att konfigga så att burkarna använder Airport för Internet men Ethernet mellan varandra?

[ 26. Januari 2003, 19:29: Meddelandet ändrat av: mattan ]

Vilka tjäster vill du kunna utnyttja mellan burkarna? Räcker det med fildelning eller är det mer?

Kör du MacOS X på båda burkarna? Det bör i så fall gå att skapa ett VPN som gör att trafik till ett visst ip går genom Ethernet. Detta är inte helt enkelt att sätta upp men sök på IPsec och mac os x så hittar du kanske något.

[ 26. Januari 2003, 21:41: Meddelandet ändrat av: tompab ]

  • Medlem
  • International user
  • 2003-01-27 02:22

Nja, fildelning räcker iofs, men helst öppet på alla portar mot ett visst IP. Skall kolla in VPN. Tack.

Uppdatering:
hmm, kollade in VPN snabbt. Kan jag verkligen styra vilket Ethernet-interface som skall användas med VPN? Verkar mer som att jag skapar ett eget nätverk över vanliga Ethernet-interfacet.

[ 27. Januari 2003, 03:08: Meddelandet ändrat av: mattan ]

  • Medlem
  • Bollnäs
  • 2003-01-27 09:59

Någon får rätta mig om jag har fel, men jag har förstått att det fungerar på det här viset:

Osx klarar flera logiska och fysiska nätverk parallellt. Till exempel tre IP#, ett på airport och två på TP-sladd. Sen väljer osx att använda det snabbaste nätet vid överföring.

Exemplet ovan skulle kunna se ut så här: airportnätet maxar i 11Mbit och är kopplad till en basstation som i sin tur är kopplad till din router via 10Mbit-hub, och i sin tur är kopplad till ADSL-modemet.

Routern har ett 10Mbit-kort kopplat till ovan nämnda 10Mbit hub. Från hubben finns även en uplink till en 10/100Mbit switch där alla sladdar till ditt TP-nät är kopplade. Inklusive servern.

I det här läget har du ett interface igång på airporten i datorn. Den är inställd på dhcp från basstationen som i sin tur har ett internt fast IP.
På TP-kortet i datorn har du en adress (en0) som är fast som går via din router, och en (en1) som går på dhcp eftersom du ibland tar med datorn till en polare/jobbet där dynamiska adresser används.

Den här konfigurationen borde innebära att om du har datorn inkopplad hemma på ditt fasta nät mot servern så kommer du att använda 100Mbit i första hand. Har du däremot inte sladden i kommer airport istället att användas. Detta sker automatiskt, och är inget som du märker av. Däremot går det inte att ha nätverkssladden ikopplad, ha servern monterad och dra ur sladden. Eftersom den då är uppkopplad via nätverkskortet. Du måste montera om den för att få den via airport istället.

Hoppas jag inte surrade till det för mycket...

Vad jag förstår har du fullt fungerande Airportanslutningar, och vill nu ha raka rör med kabel mellan maskinerna.

Enkelt - gå bara till Network preferences och välj built-in ethernet. Ange IP-nummer 192.168.0.1 på den ena maskinen och 192.168.0.2 på den andra. Sätt nätmask till 255.255.255.0 på båda (och i den mån det behövs IP-numret som routeradress).

Ange sedan bara 192.168.0.1 (eller .2) när du kontaktar den andra maskinen.

Båda nätverksinterface är igång samtidigt, och ethernet väljs bara när du kör 192.168-adressen. Om något gränssnitt skulle krångla så kolla Network Port Configurations där du ställer in de olika gränssnitten. Kolla att både Airport och ethernet är ikryssade.

//Mikael

  • Medlem
  • International user
  • 2003-01-27 16:23

Tack för svaren!

I väntan på hjälp så pulade jag lite och testade faktiskt exakt misves lösning (trodde dock inte det skulle funka). Båda portarna öppna, Airport-porten på vardera burk får adress från basstationen via DHCP+NAT och Ethernetporten har fast IP 192.osv).

Funkade bra! Gick dock iväg från datorn i några timmar och nu hittar inte PBn servern längre, verkar som om den har glömt bort att 192 ligger på Ethernet eller så har servern glömt bort att dela ut på IP 192... (DHCP-adressen är det som syns i Sharing)

Servern syns i Öppna-rutan från PBn, men jag får antingen error eller timeout när jag försöker koppla upp mot den.

Verkar som setupen är känslig för viloläge/logout-login på endera datorn. Jag skall sätta bägge på att aldrig sova och se om jag tappar kontakten igen.

//mattan

Kolla så att Airportens DHCP inte delar ut adresser i samma adressrymd som Ethernetet går på; om du har 192.168.* på AP:n så kör 10.* på Ethernet eller vice versa. Praktiskt sett så går det, men eliminera alla felkällor. (Fel kan uppstå om t.ex. de fast adresserna inkräktar på utrymmet från de som delas ut med DHCP.)

Ett alternativ är att koppla bort att Airporten skall dela ut adress, utan istället bestämma den själv för varje dator. (Configure: Using DHCP with manual IP address alternativt Manually)

//Mikael

  • Medlem
  • International user
  • 2003-01-28 04:21

Ok, ny dag i Jakarta. Satte på servern som vart avstängd under natten. PBn har vart på. Servern syns i Kringla-K, men det är över Airport. Skriver jag in 192-adressen så blir det timeout. detta bekräftas när jag loggar in på servern då DHCP-IPt (10.0.1.2) syns under Sharing.

Startar om från början. Ny Location på bägge burkarna (kanske Automatic påverkar?) med Airport-porten över DHCP 1a, Ethernet manuell 2a. Allting funkar! Startar om servern, och det funkar fortfarande att logga in på 192. (DHCP-adressen syns fortfarande under Sharing på servern dock, verkar inte spela ngn roll)

misve: Jag har tidigare tänkt att assigna manuella adresser med DHCP, men vad jag kan se i Airport Admin så funkar inte det om man skall köra NAT vilket jag måste göra. Eller kan jag låta basstationen stå på DHCP+NAT och ändå välja adress i datorerna? (Jag har ingen router innan Airporten, utan den är direkt kopplad till kabelmodemet.)

Citat:

citera:Skapades ursprungligen av: mattan:
[Q] Ok, ny dag i Jakarta. Satte på servern som vart avstängd under natten. PBn har vart på. Servern syns i Kringla-K, men det är över Airport. Skriver jag in 192-adressen så blir det timeout. detta bekräftas när jag loggar in på servern då DHCP-IPt (10.0.1.2) syns under Sharing.[/Q]

Att du bara ser 10.*-adressen spelar inte så stor roll. Den kan ju bara visa en åt gången. Använd edit-knappen för att gå till Network och du skall ha IP-information både till Ethernetet och Airporten.

Citat:

citera:[Q]Startar om från början. Ny Location på bägge burkarna (kanske Automatic påverkar?) med Airport-porten över DHCP 1a, Ethernet manuell 2a. Allting funkar! Startar om servern, och det funkar fortfarande att logga in på 192. (DHCP-adressen syns fortfarande under Sharing på servern dock, verkar inte spela ngn roll) [/Q]

Jag tror inte automatic påverkar. Jag har det och det funkar finfint.

Citat:

citera:
[Q]misve: Jag har tidigare tänkt att assigna manuella adresser med DHCP, men vad jag kan se i Airport Admin så funkar inte det om man skall köra NAT vilket jag måste göra. Eller kan jag låta basstationen stå på DHCP+NAT och ändå välja adress i datorerna? (Jag har ingen router innan Airporten, utan den är direkt kopplad till kabelmodemet.) [/Q]

Jag är inte säker, men det torde inte vara något problem att köra med DHCP och utdelning av adresser. Det mest kritiska är att ha olika IP-nummerserier för Airport och Ethernet.

Däremot har jag tidigare (dock inte under 10.2) haft problem med att inställningarna inte sparas i panelen Network (med dock i "verkligheten"). Nu funkar det klockrent.

//Mikael

1
Bevaka tråden