Akut Kernel Panic problem med G4 MDD

Tråden skapades och har fått 11 svar. Det senaste inlägget skrevs .
1

(UPPDATERING PÅ PROBLEMET 25/3 2005 - se längst ned http://www.99mac.se/forum/showthread.php?p=527972#post527972)

Jag har nu ett akut problem. Har en G4 MDD (dual 1 ghz) som får kernel panics under uppstart eller några sekunder efter att datorn har startat upp.

Akut i och med att jag har en deadline imorgon bitti - och har ingen annan dator kraftfull nog att avsluta arbetet.

Så här ligger det till. Har i slutet av förra veckan börjat få Kernel Panics igen, senast var över 2 år sedan och då gick den in på service och en felaktig processor byttes ut (under garantitiden).

Så, i förra veckan så började jag få en KP så fort datorn gick ur vila efter att den stått i vila en längre tid (typ över natten). Så startade jag om datorn och fick ofta ytterliggare en. Men efter andra omstarten var allt oftast lungnt. Detta löste jag med att helt enkelt stänga av datorn under natten.

Under helgen så fick jag kanske 1-2 st, men alltid i början då datorn var ny påslagen.

Igår kom jag hem och skulle rendera en sak i After Effects och sen skicka iväg. Jag började med detta och får plötsligt en KP. Startar om. KP. Startar om. KP. Jaa ett tiotal ggr. Tänkte att pga av renderingen kanske det var ett värmeproblem - så tog ut hårdiskarna som sitter i de främre/undre platserna och efter det gick den prima hela dan, hela kvällen och halva natten. Inga problem

Nu kommer vi till problemet.

Idag på morgonen sätter jag på datorn, kommer in i systemet börjar jobba lite. KP. Shit. Startar om. Samma visa igen, bara nu börjar de komma tidigare, lite här och där, har även lyckats få när det visas endast det grå äpplet i början av uppstarten.

Har kört Apple Hardware test - den tycker att allt är bra - en sak att nämna är att det verkar omöjligt att få en KP när man startar från den skivan.

Har tagit ut minnena, kört med ett i taget - verkar inte vara fel där om det inte är så att båda har pajat samtidigt.

Har startat i Single-user mode och kört fsck -y, resulterar ibland i att a bilden inverterar, dvs det blir svart text och vit bakgrund - och så kommer man ner till en rad där den fastnar 'kernel: We are hanging here...' - vad betyder det?

Har försökt zappa pram, resulterar alltid i en kernel panic nästan så fort man slår på datorn.

Har försökt starta från olika CD skivor - Orginal Skivorna/Panther/Techtool/Diskwarrior.

Den gång jag hunnit se översta raden i kernel panicen (de varierar mellan den grafiska med de olika språken och den med en massa textrader. ) så var texten följande:
System Failure: cpu=1; code 00000004 (Corrupt Stack)

Betyder det att ngt är fel med CPU 1?

Finns det något sätt att stänga av ena processorn?

Hur resettar man logikkortet? om det går på denna dator.

Det känns nämligen som om KP'n dyker upp när fläktarna går igång. Lämnar man datorn på när KP'n kommit upp så går fläktarna upp i högvarv och låter nästan som en dammsugare efter ett tag.

Detta är dykt upp så plötsligt - och hade det hänt bara en dag senare hade allt varit lungt - men nu är det PANIK.

Har någon några tips på vad mer jag kan testa?

Om det är processorn som gått åt skogen, eller något annat som gör att datorn måste gå på service - vem finns då i Stockholmstrakten som kan fixxa detta snabbt - och förhoppningsvis bra pris?

Väntar på svar - inget annat att göra än att tänka ihop ngt om varför jag behöver extra tid till projektet.

/MVH abens (som hoppas på att vakna snart ur denna mardröm)

Senast redigerat 2005-03-25 15:59

Låter inge roligt.
Ska försöka ge dig lite ljus i mörket.

Det verkar vara två saker jag skulle lägga ner mer tid på:
1) Hårddisk pga av de fel du får med fsck.
2) Processorn.

Hela förloppet låter processor fel, men inte till 100%, kan vara diskfel också.
låter de/den nåt? har du kört DiskWarrior på den/de? Fick du några fel där?

Jag vågar inte säga mer utan vidare undersökning.
Men det låter inte bra det kan jag säga.

AHT - skivorna suger bara så du vet.

För att rädda din situation... du känner inte någon som jag hjälpa dig?
Montera ur hårddiskarna och åk till någon har en nog kraftfull dator.
Ring ÅFn och berätta, de kanske kan hjälpa dig med lånedator.

Känner du ingen är jag säker på att någon här på 99mac kan hjälpa dig med datorkraft.

Hoppas jag hjälpte dig något.

Tack, lite hjälpte det.
Nej har ingen som kan hjälpa mig som är hemma (sportlov här nere den här veckan). Det var vad den andra timmen imorse spenderades på efter all grundläggande tester...

Disken som systemet ligger på är inte gammal men välanvänd - så visst kan problemet ligga där.
Ska sätta in den i gamla G3'an och se om DW där kan hjälpa mig.

Men det borde inte bli en KP om man försöker starta från CD om det är hårddisken det är fel på, eller? Att skivorna suger vissta jag inte, har hjälpt mig att ha dem förrut - vad ärdet som suger med dem?

Nu har datorn fungerat i 16 minuter. Skriver tom detta inlägg ifrån den. Så har det varit varje dag, en massa krasher och sen tillsist fungerar det. Idag var det visserligen mellan 30 och 40 stycken som varade i över 4 timmar.
Hur många blir det imorgon? - Eller snarare så skiter jag i att stänga av tills den krashar. Nu är problemet bara att 2 hårdiskar och halva minnet blev kvar utanför datorn när den började fungera.

Kan Kernel Panic problemet bero på värmeskillnad mellan utanför och innanför datorn. Här uppe är det visserligen rätt varmt, men på golvet där datorn står är det inget vidare varmt på morgonen.

En teori här, är det möjligt?

Nu ska det jobbas på tills(om) det krashar. Får skrapa ihop lite pengar och köpa en mini som backup - så detta kan undvikas i framtiden.

EDIT: Datorn har fungerat nu i 24 minuter.

Diskwarrior säger att båda diskarna som sitter i nu är helt OK.
Men har lagt märker till att KP får jag precis när fläktarna börja spinna upp, när detta händer är lite olika, men när det händer kommer KP'n.

  • Medlem
  • Kungälv
  • 2005-03-02 17:36
Ursprungligen av abens:

Diskwarrior säger att båda diskarna som sitter i nu är helt OK.
Men har lagt märker till att KP får jag precis när fläktarna börja spinna upp, när detta händer är lite olika, men när det händer kommer KP'n.

Det antyder ju att det är problem med överhettning.

Sänk värmen i rummet!

Ursprungligen av Macus:

Det antyder ju att det är problem med överhettning.

Sänk värmen i rummet!

Överhettning är det inte, då det snarare är kallt i rummet.

Men du har en poäng. Det hade jag inte tänkt på - att de kanske kan vara kylan. Då datorn så småningom börjar gå att använda hyfsat normalt. När den har stått på ett tag och är varma så funkar det iallafall att göra nånting. Inte perfekt då det uppståt andra problem i samband med krasherna, men inga KP's nu på två timmar.

Då detta problem började i förra veckan - ungefär runt den tiden då det blev väldigt kallt här nere. Och fallet är faktiskt att de endast uppstår då datorn är kall - antingen gått ur vila eller precis i samband med uppstart.

Processorn kanske inte gillar dessa värmeförhållanden? Lite långsökt, men kanske kanske?

Någon som kanske vet?

I samband med krasherna så har musen flippat ut totalt, ofta, ofta, så sluta strömtillförseln till USB-kedjan, så både mus och tgb upphör fungera, första gången kan man byta usb port, och köra vidare men inte andra gången, då portarna är slut. Kanske bara en tillfällighet, men väldigt irriterande.

mvh

  • Medlem
  • Stockholm
  • 2005-03-02 19:31

När du har datorn igång å funkar. Vad säger den när du trycker på program uppdatering?

Kan det ha sket i samband med den security uppdaten som kom? "Nergradera" ett snäpp?

Om den nu funkar med alla saker utdragna så kan det vara att något inte kopplar fel å det bildas statisk elektricitet å gör att datan tappar fnatt då ena disken "försvinner"....tanke!

Ursprungligen av atomlab:

När du har datorn igång å funkar. Vad säger den när du trycker på program uppdatering?

Kan det ha sket i samband med den security uppdaten som kom? "Nergradera" ett snäpp?

Om den nu funkar med alla saker utdragna så kan det vara att något inte kopplar fel å det bildas statisk elektricitet å gör att datan tappar fnatt då ena disken "försvinner"....tanke!

Har inte uppdaterat med säkerhetsuppdateringarna - då det i både 10.3.7 och .8 rapporterats om buggar på MDD'n i samband med ljudnivåer och Final Cut Pro. så kör 10.3.6 fortfarande.

Jag förstår inte riktigt vad du menar med att den får fnatt och tappar ena disken. Har två st i över facken, som funkar bra just nu - de två jag tog ut var för att tänkte att det kanske skulle hjälpa. hjälpte en dag, men det efter att den hade krashat åtaliga ggr redan, så kanske skulle det ha funkat med diskarna i. Hursomhelst så är de två diskarna fulla med projekt som inte är aktuelle just i dagarna så har därför inte satt i diskarna igen.

Det finns ingenting nytt i systemet från straax innan det började, och utläst av KP loggarna så tror jag att det är hårdvara problem.

Får se om min teori stämmer och det slutar hålla på när det blir varmare ut (och här inne).

Det låter som värmeproblem.
De som producerar värme i större mängder är processor och hårddisk.

Det låter lite som du har strömfördelningsproblem, nollställa PMU kan du göra då.
Det gör du enklast genom att stänga av datorn, öppna den sedan leta på den 2-3 mm stora knappen som sitter någonstans på logikkortet.
När du hittat den, tryck på den EN gång, max 1 sek.
Starta sedan maskinen igen. Detta kommer troligen inte lösa dina problem.
Men PMU kan ställa till många mycket underliga fel.
I och med detta tappar du alla inställningar som spars mellan omstarter.
Detta är inte samma sak som "zappa pramen".

Med tanke vad du har berättat misstänker jag än mer processorn.

  • Medlem
  • Göteborg
  • 2005-03-08 13:16

Detta var intressant. Har en kompis med exakt samma dator som du och dessutom med samma problem. Den fungerar ett tag för att sedan hänga sig med nämnda felmeddelanden. Trodde jag hade fixat den ett tag, OSX laddades nämligen inte av någon aledning vid uppstart men genom att hålla nere X vid uppstart funkade detta. Efter detta funkade datorn fint ett tag men felet kom tillbaka. Kollade minnet eftersom datorn är köpt av en IT-konsult som normalt handhar mest PC-prylar. Tänkte att de kanske hottat den med taskigt minne som inte var kompatibelt med Mac men det verkar inte vara problemet enligt ovanstående inlägg. Hittade för övrigt på nätet två andra Macanvändare som hade likadan minnesmdul och det verkade funka bra; PC2700U-25330-B2 1368 L6423DTM-CB3 står det på den för övrigt om du vill kolla om vi har samma (är tydligen en Samsungmodul).

Funderat på att installera om, kan det lösa något tro? Abens hade du testat det eller hur var det?

clabur> nej jag har inte installerat om däremot har jag sätt i en annan hårdisk med nyinstallerat osx på som enda hårddisk och fortfarande samma problem, så jag tror inte på hårddisken då denna hårddisk fungerar prima i en kompis dator.

UPPDATERING PÅ PROBLEMET 25/3 2005:

Jag har nu jobbat på och fått gjort allt kritiskt arbete. Löste problemet genom att inte stänga av datorn (lite svårt att sova en meter härifrån bara).

Är datorn på efter att man slitit att få igång den så funkar den. Det går att stänga av den kortare stunder (har problem med usb-kedjan också, att den krashar ibland så blir tvungen att starta om då och då). Även har jag på detta sätt löst att de två hårddiskar som suttit i undre facket står numera i skåpet och sätts in endast då de behövs (2st video diskar).

Även har jag konstaterat följande; temperaturen i rummet är normal, datorn går enda upp till mellan 59.6 och 59.9°C vid vanligt användande, sätter jag i de två hårddiskar i undre facken och kör normalt så ligger den ungefär en grad högre. Vid krävande video arbete går den upp till 62-63°C.

Öppnar jag fönstret och får in kall luft i rummet så blir det förbannat kallt, men dator temperaturen går ner någon halv grad - känns bättre, men samtidigt vet jag inte, är det kanske inte bra att temperaturen går upp och ner? Bättre att hålla konstant? Fönstret öppet har dessutom gett mig en förkylning så man får tydligen välja om datorn eller jag själv ska må bra.

Så konstaterat är att med alla diskar i datorn så har temperaturen gått upp minst 2 grader C jämfört med förut (innan detta problem uppstod).

När jag startar datorn så går temperaturen upp till 62-63°C, vare sig alla diskar sitter i eller inte, för att sedan stabilisera sig något till det värden jag anget ovan.

När datorn varit avstängd en längre tid så går det alltid första gången att komma rätt långt, in i finder och leka lite, men då krashar den och nästa gång kommer man inte alls lika långt, och nästa gång stannar den ännu tidigare.

Men om jag kommer in i finder och lyckas starta temperature monitor, så brukar datorn krasha när den kommer i upp i 58 °C - kanske bara ett sammanträffande, men så har det varit.

Och datorn går inte upp i högre temperaturer när den är nystartad - endast vid omstart.

Även så är chansen större att edn startar utan att krasha om man lämnar kvar den ett tag vid login rutan - om man kommer så långt. Kanske för att den inte hinner starta några program?

Vad som är postivt är att den inte krashar då den äntligen är på. Då är det bara att köra.

Jag är ingen tekniker och skulle inte börja byta delar som inte är rekomenderat att man själv gör, så frågan är, kan det vara fläkten som börjat bli ostabil? Kan man jälpa till med ngn typ av extern kylning, typ stor fläkt att ställa bakom datorn?

Den här datorn var en stor investering med lånade pengar (som ännu inte är helt återbetalda) - och har redan förut varit inne på service för byte av processorer (under garantitiden) Kernel Panic problem även då.
Kändes från första början som ett måndagsexemplar. Är ju trots allt generation 1 av MDD.

Nu är frågan vad som behöver göras. Vore trevligt att kunna stänga av datorn när man går hemifrån eller när man vill sova.

Några tips? - på vad som kan göras? - Testa fläktarna på något vis?
Eller något bra service ställe i stockholm omr. som kan tänkas titta efter vad det är för fel - för en inte alltför hög kostnad?

Nästa torsdag den 1/4 börjar det bli kritiskt för arbete igen och nu faller ju några dagar bort för påsken. Kan tilläga att stället jag lämnade in datorn för byta av processorer ( då jag nästan var helt säker vad som var fel efter många timmars sökande ) så skulle detta service center kolla upp vad som var fel - några dagar skulle det ta, efter en vecka så var det fixat - bra. Då skulle de bara vänta på processorerna vilket skulle ta max en vecka till - tog cirka 4 veckor till - inte så roligt när man haft ny dator i 6 veckor att bli av med den i 5 veckor.
Något som är absolut uteslutet nu.

Är tacksam för alla tips som kan göra vardagen lite lättare

MVH / Abens

1
Bevaka tråden