G3 med OSX.2 startar inte Classic!

Tråden skapades och har fått 11 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2005-02-22 17:40

Måste nog bli en ny tråd. Har install. Jaguaren på Part.1 och systemmappen för OS9 ligger på part.2. Vid försök att starta classic blir det bomber. 1 systemfel. uninplemented trap. 2. Ett kodfragment kunde inte förberedas. Em Extension feltyp 1010. 3, Carbon lib.
Hade först system 9 på en 3 GB extrahd men kopierade över den till part.2 pga att 3GB är slö. Ngn. Idé? (den syns i systeminst. och är vald för classic.) Tyvärr kunde jag inte ominstall.OS9 då det inte passade G3n. Är till en iMac. Ska jag behöva köpa en OS9 när jag har en OSX.2?
Ps. Har bytt tillbaka G3.proc. ingen skillnad.Ds

  • Medlem
  • 2005-02-22 18:29

Jag är inte helt hundra på att jag hängde med hela vägen, men du måste installera "stöd för OS 9" när du skapar partitionen. Det gör den vansinnigt nog inte automatiskt, och vad jag vet går det inte att fixa i efterhand. Jag har inte grävt så mycket i det, det är inte omöjligt att det finns verktyg för det.

  • Medlem
  • Kristianstad
  • 2005-02-23 18:58

Har jag missuppfattat detta? Är det inte så att antingen kör man i Classic via OS X och då behövs inga partitioner eller så gör man partitioner och väljer OS X eller OS 9 vid uppstart?

  • Medlem
  • 2005-02-23 20:19

Hänger inte riktigt med själv. 1) Beige G3 med OS9.2. och ZIF G4-proc.kort och 28GB HD. 2) Vill install. OSX.2. G3n kräver partition under 8GB. 3) Sparar då det jag behöver inkl.OS9 på en 3GBHD som går som slave. 4) Install. OSX.2 på part.1 och kopierar tillbaka mina filer inkl.OS9 från 3GBHDn till part.2. pga att 3GB är gammal och slö. 5) Prövar att köra Classic som då börjar köra mot 3GB, avbryter och väljer part 2 som startdisk för classic. 6) Classic börjar starta men hänger sig med olika meddelanden. Bomb,CarbonLib, uninplemented trap, Ett kodfragment kunde inte förberedas Em Extension feltyp 1010, etc.
Kanske gick nåt på tok vid kopiering. Men vad betyder felmedd.? Såg nånstans att carbonLib var nåt man kunde ladda ner. Likaså att startskiva skulle vara 9.2.2. Hemskt bra om nån kunde hitta en lösning.

  • Medlem
  • 2005-02-23 22:23
Ursprungligen av med:

Hänger inte riktigt med själv. 1) Beige G3 med OS9.2. och ZIF G4-proc.kort och 28GB HD. 2) Vill install. OSX.2. G3n kräver partition under 8GB. 3) Sparar då det jag behöver inkl.OS9 på en 3GBHD som går som slave. 4) Install. OSX.2 på part.1 och kopierar tillbaka mina filer inkl.OS9 från 3GBHDn till part.2. pga att 3GB är gammal och slö. 5) Prövar att köra Classic som då börjar köra mot 3GB, avbryter och väljer part 2 som startdisk för classic. 6) Classic börjar starta men hänger sig med olika meddelanden. Bomb,CarbonLib, uninplemented trap, Ett kodfragment kunde inte förberedas Em Extension feltyp 1010, etc.
Kanske gick nåt på tok vid kopiering. Men vad betyder felmedd.? Såg nånstans att carbonLib var nåt man kunde ladda ner. Likaså att startskiva skulle vara 9.2.2. Hemskt bra om nån kunde hitta en lösning.

Jag är ledsen, men jag hajar inte vad du skriver... Om du kan antingen beskriva det lite enklare, eller helt enkelt göra det på ett enklare sätt kanske jag kan hjälpa dig.

Vissa uppgraderingskort kräver ett tillägg i systemmappen, kanske är det det?

  • Medlem
  • 2005-02-23 22:48

Vi försöker: G3n har en 28GB HD med 2 partitioner. På ettan ligger OSX.2. På tvåan ligger OS.9.2. Men OS.9/classic startar inte. Får meddelanden med BOMB! CarbonLib, unimplemented trap.
Ett kodfragment kunde inte förberedas. Em Extension feltyp 1010.

  • Medlem
  • 2005-02-24 00:04

Boota in i OS X, kolla i skivverktyget om det finns drivrutiner för OS 9 på OS 9 partitionen. Om det inte finns det, måste du göra en backup och formatera om den, med rutan "drivrutiner för OS 9" ikryssad.

Återkom om det inte är problemet.

  • Medlem
  • 2005-02-24 15:42

Har kollat och vid alternativ syns rutan ibockad /install OS9-drivr./. Vad jag sett ska inte G3n behöva ny firmware. Hittade nånstans på datorn att G3n har Mac OS ROM s.1-8.7. Undrar om det ska vara det? Men kan ingen i Macvärlden vad felmedd. betyder: Unimplemented trap?

  • Medlem
  • 2005-02-25 23:13

Installerade OS9 på part.2 då startade det. Gm att välja pert.1 som startskiva startade OSX.2. Uppgrad. OS9-9.2. Så nyinstall. är tydligen medicinen. Nu verkar de synkrona me varandra.

  • Medlem
  • 2005-02-26 00:18

Det funkade till sist alltså?

  • Medlem
  • 2005-03-03 23:17
Ursprungligen av stfm:

Det funkade till sist alltså?

Tillfälligt Allt gick fint men så fick jag problem med PageMaker som inte ville starta. Löstes gm ominstall. Fick problem med Outlook adresser o mail som försvunnit. Blev nån omstart mm och plötsligt kom jag bara in i OS9! Prövade byta startskiva men då kommer gråskärm med förbudsmärke! provat att starta med OSX-cd men den vill install. nytt OSX och ersätta det som finns på HDn. Tror att det kan vara ZIF G4-proc. som jag install. som spökar. Frågan är nu: Byta tillbaka G3-proc. och kanske få igång OSX eller pröva en ominstall. med allt inställningskrångel och som kanske inte lyckas pga G4-processorn.
(Jag lovar att aldrig mer uppgradera gammalt utan bara köpa nytt! )

  • Oregistrerad
  • 2005-03-04 11:14

Tråkigt. Det låter absolut som problem med hårdvaran. Eftersom det är en beige G3 hade mina misstankar riktats mot problem med "data corruption" på hårddisken.

Med beige G3 har jag drabbats av felmeddelanden, spontana krascher, program som inte vill starta, korrupta dokument och i något fall så småningom ett helt obrukbart OS. Lösningen för mig har varit en uppgradering av lagringsmedia: ny hårddisk parad med en Acard ATA-adapter. Därefter att ta bort filen /System/Library/Extensions/AppleNDRV/ATIDriver.bundle från 10.2.8 eller helt stanna i 10.2.6.
Tillsammans har dessa två "fixar" gjort mina beiga G3or urstabila.
Tyvärr har jag ingen erfarenhet av G4-uppgraderingar i beige G3, bara uppgradering till snabbare G3 eller överklockning av befintlig processor. Frågan är om du vill lägga ytterligare 4-500:- på din gamla dator?

1
Bevaka tråden