Varför funkar inte Civ II i Classic?

Tråden skapades och har fått 15 svar. Det senaste inlägget skrevs .
1

Vad jag fattar efter att ha läst större delen av alla fora på planeten är jag den ende som har problem med Civ II i Classic. Jag har en Powerbook G3:a med 10.3.8 och 9.2.2 som Classic. När Civ II drar igång så dyker det upp en diologruta med att "QTUtilitylib" saknas och att Civ II därför inte kan startas. Bisarrt nog så går det utmärkt att starta map-editorn.

Kan det påverka att jag slängt in 9.2.2 i efterhand, och alltså inte vid installationen av OSX? Alla andra Classic-program jag testat funkar bra. Det suger i CivII-tarmen (i dubbel bemärkelse ...), så kan någon bringa lite ljus i detta vore jag ofantligt tacksam. Och nej, CivIII är inget substitut. Ett bra spel måhända, men inget substitut, mer än sushi är när man är sugen på pizza, if you get my drift.

Har du sökt efter QTutilitylib? Det kan vara så enkelt att filen saknas helt och hållet...

Ursprungligen av Hasdrubal:

CivIII är inget substitut.

Bah!

  • Medlem
  • 2005-02-18 07:21

Civ2 funkar i min Classic, också installerad separat. Någon fil med det namnet finns inte, eventuellt att lib:et är inbakad i något QT-tilägg. Kolla så att QuickTime och QuickTime PowerPlug ligger i mappen "extensions/tillägg" i OS9s system-mapp.

Ursprungligen av SirN:

Civ2 funkar i min Classic, också installerad separat. Någon fil med det namnet finns inte, eventuellt att lib:et är inbakad i något QT-tilägg. Kolla så att QuickTime och QuickTime PowerPlug ligger i mappen "extensions/tillägg" i OS9s system-mapp.

Jodå, de ligger båda där de ska, tillsammans med en massa andra QT 6.0.3-filer. Alla QT-extensions är påslagna också.

Ursprungligen av Andersson:

Har du sökt efter QTutilitylib? Det kan vara så enkelt att filen saknas helt och hållet...

Nä, det finns ingen sån fil. Men det gör det inte på min iMac som enbart kör 9.2.2 heller. Jag har dessutom sökt på filnamnet, och man får exakt EN träff på hela internet. Så jag undrar så smått vad det där är för fil

  • Medlem
  • International user
  • 2005-02-18 09:56

Insatllera rätt QT version i Classic och det ska lösa sig.
Eller installera om Civ2 endera hjälper

Ursprungligen av juanito:

Insatllera rätt QT version i Classic och det ska lösa sig.
Eller installera om Civ2 endera hjälper

En dum fråga kanske, men vad är "rätt" qt-version? När CivII kom var det väl QT3 som gällde eller nåt? Har 6.0.3 nu.

  • Medlem
  • 2005-02-18 10:20
Ursprungligen av Hasdrubal:

En dum fråga kanske, men vad är "rätt" qt-version? När CivII kom var det väl QT3 som gällde eller nåt? Har 6.0.3 nu.

Jag kör QT 5.0.2 is OS 9.2.2, och det funkar. Lite instabilt dock, kraschar ibland.

Ursprungligen av SirN:

Jag kör QT 5.0.2 is OS 9.2.2, och det funkar. Lite instabilt dock, kraschar ibland.

Vet du var man hittar 5.0.2? Finns ju inte hos Apple längre ...

Vaersion 6.03 för 9.2.2, ska funka under classic.

http://www.versiontracker.com/dyn/moreinfo/macos/17804

Ursprungligen av Leftrustle:

Vaersion 6.03 för 9.2.2, ska funka under classic.

http://www.versiontracker.com/dyn/moreinfo/macos/17804

Visst funkar det under classic. Alldeles utmärkt till och med. Det är CivII som klagar.

  • Medlem
  • 2005-02-19 09:55

Qt5:
http://docs.info.apple.com/article.html?artnum=120132

Den ända infon jag hittat angående QTUtility berör språk-problemet med Classic. Se till att ha Qt i rätt språk.

Ursprungligen av SirN:

Qt5:
http://docs.info.apple.com/article.html?artnum=120132

Den ända infon jag hittat angående QTUtility berör språk-problemet med Classic. Se till att ha Qt i rätt språk.

Imponerad att du hittade QT5. Mer än vad jag gjorde ... Har testat både enegelsk och svensk version av QT5 och CivII klagar fortfarande på samma sak. Nu klagar dessutom OS9 på att jag har en för gammal QT

Annars är både Os9 och Civ engelskspråkiga.

Måste civ ligga i nån särskild mapp eller nåt?

Ursprungligen av Hasdrubal:

CivIII är inget substitut.

Nej, det är det verkligen inte. Suck... saknar Civ II. Jag har det bara till Windows, och någon PC har jag inte. Köpte faktiskt Civ III just för att ha som substitut, men det funkade inte. (Spelet funkar alltså, det substitutfunktionen det inte fungerar i.)

Och Civ 2 är inte i mina nostalgiska ögon något substitut för Civ....

Ursprungligen av Leftrustle:

Och Civ 2 är inte i mina nostalgiska ögon något substitut för Civ....

Alla har vi våra böjelser

Personligen störde jag mig för mycket på AI:ns fuskande ...

1
Bevaka tråden