php på osx 10.3.7

Tråden skapades och har fått 6 svar. Det senaste inlägget skrevs .
1

Hejsan

Jag undrar hur man installerar php på osx? allså så man kan köra php script på sin personal web sharing.

eller går de ens?

jag kommer ihå när jag skulle installera php på windows 98 en gång i tiden. Fy fasiken vilket h-lvete. Men de gick till slut. Är de likadant på mac?

Redan fixat !

  • Medlem
  • Linköping
  • 2005-01-12 09:39

Gå till entropy.ch och klicka på software, där kan du ladda hem PHP för OSX som funkar med den inbyggda webservern

Lycka till

PHP är redan installerat i OS X bara att slå på.
Du måste för hand fixa det i httpd.conf. Sök på internet hurm an ändrar det inga svårigheter.
Sedan startar du om Apache. Done.

  • Medlem
  • Mölndal
  • 2005-02-03 21:38

Finns det någon anledning för mig som nyss börjat med php att ladda hem version 5 istället för att använda 4.3 som är installerat?

Och hur är det med apache 2 vs. 1.3?

  • Medlem
  • Karlstad
  • 2005-02-03 22:44
Ursprungligen av memark:

Finns det någon anledning för mig som nyss börjat med php att ladda hem version 5 istället för att använda 4.3 som är installerat?

Och hur är det med apache 2 vs. 1.3?

I båda fallen så spelar det ju ingen roll om du gör egna grejer som du ska ha kvar i egen burk. Då kan du använda vilket som.

Men om du t.ex. tänkar 1) skaffa färdiga skripter eller 2) flytta skapelsen till annan host så småningom så kan det bli problem om dom inte stöds av eller stöder senare versioner.

Jag e iofs en nybörjare på PHP och annat, men det är så jag fattar det hela.

  • Medlem
  • Stockholm
  • 2005-02-03 23:57
Ursprungligen av Danne V:

I båda fallen så spelar det ju ingen roll om du gör egna grejer som du ska ha kvar i egen burk. Då kan du använda vilket som.

Men om du t.ex. tänkar 1) skaffa färdiga skripter eller 2) flytta skapelsen till annan host så småningom så kan det bli problem om dom inte stöds av eller stöder senare versioner.

Jag e iofs en nybörjare på PHP och annat, men det är så jag fattar det hela.

PHP-communityn själva rekommenderar 1.3 med PHP på produktionsservrar eftersom många tilläggsbibliotek inte är "thread safe" vilket *kan* skapa problem med Apache2.

1
Bevaka tråden