SSH-timeouts

Tråden skapades och har fått 4 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Umeå
  • 2004-12-07 13:02

Jag använder ganska ofta Cyberduck (förut Fugu) för att redigera filer på någon remote-server (mest olika linux-burkar, men även maccar), men när jag lämnar min lilla editor för en stund (fika och sånt ) så blir det nån sorts idle-timout på ssh-kopplingen och Cyberduck dör lite tragiskt och kommer inte åt servern.

Samma sak händer om jag använder mig av ssh i terminalen för att jobba lite remote, lämnar jag den orörd en stund så tappar den uppkopplingen. Och det är likadant på alla mina maccar som kör Panther allihopa.

Det funkar (tror jag) i mitt privata lilla nätverk utan större problem, det är ju bara maccar då iofs. och det finns ingen brandvägg mellan dessa datorer.

Kan tänka mig att man ska in i /etc/ssh_config och pula, nån som känner till problemet?

  • Medlem
  • Göteborg
  • 2004-12-07 13:09

Du kan ju kika på

ClientAliveInterval och
ClientAliveCountMax

i sshd_config. Tror nog att du kan hitta en bra lösning där

  • Medlem
  • Umeå
  • 2004-12-07 13:18

Är inte sshd_config konfigurationen för server-demonen? Jag vill ju ändra så att det sköts från mitt håll (klienten) jag kan ju inte ändra i sshd_config på alla servrar jag använder, eftersom jag inte administrerar dem.

  • Medlem
  • Göteborg
  • 2004-12-07 13:47
Ursprungligen av Jobbe:

Är inte sshd_config konfigurationen för server-demonen? Jag vill ju ändra så att det sköts från mitt håll (klienten) jag kan ju inte ändra i sshd_config på alla servrar jag använder, eftersom jag inte administrerar dem.

Jepp, sorry. trodde du var admin :/ Men det finns identiska settings i ssh_config på klientsidan med,
samt ett 'TCPKeepAlive' option, men den är default YES har jag för mig.
Det är det enda jag kan tipsa om tyvärr, då jag själv bara sitter i konsolmiljö, och inte jobbar via några speciella SSH-klienter.

Hoppas du löser det iaf!

  • Medlem
  • Umeå
  • 2004-12-07 14:04

Det verkar som om ServerAliveInterval bara finns i openSSH v3.8 och högre. Verkar som om Panther kör v3.6 :-(. Får ladda ner och kompilera en egen version eller titta om den finns i Fink.

Men den verkar ju göra det jag vill:

Citat:

ServerAliveInterval
Sets a timeout interval in seconds after which if no data has
been received from the server, ssh will send a message through
the encrypted channel to request a response from the server. The
default is 0, indicating that these messages will not be sent to
the server. This option applies to protocol version 2 only.

Ska testa lite, tack för hjälpen!

1
Bevaka tråden