FAQ: Så använder du RSS på 99.se

Tråden skapades och har fått 63 svar. Det senaste inlägget skrevs .

Vi får en del frågor kring RSS och vi kan bekräfta att vi har väl fungerande RSS-export ifrån alla delar av 99.se

Den nuvarande RSS-feeden som tar med alla nya diskussioner finns här:
http://www.99.se/external.php?

Jag har skapat sex olika RSS-feeds enligt följande:

www.99.se/rss/ <- Alla forum
www.99.se/rssmac/ <- Mac
www.99.se/rssmusik/ <-Musik
www.99.se/rssipod/ <- iPod
www.99.se/rsswebb/ <- Webb
www.99.se/rssmacwebb/ <- Mac & Webb

På sikt borde vi kunna bygga så att varje medlem kan bygga sin egen RSS feed där man väljer forum inom sina intresseområden.

Parametrar
Det är även möjligt att begränsa en feed till ett visst eller vissa forum genom att lägga till en enkel tag: forumids följt av forumnumret. Du kan ange flera forum separerade av decimaltecken.
http://www.99.se/external.php?type=rss2&forumids=41
(Ovanstående länk ger våra säljesannonser)

Javascript
Det är även möjligt att använda Javascript istället för RSS. Samma parametrar som ovan fungerar fint.
http://www.99.se/external.php?type=js

Kan någon göra en lista på lämpliga RSS-klienter för OS X och Windows?

  • Medlem
  • Karlstad
  • 2004-10-05 18:57

Tjusigt!!!

RSS-läsare

En trevlig RSS-läsare jag använder för närvarande är NewsFire. Ganska minimalistiskt, men ovanligt trevlig för att vara freeware.
http://www.newsfirerss.com/

  • Medlem
  • 2004-10-06 00:42
Ursprungligen av Pegges:

En trevlig RSS-läsare jag använder för närvarande är NewsFire. Ganska minimalistiskt, men ovanligt trevlig för att vara freeware.
http://www.newsfirerss.com/

Tack för tipset. Byter nu från NetNewsWire. Den här klienten var ju riktigt snygg och trevlig

  • Medlem
  • Karlstad
  • 2004-10-06 08:32
Ursprungligen av odin:

Tack för tipset. Byter nu från NetNewsWire. Den här klienten var ju riktigt snygg och trevlig

Håller med! Mycket trevligare. Men bra att man kunde exportera nyhetskällorna från NetNewsWire och bara importera till NewsFire.

  • Medlem
  • Karlstad
  • 2004-10-05 20:13

Jag har just lagt in länkarna i min reader som heter NetNewsWire Lite och det funkar finemang!

Om nån är intresserad av att testa läsaren så finns den här:
http://ranchero.com/netnewswire/ eller här http://www.versiontracker.com/dyn/moreinfo/macosx/15500

EDIT: Den är alltså gratis...

  • Medlem
  • International user
  • 2004-11-04 21:40

Nya Safari kommer ju såklart snart

  • Medlem
  • Mölndal
  • 2004-11-08 22:18

får inte nyheter rss:en att funka med newsfire. klickar jag på länken i safari så verkar den funka dock. vad kan jag nu ha sabbat?

Härligt med RSS. Kan man inte få RSS på bara en tråd, eller alla sina bevakade trådar? Det skulle vara guld.

Nyhetssidan går inte att ladda... Har den flyttat eller ngt?

Ajdå - den är flyttad. Kan tyvärr inte ge dig den nya adressen riktigt ännu

  • Medlem
  • International user
  • 2005-05-01 17:08
Ursprungligen av Björnström:

Ajdå - den är flyttad. Kan tyvärr inte ge dig den nya adressen riktigt ännu

Vi väntar. Med spänning.

  • Medlem
  • Borås
  • 2005-05-22 22:34

Nyhets-feeden..?

  • Medlem
  • Malmö
  • 2005-05-26 20:54
Ursprungligen av amolle:

Nyhets-feeden..?

Jag hittade den av en slump http://www.esplanaden.se/rss.pl?iid=259587

Väntar med spänning...

  • Medlem
  • International user
  • 2004-12-19 01:09

Hur blev det med nyhetsfeedet? Kan inte läsa det :/

feedet lirar inte. annars undrar jag om rssen inte skulle kunna göras lite mer interaktiv typ så att man kan bevaka vissa användares poster eller poster innehålandes ett visst ord? typ.

  • Medlem
  • Stockholm
  • 2005-04-26 17:32

Hej

Jag sitter och testar NetNewsWire Lite, bra program för övrigt...

Feeden http://www.mantaray.se/news/index.xml
funkar inte...

Får error 404

Åååhh..så underbart att köra 99mac forum i safari rss....

  • Oregistrerad
  • 2005-05-26 22:39

Jag har problem med åäö. Det blir bara frågetecken istället för åäö. Är det jag som har fel inställning eller är det något annat som är fel? Det är i Safari 2.0 som det inte fungerar för mig. Har inte testat med annat program.

Senast redigerat 2005-05-26 23:40
  • Medlem
  • Mölndal
  • 2005-05-26 23:27

samma här, problem med åäö

Hmm, jag hittar inte felet direkt. Har ändrat på lite inställningar men lyckas inte trolla fram åäö.

  • Medlem
  • Bollnäs
  • 2005-05-27 13:11
Ursprungligen av Björnström:

Hmm, jag hittar inte felet direkt. Har ändrat på lite inställningar men lyckas inte trolla fram åäö.

Problemet är att du använder iso-8859-1 som teckenkodning i xml-filen, men har inte angett det i doctypen. Standardkodning för xml är utf-8, vilket RSS-läsarna faller tillbaka på om inget finns angivet. Vilket resulterar i feltolkning av alla tecken utanför »Basic latin«.

Lösningen är att du lägger till teckenkodningen i doctypen så den ser ut så här:

<?xml version="1.0" encoding="iso-8859-1"?>
Ursprungligen av Kalle W:

Problemet är att du använder iso-8859-1 som teckenkodning i xml-filen, men har inte angett det i doctypen. Standardkodning för xml är utf-8, vilket RSS-läsarna faller tillbaka på om inget finns angivet. Vilket resulterar i feltolkning av alla tecken utanför »Basic latin«.

Lösningen är att du lägger till teckenkodningen i doctypen så den ser ut så här:

<?xml version="1.0" encoding="iso-8859-1"?>

Ok, ska försöka räkna ut hur jag gör det - sidan skapas dynamiskt. Tror detta är ett ärende för Arvid

  • Medlem
  • International user
  • 2005-06-10 03:39
Ursprungligen av Björnström:

Ok, ska försöka räkna ut hur jag gör det - sidan skapas dynamiskt. Tror detta är ett ärende för Arvid

Dessutom, inga bilder, inte hela artiklarna? Jag som trodde 99mac skulle göra det bäst av alla?

Ursprungligen av Kalle W:

Problemet är att du använder iso-8859-1 som teckenkodning i xml-filen, men har inte angett det i doctypen. Standardkodning för xml är utf-8, vilket RSS-läsarna faller tillbaka på om inget finns angivet. Vilket resulterar i feltolkning av alla tecken utanför »Basic latin«.

Lösningen är att du lägger till teckenkodningen i doctypen så den ser ut så här:

<?xml version="1.0" encoding="iso-8859-1"?>

Tro det eller ej - Martin "haxxor" Björnström fixade problemet själv! Gick in i en rss.class fil och upptäckte att endast RSS 0.92 hade encoding specifierat. Nu lirar det med svenska tecken!

En feed för diskussionerna är rätt meningslös om man inte får inläggen också. Jag skulle vilja ha en feed som ger mig alla nya inlägg. Typ som WordPress forumfeed. Det blir förstås rätt mycket, men å andra sidan är det bara att ställa in feed-läsaren att inte spara mer än lämpligt.

Finns det i dagsläget en fungerande RSS 2.0 eller Atom-feed för 99mac? Jag har försökt med den länken som trådens första post uppges vara en RSS2.0-feed men får det inte att funka med annat än rubriken.

Har problem med åäö i OmniWeb i menyn. I stället för bokstaven visas (null). Sidorna visas rätt men rubrikerna i menyn får dessa (null)-stavade rubriker.

Bevaka tråden