försvunnen HD

Tråden skapades och har fått 26 svar. Det senaste inlägget skrevs .
1

Hej. Jag har köpt en ny hårddisk (Seagate) till min G4 MDD dual 1GHz med OS 10.2.1. Formaterade den och döpte den. Allt såg bra ut ett tag tills den försvann. Någon dag senare var den där igen, men försvann lika snabbt från skrivbordet. Under uppstarten av datorn står det att den "letar efter local disks" och jag får sedan upp ett felmeddelande om att jag har matat in en enhet som inte kan läsas av OS X. Jag har försökt reparera den med skivkontroll men med inget resultat. När jag kontrollerar disken där står det "Ogiltig storlek för B-trädet". Vad betyder det?

Hur ska jag göra för att få upp den på skrivbordet?

Mvh tobias

Senast redigerat 2004-09-29 01:05

Kan du inte försöka formattera om den? Eller har du redan hunnit lägga en del på disken

Har ingen lust att formatera om den. Den är nästan full med filer.

Det var ju lite synd...Har du skivan Hardwaretest, så kör den.
Starta om datorn med skivan isatt, och håll nere c-tangenten vid uppstart

Fortsatta problem!

Har fortfarande inte kunnat få upp min hårddisk på skrivbordet. Har kört Apple Hardware Test (har dock en finsk version så jag fattade inte helt - är det någon som kan översätta vad knapparna står för är jag tacksam). Hur som helst är det som jag kommit fram till följande:

Vid uppstart av OS X: "Väntar på local disks" för att sedan följas av ett systemmeddelande "Du har matat in en skiva som inte kan läsas av OS X".

OS X Skivkontroll: Hittar den fysiska hårddisken, men inte det jag döpte den till. Resultatet av kontrollen blir "Ogiltig storlek för B-trädet". Vägrar sedan reparera.

OS 9 Skivkontroll: Hittar den fysiska hårddisken och mitt namn på den. Resultatet av kontrollen blir "Skivkontroll kunde inte läsa från disken".

Diskwarrior 3: Hittar den fysiska hårddisken och mitt namn på den. När jag startat REBUILD hänger programmet sig vid steg 5: "Finding local directory". Någon fortsättning följer inte, alltså ingen rapport. Kan dock konstatera att det inte är något fysiskt fel på hårddisken.

Är mycket tacksam för vägledning!!!! Jag vägrar tro att all data på den är försvunnen för evigt. Måste gå att fixa tillbaka mina filer på något sätt!!!!!!!!

  • Medlem
  • Stockholm
  • 2004-09-29 02:28

Har du byglat den som "slave" eller "cable select" och inte "master"? Har du satt den på grå bygel bredvid din systemdisk i ATA100bussen?

Det är problem med det där också. Den sitter nu som CABLE SELECT på ATA66-bussen (alltså MASTER). Jag har försökt att byta den till ATA100-bussen (CABLE SELECT alltså SLAVE) men då vägrar OS X att starta. I ATA100-läge har jag också försökt att starta från startskivan och göra skivkontroll, men den vägrar även här starta.

  • Medlem
  • Stockholm
  • 2004-09-29 11:45

Det framgår inte om du byglat själva disken. För att den ska fungera som slave eller cable select måste HDn vara konfigurerad för det. Basinfo om att sätta "den lilla" bygeln rätt.

Jo. Jag har byglat den som CABLE SELECT. Jag har satt den i slutet av ATA-kabeln på ATA66-bussen, vilket medför att den blir MASTER när jag kollar i Skivkontroll. Det är en Seagate Barracuda 7200rpm 80Gb. Problemet är inte att systemet inte hittar den fysiska disken (förrutom när jag sätter den på ATA100-bussen då OS X inte startar alls). Problemet är att jag inte kan lägga den på skrivbordet och att den inte går att läsa ifrån.

Ursprungligen av tobias_tott:

Jo. Jag har byglat den som CABLE SELECT. Jag har satt den i slutet av ATA-kabeln på ATA66-bussen, vilket medför att den blir MASTER när jag kollar i Skivkontroll. Det är en Seagate Barracuda 7200rpm 80Gb. Problemet är inte att systemet inte hittar den fysiska disken (förrutom när jag sätter den på ATA100-bussen då OS X inte startar alls). Problemet är att jag inte kan lägga den på skrivbordet och att den inte går att läsa ifrån.

Har du provat med Disk Warrior?

  • Medlem
  • Stockholm
  • 2004-09-29 13:10

Har du byglat systemdisken som master och inte som cable select? Funkar det om du sätter den nya på grå bygel i ATA100bussen och startar om från systemskivan, väljer din master som startskiva och startar om...? (Alternativt håller inne "alt" vid uppstart tills du får upp system som finns tillgängliga...)

Nytt försök!

Ok. Jag tror jag har provat det, men jag ska göra ett försök ikväll. Ska jag sätta systemdisken som MASTER och den nya som SLAVE på ATA100-bussen och sedan starta om och hålla inne "alt"?

  • Medlem
  • Stockholm
  • 2004-09-29 13:32

Precis... Berätta hur det går. Jag hade strul med diskarna i en likadan burk (fast inte så mycket som du beskriver) när jag inte forcerat systemdisken till "master".

Skippa CS. Hårdvarubygla till Master / Slave i stället. Denna bygling har högre prioritet än CS och "tar över". Omaket är att man måste pilla med gyglar för att ändra, men fördelen är att det brukar fungera.

Det ska inte spela nån roll om System ligger på Master eller Slave, men ibland är det lite woodoo inblandat. Systemet på Master brukar vara en bra tumregel.

Undvik att ha ATA100 diskar på ATA66 kontrollern. Skaffa hellre ett extra ATA kort. Happy Hunting.

  • Medlem
  • Stockholm
  • 2004-09-29 16:12
Ursprungligen av leonardo:

Skippa CS. Hårdvarubygla till Master / Slave i stället.

Hur mjukvarubyglar man...

Citat:

Undvik att ha ATA100 diskar på ATA66 kontrollern. Skaffa hellre ett extra ATA kort.

Det spelar ingen roll annat än att de blir lite långsammare.

Ursprungligen av Earth:

Hur mjukvarubyglar man...

Det spelar ingen roll annat än att de blir lite långsammare.

Jag har sysslat med datorer så länge att delar av min datorvälska stammar från den tiden då byglingen gjordes i bootstrap (mjukvarubygling). Ibland hemfallar dinosaurier åt reflexer.

Jag rekommenderar att undvika att sätta ATA100 diskar på ATA66 lina, just för att det gåår 35% saktare att läsa / skriva. Om detta inte spelar nån roll för Dig personligen så kan Du få överta en North Star controller. Den går i max 15kbps, så Du hinner läsa strömmen om Du dumpar den till skärmen.

Nytt försök: misslyckades!

Nu provade jag att sätta min systemdisk som MASTER och extradisken som SLAVE på ATA100-bussen. När de båda sitter där så vägrar OS X starta. När jag höll nere "alt" hittades systemdisken, men inte den andra. Jag valde systemdisken och fortsatte. Det gråa äpplet kommer och det snurrar lite i BÅDA hårddiskarna, men sedan är det stopp. När OS X startfönstret ska komma blir skärmen istället helt grå.

När jag hade systemdisken på ATA100-bussen som MASTER och extradisken på ATA66-bussen så startar OS X utan problem, Dessutom hittar systemverktyg de båda diskarna, men det går inte att lägga extradisken på skrivbordet - jag kan alltså inte läsa ifrån den.

Vad ska jag göra? Jag kan inte fatta vad felet beror på. Se mitt andra inlägg som visar vad skivkontroll och Diskwarrior säger.

Tacksam för all hjälp!

  • Medlem
  • Stockholm
  • 2004-09-30 11:20
Ursprungligen av leonardo:

Jag har sysslat med datorer så länge att delar av min datorvälska stammar från den tiden då byglingen gjordes i bootstrap (mjukvarubygling). Ibland hemfallar dinosaurier åt reflexer.

Jag rekommenderar att undvika att sätta ATA100 diskar på ATA66 lina, just för att det gåår 35% saktare att läsa / skriva. Om detta inte spelar nån roll för Dig personligen så kan Du få överta en North Star controller. Den går i max 15kbps, så Du hinner läsa strömmen om Du dumpar den till skärmen.

Så länge har jag definitivt inte varit med i matchen...

Tänkte bara att din rekommendation gäller alla modeller före MDDn. Många kort blir det, och jag märkte skillnad i den gamla "Lövblåsaren" men aldrig så mycket att jag tänkte på att kosta på den ett ATA100kort.

Det är fruktansvärt vänligt av dig (Earth) att hjälpa till. Håller med dig att ett extra ATA100-kort inte är helt prioriterat. I så fall köper man väl ett serial-ATA direkt.

Om jag får spekulera så tror jag att det inte skulle vara några problem att sätta in en ny hårddisk på ATA100-bussen. Det är nog inte själva bussen som det är fel på. Det skulle förmodligen också funka om jag formaterade om den extra hårddisk jag har.

Problemet för mig är att jag vill åt all data jag har på den extra hårddisken. Efter att den är säkrad är det bara att formatera och trixa. Då kommer det säkert att funka efteråt.

Frågan är hur jag kan få tag i mina filer! Jag vägrar tro att de är borta för evigt (eftersom de finns där, men jag inte kan komma åt dem. Diskwarrior säger dessutom att det inte är något fysiskt fel på disken.). Är det någon idé att lämna in den på något serviceställe som säger att de befattar sig med att "rädda" hårddiskar. Vad kan de göra som inte jag kan? Är det någon som har någon erfarenhet? Jag kommer inte att formatera om hårddisken förrän jag har tömt ut alla möjligheter att rädda innehållet!

Hälsn. Tobias

Ursprungligen av Earth:

Tänkte bara att din rekommendation gäller alla modeller före MDDn. Många kort blir det, och jag märkte skillnad i den gamla "Lövblåsaren" men aldrig så mycket att jag tänkte på att kosta på den ett ATA100kort.

Spelar ingen roll vilken burk det är. Det handlar om vilket gränssnitt det är. ATA133 (som aldrig varit standard) kräver kontrollerkort för att fungera UA, men går med lägre hastighet på andra bussar. Likadant med alla andra diskart, de är bakåtkompatibla, dvs. fungerar, men med en lägre hastighet.

Skillnaden kanske kan maskeras av andra faktorer, eller förstärkas, ex.vis systembussens hastighet, möjligheten till DMA mm, men det har jag ingen uppfattning om.

Få tillbaka data?

Är det någon idé att lämna in den på något serviceställe som säger att de befattar sig med att "rädda" hårddiskar. Vad kan de göra som inte jag kan? Är det någon som har någon erfarenhet?

Ny diagnos!!!!!

Det verkar som om det är helt kört! Har nu provat att köra Tech Tools, vilket har medfört att jag förmodligen lyckats hittat felkällorna, men inte lyckats lagat disken. Tech Tools meddelar att:

1. Det är inget fysiskt fel på disken (genom SMART)

2. Volymen är korrupt, dvs den går inte att reparera. Diskkontroll har tidigare sagt att B-trädet har ogiltig storlek.

3. När jag körde surface scan visar den på 1000-tals bad blocks. Jag orkade inte köra en fullständig surface scan, men efter att ha undersökt 300000 blocks hittades ca 1000 bad blocks. Det är 156000000 blocks på min hårddisk. Att undersöka 300000 blocks på min dubbla 1Ghz G4 tog 12 timmar. Det skulle med andra ord ta månader att undersöka hela disken.

Jag har förstått att bad blocks är fysiska fel på hårddisken. Hur uppkommer dessa? Jag har verkligen varit snäll mot disken. Kan det vara så att den märkliga uppkomsten av denna mängd bad blocks har gjort filsystemet (B-trädet?) korrupt? Går det att återskapa ett filsystem på något sätt för det måste väl finnas data kvar på de blocks som inte har gått sönder?

ÄR DET HELT KÖRT? ELLER FINNS DET NÅGON MÖJLIGHET ATT RÄDDA DET SOM ÄR KVAR?

(Varken Diskwarrior eller Tech Tools har fungerat.)

  • Medlem
  • Stockholm
  • 2004-10-10 02:27

Jag körde prosoft´s data rescue x, den fixade fram 26000 filer till mig på en disk som inte kändes igen av systemet. Men då använde jag inte något program som provade reparera disken först, vilket ju kan skriva över viktiga ledtrådar.
Har provat b.l.a. diskwarrior efteråt, men det kunde inte göra något.
Finns att tanka ner på
http://www.prosofteng.com/products/downloadcenter.php?PHPSESSID=97d87c6d3a249ad8c57ef56e97bf25fe
Du kan prova gratis, sen köpa till S/N.

Hoppas det funkar...

Mvh

lämna in?

Är det någon som vet något bra ställe i Stockholm man kan lämna in sin mac på service, så att de får kolla upp om det går att rädda någon data?

  • Medlem
  • Stockholm
  • 2004-10-10 23:17

Är du seriös och tycker det är värt en del slantar att få fram grejerna igen så finns det hjälp. http://www.ibas.se/. Väldigt seriöst labb i Norge. Dom hämtar disken vid din dörr några timmar efter beställning.
Men du bör nog kolla priset FÖRE du gör något. Om du gör det kan du väl skriva hur mycket analysen/kostnadsförslaget går på
Jag var beredd på att lämna min HD dit om jag nu inte fick rätt på det själv.

Provade du Datarescue X? Du behöver en HD som du kan starta på och som kan ha temporära arbetsfiler på sig. Läs instruktionerna också.

Mvh
Fredric

Jo. IBAS - dyrt som bara katten, men det är väl bra att de finns.

Har inte provat Data Rescue X fullt ut än, men med lite tur så kommer det att vara lösningen. Programmet verkade i alla fall hitta min problemhårddisk. Det stod dock att den är volymen man bootar ifrån, vilket inte stämmer (eftersom jag inte har något OS på den). Min "Macintosh Hd" är också bootvolymen enligt Data Rescue X. Förvirrande!

Jag hade problem med att programmet behövde en volym att skriva på. När jag skulle scanna problemdisken dög "Macintosh Hd" tydligen inte att använda som volym för de temporära filerna.

Är det så att jag behöver en tredje hårddisk att skriva de temporära filerna på?

  • Medlem
  • Stockholm
  • 2004-09-30 11:18

Skumt!

När du håller inne "alt" vid uppstart får du bara upp systemmapparna inte hårddiskarna så det är i sin ordning. Men att den inte kan starta för att du sätter den nya disken bredvid förstår jag inte alls!? Då antar jag att det inte heller funkar att starta från CDn (DVDn) och ändra startskiva.

Mitt enda tips i det här läget är trots allt att tömma den nya disken och formattera om den, funkar inte det kan man kanske misstänka att det är fel på den... Men om du kan testa med en annan IDEdisk först så kan du utesluta om det är disken som är boven. Ser att du bor i Johanneshov, om du kan släpa över datorn hit har jag en du kan testa med.

1
Bevaka tråden