Ny intern hårddisk går att formatera men ej starta ifrån?

Tråden skapades och har fått 18 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2004-08-05 12:08

Tjohej. Jag tänkte jag skulle förgylla min nyinförskaffade PBG4/400 med en "ny" hårddisk. Från min PC (med kraschad nätdel) plockade jag därför över en 30 gb hårddisk och tänkte att den ju kan sitta i macen i stället. 30 hästar springer längre än 10 liksom.

Att öppna datorn och byta disk var inga problem, har Torx-mejsel och allt sånt. Startar om på CD och öppnar skivverktyg. Där finns den "nya" disken från PCn. Formaterar och allt ser bra ut. Avslutar skivverktyg.

Men när jag kommer tillbaks till OS-installeraren får jag hela tiden ett fett rött utropstecken. "Kan inte starta från denna hårddisk". Den vägrar alltså installera MacOS på disken. Har formaterat (både Journaled och inte, testat flera olika) och kört kontroll av hårddisk etc, visar inga fel alls, tvärt om. Både original-hårddisken och denna är Toshiba-diskar och jag hittar inga skillnader på dem rent fysiskt, kanske finns någon ID-switch under kontrollerkortet på diskarna? Kanske rentav byta kontrollerkort så A får B och B får A?

Den nya disken fick ID 0, vet inte vad disken ska ha för ID. Kan det vara detta?

Vore verkligen tacksamt med de där extra 20 Gb. Tips? (Nej, jag vill inte ha den i en extern låda).

Observera att frågan alltså gäller Powerbook.

Har du prövat att göra flera partitioner på den? Det borde ju inte behövas på en PBG4 (på min gamla 500MHz var det bara att tuta och köra med ny 40GB-disk), men på min iMac 233 var OS X tvunget att ligga i en partition liggandes inom de första 8GB av hårddisken. Borde inte vara detta, men du kan ju testa.

Kontrollerkortet skulle jag inte byta (annat än på identiska diskar) om jag vore du. Då kommer 30GB-disken förmodligen att tro att den är en 10GB-disk och låta sina skrivhuvuden börja dansa en dödsdans över diskytan.

  • Oregistrerad
  • 2004-08-05 12:34

Jepp, nej jag tänkte inte byta korten... Har provat partitionera men det var samma sak då, då blev det röda utropstecken på bägge partitionerna.

Sökte runt lite och hittade disken i fråga på XLR8. Där står att den funkar bra med OS X osv när den är i rätt master / slave-läge - min kanske är i fel läge då. Frågan är du var man ändrar detta på dessa småpryttlar...

Originaldisken heter Toshiba HDD2152 (MK1016GAP).
Den här disken heter Toshiba HDD2181 (MK3021GAS).

Master/slave-jumpern hittar du på baksidan av disken (oftast), precis bredvid IDE-anslutningen. På t ex den lilla IBM-disk jag har liggande här är det bara fyra "pinnar" i motsats till vanliga hårddiskar som tenderar att ha sex eller åtta stycken. Leta upp någon referensmanual på tillverkarens hemsida, vet jag. Jag tror att det normala är att laptophårddiskar är master om det inte sitter någon jumper på pinnarna, men jag vågar inte lova något.

Dock - har den redan suttit som systemdisk i en annan laptop vore det ju rätt konstigt om den var slavejumprad.

Har du senaste firmware i datorn?

  • Oregistrerad
  • 2004-08-05 12:46

Svår fråga där om firmware; körde 10.3.4 på 10 gb-disken igår utan problem, alla uppdateringar via software update. Firmware-uppdateringar kanske inte dyker upp där? I så fall är jag "kokt" på den vetskapen...

Det är inga jumprar på vare sig 10:an eller den andra, som synes inga skillnader förutom lite olika appearance på kontrollerkorten (fyra nyanser av br... grönt). Det finns ingen liten switch under kontrollerkorten då?

Switch tror jag inte... Brukar vara jumprar, som sitter på fyra pinnar som är strax till höger om IDE-pinnarna.

Nej, firmwareupdates dyker inte upp i software update. Dock kollade jag just Apples knowledgebase, och de verkar inte ha släppt någon (förutom en till DVD-enheten).

Jadu... Jag vet faktiskt inte. Du kan ju starta Powerbooken i target disk-mode och se om det alls går att använda hårddisken?

  • Oregistrerad
  • 2004-08-05 12:59

Jadu... Jag vet faktiskt inte. Du kan ju starta Powerbooken i target disk-mode och se om det alls går att använda hårddisken?

Ptja, men jag tyckte ju jag fick svar på den frågan i och med att disken gick så smutt att formatera. Skulle iofs kunna skriva nollor på disken, men det tar ju typ ett dygn... :-/

Tack för hjälpen iaf, jättesnällt att du tar dig tid. Ngn mer som har ngt infall?

  • Oregistrerad
  • 2004-08-05 13:19

Skulle verkligen behöva få detta löst... nu... Någon?

  • Medlem
  • 2004-08-05 13:30

Kolla här, trixa lite med byglingar och se om det hjälper. Du ska inte ha några byglingar alls på disken för att få den i master-läge.

  • Oregistrerad
  • 2004-08-05 13:41

Men nu säger du ju emot dig själv...

Trixa med byglingar. Du ska inte ha några. Eh?

Det finns inga byglingar, disken går att formatera. MacOS X vill inte installera på den.

Har jag missat något skumt i installeraren?!

  • Medlem
  • 2004-08-05 13:50
Ursprungligen av PF:

Men nu säger du ju emot dig själv...

Trixa med byglingar. Du ska inte ha några. Eh?

Det finns inga byglingar, disken går att formatera. MacOS X vill inte installera på den.

Har jag missat något skumt i installeraren?!

Ja, jo, iofs. Skrev sista meningen efter att jag postat inlägget. Kollade igenom länk ordentligt efter jag skrivit klart, blev kanske lite snurrigt.

Kolla på denna sidan då (http://sdd.toshiba.com/cda/main.aspx?Path=/818200000007000000010000659800000d2a/81820000011e000000010000659c00000401/818200000121000000010000659c0000040e/818200000634000000010000659c000013d5/818200000635000000010000659c000013d6) , där har du ju all möjlig info om disken.

Ursprungligen av PF:

Men nu säger du ju emot dig själv...

Trixa med byglingar. Du ska inte ha några. Eh?

Det finns inga byglingar, disken går att formatera. MacOS X vill inte installera på den.

Har jag missat något skumt i installeraren?!

Vad jag menade var alltså att det "normala" i min erfarenhet är att det inte ska sitta någon jumper på de pinnarna, men att det ju kan vara olika på olika diskar.

Bra att det löste sig i vart fall. Jag har för mig att jag någon gång när jag skulle installera X på en dator var tvungen att formattera disken med en startskiva för OS 9 för att OS X alls skulle hitta den. Något att testa nästa gång kanske.

  • Oregistrerad
  • 2004-08-05 13:45

(Tack Stevie Wonder för I Wish... soul brother!)... FAAAAAN vad trist att det inte bara FUNKAR!

  • Oregistrerad
  • 2004-08-05 13:47

Om man vänder flatkabeln upp och ned då? Passar ju åt bägge håll?

  • Oregistrerad
  • 2004-08-05 13:55

Tack - men det gjorde mig inte klokare. Synd att inte en miljon mer människor använder XLR8yourmac och fyller på med allehanda vettig vetenskap. Får prova en gång till helt enkelt. Bara för att konstatera att det är 10:an jag ska använda...

  • Medlem
  • 2004-08-05 14:10

Det kan vara som så att det är en gammal inställning i OpenFirmware som ställer till det för dig. Testa att starta datorn med Option-tangenten intryckt, då ska man tydligen kunna välja vilken disk man ska ha som boot-disk (även om det bara finns en i en Powerbook kanske datorn förutsätter att det är den gamla som är boot-disk).

-edit- såg att du fick det att funka nu. bara att tuta o köra då

  • Oregistrerad
  • 2004-08-05 14:02

?!!

Nu startade jag om. Körde installeraren på engelska för omväxlings skull.
Jahaja, nu går det ju att installera på den "!/)"=!+? disken. Varför inte nyss?

Antar jag borde vara happy... happy happy joy joy...

  • Oregistrerad
  • 2004-08-05 14:29

Ja, helskumt. Vi får lägga till det till 99macs "knowledge base": Om OS X vägrar installera på en disk som verkar helt korrekt formaterad, starta om och försök igen så fungerar det. Ingen logik för fem öre, men så var det för mig...

Jag har också haft detta problem ett antal gånger. Det räcker att starta om några gånger så funkar det helt plötsligt. Vet inte vad det beror på...

1
Bevaka tråden