ÅÄÖ/UTF-8 i websidor???

Tråden skapades och har fått 7 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2004-08-03 22:47

Jag får inte rätt på ÅÄÖ / UTF-8 när jag försöker bygga en website i OS X. I Windows har jag sällan haft några problem, men nu när jag skriver HTML i Taco HTML Edit under OSX blir alla åäö helt sabbade när jag ftp:at upp dem till ISP:n (som kör någon BSD-variant). I webservern under OS X ser allt bra ut...
Jag har:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
i headern på sidorna.

Någon som har en ide till hur jag får rätt på mina tecken?

/Asker

  • Oregistrerad
  • 2004-08-03 23:03

Jag föredrar att använda ö etc.

Tricket är väl att Taco HTML inte sparar i dokumentet i utf-8.

  • Medlem
  • Bollnäs
  • 2004-08-03 23:21

Bara för att man anger utf-8 i huvudet i dokumentet innebär det inte att det verkligen är den kodningen dokumentet är sparat i. De flesta moderna textredigerare sparar som förval i operativsystemets normala teckenkodning; Macroman på mac och CP-1252 på win. Du måste ange i programmet att det ska använda en viss kodning av dokumentet när det sparas/öppnas.

Vill du veta mer om teckenkodning så kan du läsa mitt seminarie på Bold.

  • Oregistrerad
  • 2004-08-03 23:28

Jag vet inte hur du för över filerna till servern men det finns alltid en chans/risk att det program du använder gör en auto-magisk konverting av tecknen också.

  • Oregistrerad
  • 2004-08-03 23:51

Tack för tipsen, men filerna är sparade som UTF-8 inifrån Taco... Jag använder Transmit med SFTP för att ladda upp filerna...
Testade att öppna i SubEthaEdit. Stod inte på UTF-8... Valde UTF-8 och reinterpret. Sparade ned. Tankade up. Samma skit... Har även provat sftp från terminalen med samma resultat...

Fler ideer?
Jag hatar att använda ö etc, särskillt näre det inte ska vara nödvändigt!

  • Oregistrerad
  • 2004-08-03 23:56

Jag förstog inte riktigt: om du laddar upp en UTF-8 fil till servern och sedan laddar ner den igen (inte via nån webläsare) är den då fortfarande i UTF-8? Om du loggar in på servern och kollar där, är filen i UTF-8 då?

  • Oregistrerad
  • 2004-08-04 00:06
Ursprungligen av Jan Erik Moström:

Jag förstog inte riktigt: om du laddar upp en UTF-8 fil till servern och sedan laddar ner den igen (inte via nån webläsare) är den då fortfarande i UTF-8? Om du loggar in på servern och kollar där, är filen i UTF-8 då?

Hur kollar jag vad den verkligen sparats som? När jag vill öppna filen vill alla program välja format automatiskt efter filtypen, eller så kan jag välja hur den ska öppnas (tex TextEdit & SubEthaEdit)... Lite konstigt tycker jag...

  • Oregistrerad
  • 2004-08-04 00:03

Kom på världens konstigaste (bökigaste) lösning... Öppnar upp i SubEthaEdit. Då står den automatiskt på Western (Mas OS Roman) som den valt utifrån ändelsen (html) på dokumentet... Väljer Unicode (UTF-8) och Reinterpret. Väljer därefter Western (ISO Latin 1) och Convert. Sparar ned och ftp:ar upp. Då funkar det. Headern i dokumentet är oförändrat UTF-8.
Helknasigt...

1
Bevaka tråden