G4 Cube felkonstruerad för ljud.

Tråden skapades och har fått 15 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2004-07-06 13:02

Jag har haft en lång rad helmystiska ljudproblem med min Cube och bytt alla möjliga konstiga grejer. NU verkar det som om jag, efter lite letande på nätet, funnit problemet. Den är helt enkelt felkonstruerad. Usb 1.0 orkar inte skicka högkvallaljud utan lägger av på en rad olika sätt, oftast genom att dra de flesta andra usb-funktioner med sig och gärna sänka systemet också (panther).

Har jag ultralåg ljudnivå klarar den sig i några timmar, med lagom nivå sänks den på en halvtimme. Den börjar också funka efter en (hård, med knapp) omstart.

Någon firewire-till-usb2-adapter finns inte, och en firewire-ljudut-grej kostar 3000:- (audiophile @ macoteket). Jag antar att det helt enkelt är kört, och vill egentligen bara beklaga mig och höra om någon annan har haft liknande erfarenheter. eller om nån till äventrys har en lösning...

http://99mac.se/forum/showthread.php?t=3894&highlight=cube+ljud

http://www.macintouch.com/cube3.html

http://www.cube-zone.com/jan.html :

"Several of our readers seem to experience problems with their Cubes and USB sound. When the volume is set to max, the sound sometimes stop and some USB peripherals begin to stop working. However, the Cube does not seem to have crashed. . What we can call a "sound crash" may be related to the USB bus and the way it is powered. When you push the volune too high, the bus does not seem to have enough power to handle all the peripherals connected."

  • Oregistrerad
  • 2004-07-06 13:09

Är det bara "kräm" som saknas så kan väl en hub med strömförsörjning hjälpa lite?

  • Medlem
  • 2004-07-06 15:48

Nix. Det är inte kräm (har en kensington med extern ström-hub), det är "bandbredd". USB 1.0 duger inte till att skicka högkvallaljud, än mindre till att samtidigt sköta tangentbord, mus etc. Som att skicka en golfboll genom en trädgårdsslang.

Ursprungligen av Enar:

Nix. Det är inte kräm (har en kensington med extern ström-hub), det är "bandbredd". USB 1.0 duger inte till att skicka högkvallaljud, än mindre till att samtidigt sköta tangentbord, mus etc. Som att skicka en golfboll genom en trädgårdsslang.

Ljud ska helst inte gå genom USB hubbar då blir det ofta problem.

  • Oregistrerad
  • 2004-07-06 16:34

Finns det inga små käcka PCI-kort på Clas Ohlson då?
Eller går inte ljudet äver det?

[Blir väl inte större bandbredd av högre volym? Möjligen fler nollor i bytes:en]

  • Medlem
  • 2004-07-06 19:31
Ursprungligen av Pär:

Finns det inga små käcka PCI-kort på Clas Ohlson då?
Eller går inte ljudet äver det?

PCI? Det finns väl ingen dylik palts i kuben?

Ursprungligen av Pär:

[Blir väl inte större bandbredd av högre volym? Möjligen fler nollor i bytes:en]

Från länkarna ovan:

"We recently discovered a bug concerning USB speakers and high quality sound. This problem has only been confirmed on Macintosh G4 Cube systems with USB speakers but, it is likely that other systems are affected. While I do not have a definite cause yet, it appears that setting the sound options such that the demand is greater than the USB bus can handle (e.g., 16-bit, 44KHz) causes a memory corruption bug to surface in the Mac sound manager (or related code)."

  • Oregistrerad
  • 2004-07-06 19:43
Ursprungligen av Enar:

PCI? Det finns väl ingen dylik palts i kuben?

Nä just det
My bad

Ursprungligen av Enar:

Från länkarna ovan:

"We recently discovered a bug concerning USB speakers and high quality sound. This problem has only been confirmed on Macintosh G4 Cube systems with USB speakers but, it is likely that other systems are affected. While I do not have a definite cause yet, it appears that setting the sound options such that the demand is greater than the USB bus can handle (e.g., 16-bit, 44KHz) causes a memory corruption bug to surface in the Mac sound manager (or related code)."

Jo, men 16-bit/44,1kHz är lika många bits och bytes oavsett om det är högt eller lågt (1000000000000000 är tyst och 0000000000000000 är odefinierat men oftast full ström).
Är inte hundra på USB men jag tror inte det bara sänder förändringar utan det sänder data kontinuerligt på ett liknande sätt…

  • Medlem
  • 2004-07-06 20:18
Ursprungligen av Pär:

Jo, men 16-bit/44,1kHz är lika många bits och bytes oavsett om det är högt eller lågt (1000000000000000 är tyst och 0000000000000000 är odefinierat men oftast full ström).
Är inte hundra på USB men jag tror inte det bara sänder förändringar utan det sänder data kontinuerligt på ett liknande sätt…

Så kan det mkt väl vara. har ingen koll alls på sånt här egentligen. Att ställa ner 16-bit/44,1kHz käns ju lite sunkigt, och jag vet inte ens om det går att göra någonstans.

  • Medlem
  • International user
  • 2005-01-16 13:00
Ursprungligen av Pär:

Nä just det
My bad

Är du säker tror mig komma ihåg att cuben hade en kortplats. Om det sen var PCI?

Ursprungligen av juanito:

Är du säker tror mig komma ihåg att cuben hade en kortplats. Om det sen var PCI?

De enda kortplatserna som finns i en Cube är till grafikkortet, och till Airport-kortet.

Ingen PCI.

Inga problemos här. Tycker att jag har en hel del inkopplat via USB som borde stjäla bandbredd.
-Soundsticks/klothögtalare (används inte samtidigt)
-Eye TV USB
-Skrivare
-Tangentbord
-Mus

  • Medlem
  • 2004-07-06 19:59
Ursprungligen av Dr Jerkyll:

Inga problemos här. Tycker att jag har en hel del inkopplat via USB som borde stjäla bandbredd.
-Soundsticks/klothögtalare (används inte samtidigt)
-Eye TV USB
-Skrivare
-Tangentbord
-Mus

Tidigare hade jag klotisarnas förstärkare inkopplad på stereon, men den hade också problem (fick elchockar av strömspikar från ett lysrör), så jag kopplade in en fin m-audio transit istället, och sedan dess har det blivit omöjligt. En tanke är ju att m-audio är klantar, men det vore ju märkligt (Eller? http://99mac.se/forum/showthread.php?t=45244 ). Även om jag bara har den + tangobord + mus inkopplad händer det....

  • Medlem
  • 2004-07-07 10:10

Än så länge går det inte genom hubben, men jag hade tänkte testa det också.

Har problemen löst sig med systemuppdateringar/m-audio-fixar nu?
Är själv på väg att skaffa mig en m-audio transit+surround-högtalare till min kub och det skulle ju inte va så kul om den inte fixade det när jag väl köpt grejerna...

Nån kanske kan testa följande tips och se om det fixar problemen med transiten
http://www.macosxhints.com/article.php?story=20040514125451790

  • Medlem
  • Kungälv
  • 2005-01-16 14:56

Jag har en Griffin Powerwave kopplad till den ena USB-porten på min Sawtooth, som är jämngammal med din kub. Den har fungerat helt suveränt. Visserligen så ger den "bara" 16-bit/44,1kHz, men det duger åt mig. Deras programvara Final Vinyl funkar också bra.

http://www.griffintechnology.com/products/powerwave/

Griffin har i dagarna lanserat en FireWave. Men jag gissar att den "bara" ger ljud ut. Kan inte utläsa huruvida den har ljud-ingångar eller ej från deras hemsida.

http://www.griffintechnology.com/products/firewave/

1
Bevaka tråden