Högre hastighet med router än utan

Tråden skapades och har fått 5 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2004-06-08 19:18

Jag har ett litet problem som jag hoppas någon här inne kan förklara för mig

Jag är uppkopplad via Mälarenergis stadsnät och använder där Labs2 som operatör. Hastigheten är 10Mbit/s halvduplex.

Om datorn (G5:a 1.6) är inkopplad direkt till nätverksuttaget i väggen så får jag hastigheter på ca 7Mbit/s (TCP mottagning) när jag mäter med TP-test.

Men om jag istället kopplar datorn via routern så når jag hastigheter på ca 9 Mbit/s !!

Routern är en vanlig simpel Dlink DI-604.

Borde jag inte förlora i hastighet när trafiken går via en router ?

Kikar jag i "Nätverksverktyg" så står anslutningen som 10Mbit när jag kör utan router och som 100Mbit med router.

Är det detta som orsakar fenomet eller har ni några andra idéer ??

Ursprungligen av Mikael S:

1 - Borde jag inte förlora i hastighet när trafiken går via en router ?

2 - Kikar jag i "Nätverksverktyg" så står anslutningen som 10Mbit när jag kör utan router och som 100Mbit med router.

1) Nej, det ska du inte göra.
2) Routern och din dator pratar säkert i 100 mbit mellan varandra sedan är det routern som pratar mot internet med 10 mbit.

Vad dit "problem" kan bero på har jag lite svårt att utröna. Hmmm...
Du borde ha samma hastighet hela tiden.

När du säger halvduplex, hur har du tagit reda på det?

  • Oregistrerad
  • 2004-06-08 20:19
Ursprungligen av Mattias Hedman:

När du säger halvduplex, hur har du tagit reda på det?

Att stadsnätet endast är halvduplex? Det är vad Mälarenergi/Labs2 specificerar på sina hemsidor.

Ursprungligen av Mattias Hedman:

1) Nej, det ska du inte göra.

Med en så pass enkel router kan man räkna med en prestandaförsämring i dessa hastigheter.
Testar man en brandvägg som har möjlighet att slå på och av adressöversättning, märker man att utan adressöversättning får man 10-20% högre prestanda.
Har däremot router så mycket muskelkraft att bandbredden på interfacen blir flaskhals, är det en annan sak.

Mikael, har du ställt hastighet och duplex manuellt på datorn? (Går i 10.3)
Om inte kan du kolla på ifconfig i terminalen och se vad den står på där.
Kanske är det så att datorn får för sig att förhandla full duplex, medan stadsnätet kör halv duplex. Detta orsakar kollisioner och omsändningar. Således lägre nettohastighet.
Tyvärr händer det lite då och då att autonegotiation på ethernetnivå inte alltid fungerar mellan olika tillverkare. Jag vet inte vad första utrustning du ansluter till är. Fiberkonverter? Switch? Jag vet att de kör med Nortel-switchar i stamnätet. Men om det är Nortel i ändarna vet jag itne.

  • Oregistrerad
  • 2004-06-09 11:06

Har nu testat att ändra på duplex och hastigheter men med samma resultat.

Ett ytterligare problem är att jag måste ha en box till iptelefonen inkopplad mellan routern och nätverksuttaget och då sjunker hastigheten igen till ca 7 mbit dvs till samma hastighet som när jag kör med datorn ansluten direkt tll väggen.

Även testat med PC´n med samma resultat, dvs om den är kopplad direkt till väggen så får jag ut 7 mbit och via routern ca 9 mbit.

Så det verkar som om routern lyckas kommunicera bättre än vad som är standard för vad ett nätverkskort som är inställt på 10 mbit klarar.

Märkligt problem är det iaf

1
Bevaka tråden