Webalizer

Tråden skapades och har fått 6 svar. Det senaste inlägget skrevs .
1

Är det någon som lyckats installera Webalizer under Mac OS X 10.3? Jag får inte det inkluderade perl-skriptet att köra, de andra bifogade skripten funkar...

vad säger han när du kör perl skriptet?

Ursprungligen av johan dansk:

vad säger han när du kör perl skriptet?

Det går inte att köra det alls. När jag dubbelklickar på det öppnas det i BBEdit, till skillnad från de andra bifogade skripten som kör. Är det någon skillnad på att köra i det i bash eller i tsch? Skriptet är ju skrivet på 10.2-tiden...

Tack för tipset, Danne. Ska kolla på det...

  • Medlem
  • Karlstad
  • 2004-03-17 10:34

Har du besvär med webalizer, så kolla AW Stats. IMHO visar den t.ex. referring sites bättre är Webalizer:
http://awstats.sourceforge.net/

  • Medlem
  • Karlstad
  • 2004-03-17 10:40

Har du besvär med webalizer, så kolla AW Stats. IMHO visar den t.ex. referring sites bättre är Webalizer:
http://awstats.sourceforge.net/

perl script måste du köra ifrån terminelen eftersom du har (precis som mig) lagt till att perl filer ska öppnas med bbedit.

så, i terminlen, i rätt katalog, skriver du "perl foo.pl" för att köra skriptet genom perl programmet.
om du kör det i bash, zsh, tsch eller vilket annat som helst spelar ingen roll eftersom skriptet körs av perl...

Jag gissar rent spontant på att de andra skripten är sk. shellscripts eller har körbarhets rättigheter, vilket att anledningen till att du kan köra dom ifrån findern..

Ok, nu har jag fått tid att testa igen...

Alla skripten är Unix Executable files, men det är bara installationsskriptet (install-osx) som öppnas i BBEdit. Om jag kör det i terminalen med 'sudo ./install-osx' får jag svaret 'command not found'. Om jag försöker köra det med 'perl install-osx' händer ingenting (inte heller om jag lägger till .pl som filändelse). Jag kommer bara direkt tillbaka till prompten.

Första raden i skriptet är '#! /usr/bin/perl' om det är till någon hjälp...

1
Bevaka tråden