Intervall i Excel

Tråden skapades och har fått 3 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2004-01-23 15:05

Jag vill skriva en formel i Excel som skriver ut ett ord om värdet i en cell befinner sig inom ett visst intervall. Till exempel: Om A1 är mellan 0 och 20 så ska den säga "intervall 1" och om det är mellan 20 och 40 så ska den säga "intervall 2" osv... (Det är alltså en lång kolumn med siffror som i kolumnen bredvid ska delas in i olika intervall. Det kanske går att lösa på något helt annat sätt???)

Jag tycker själv att det borde vara ganska enkelt, men jag lyckas inte. Finns det något tecken för "mellan"? Jag provade med kolon eftersom man använder det när man anger cellintervall, men det gick inte alls.

Förslag på lösning?

  • Medlem
  • Stockholm
  • 2004-01-23 16:32

efa,

Testa att kopiera in nedanstående rad. Har du engelskt office så glöm inte att ändra "om" till "if". Och börja din tabell vid A1. Du kan alltid markera och flytta den senare.

0-19,999 ->intervall 1
20-39,999 -> intervall 2
osv...

Kanske inte den smidigaste lösningen men det verkar funka. Någon annan har säkert en bättre variant. Men annan har ju inte svarat än. Är lite krångligt med riktigt stora intervall. Hoppas du förstår principen. Fråga annars

raden:

=OM(A1<0;"Ogiltigt värde";OM(A1<20;"intervall 1";OM(A1<40;"intervall 2";OM(A1<60;"intervall 3";OM(A1<80;"intervall 4";"Ogiltigt värde")))))

  • Medlem
  • 2004-01-23 16:38

Hej Kambei och tack för lösningsförslaget. Tyvärr fungerar det inte riktigt. Som du gjort blir det:

1-19,9999 -> intervall 1
1-39,9999 -> intervall 2
Alltså intervall 1 ingår i intervall 2.

Jag testade tidigare med två större/mindre-än-tecken men fick inte det att fungera heller (alltså 0<A1<20 och 20<A1<40).

Fler förslag???

EDIT: Kanske det fungerar ändå.. testar nu igen med din formel och det verkar gå bra nu!! Så tack!

EDIT 2: JO! Det fungerar perfekt! Tack!

Senast redigerat 2004-01-23 17:35
  • Oregistrerad
  • 2004-03-03 00:33

En kortare variant skulle vara:
=SAMMANFOGA("Intervall ";HELTAL(A1/20)+1)

1
Bevaka tråden