X11 på fel skärm

Tråden skapades och har fått 7 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Umeå
  • 2004-01-09 22:52

Har tv'n kopplad som andra skärm till datorn, när jag kör x11 och applikationer i denna så öppnas de alltid på tv-skärmen... Det är det enda program som gör så och det är lite irriterande att måsta slå på tv'n för att kunna dra över fönstret till min vanligt skärm. Har inte hittat någon inställning som låter mig ändra vilken av skärmarna X11 skall använda som förval...

Någon som har en bra lösning?

Hade jag haft två vanliga skärmar hade jag nog uppskattat en liknande grej, men nu är det bara störande...

  • Medlem
  • 2004-01-10 01:52

Koppla ur TV:n?

  • Medlem
  • International user
  • 2004-01-10 10:17

Kan export DISPLAY=localhost:1 hjälpa?

placera tv:n till höger om bildskärmen... alltså i System Preferences

  • Medlem
  • Umeå
  • 2004-01-10 14:57

Loranga: nope... såvida jag inte missförstått... Jag testade skriva det i X11 terminalen...

Anders: Det är där jag har den nu...

  • Medlem
  • International user
  • 2004-01-10 15:58

hmm, du får nog köra det i Terminal.app innan du startar X11.

  • Medlem
  • International user
  • 2004-01-10 22:37
Citat:

Skrevs ursprungligen av Bonish
Anders: Det är där jag har den nu...

Testat att ha den på vänster sida då? Har det någon betydelse?

För mig iaf hamnar X11 fönster uppe till vänster, så för att undvika att de ska hamna på TV:n har jag placerat den nere till höger.

Annars kan man när man startar program från terminalen lägga till flaggan -geometry +<avstånd från vänstra kanten>+<avstånd från toppen>

exempel:

xterm -geometry +200+200

Man kan även byta + till - och få avstånden mätta från hörnet nere till höger.

OBS! Detta kanske inte funkar med alla program...

1
Bevaka tråden