Ehum Svenska tecken? (åäö alltså)

Tråden skapades och har fått 18 svar. Det senaste inlägget skrevs .
1
  • Oregistrerad
  • 2003-12-12 01:10

Hur får man svenska tecken i terminalen (bash)?

Har för mig att jag körde bash även i debian och inte hade några problem där. Nån inställning, månne?

  • Medlem
  • Svedala
  • 2003-12-12 12:38

Öppna menyn "Terminal", välj "Fönsterinställningar".
Där väljer du "Skärmutseende" och ställer in "Västerländsk (ISO Latin1)".
Det borde fixa biffen!

  • Oregistrerad
  • 2003-12-12 12:47

Jag har testat alla möjliga inställningar i terminalen (inklusive skärmutseende -> teckenkodsuppsättning) men inga inställningar verkar spela någon roll. Knapparna å,ä och ö fungerar inte i alla fall.

Någon som fått det att fungera?

  • Medlem
  • Svedala
  • 2003-12-12 13:40

Inte direkt i BASH, men i andra program som körs i terminalen fungerar det utmärkt.

Jag hade å, ä och ö i bash innan, men testade lite andra teckenuppsättningar efter att ha läst här. Nu får jag bara massa konstiga koder iställer för å, ä och ö. Det kan alltså funka... men man SKA inte pilla med ngt som funkar.

RÄTTELSE:
Jag hade naturligtvis inte å, ä och ö i min bash på macen. I hastigheten blandade jag ihop min lokala burk och min server med slackware.

  • Oregistrerad
  • 2003-12-14 19:37

Om man kör t ex emacs i terminalen med latin-1 så borde ju åäö fungera, men det gör det INTE!!!

Mycket irriterande tycker jag, eftersom jag ofta använder text-editorer från terminalen. Kan det vara så att det är bash som gör att åäö inte fungerar?

Det kan ju bara inte vara så här det är tänkt att "fungera"...

Man har ju även filnamn som innehåller åäö vilket leder till problem...

  • Medlem
  • Tyresö
  • 2003-12-14 21:44

$ cat .inputrc
set show-all-if-ambiguous on
set completion-ignore-case on
set completion-query-items 200
set convert-meta off
set input-meta on
set output-meta on

input/output tror jag löser åäö problemen.

  • Oregistrerad
  • 2003-12-14 22:59

Om du vill ha åäö i emacs så skapa en .emacs fil i din hemkatalog med följande innehåll.

(set-input-mode t nil 'iso)
(standard-display-8bit 160 255)
(standard-display-european t)
  • Medlem
  • International user
  • 2003-12-15 00:24

Gäller det även för carbon versionen av emacs? Jag har samma problem där som i terminalen nämligen. Får testa imorgon isf.

  • Medlem
  • Höganäs
  • 2003-12-16 22:48
Citat:

Skrevs ursprungligen av mr_sandin
...
Det kan ju bara inte vara så här det är tänkt att "fungera"...

Man har ju även filnamn som innehåller åäö vilket leder till problem...

Håller med!

Hur gör man för att fixa detta. Nu kan man (dvs jag) ju inte navigera i mappar med åäö i namnen!

Lösning efterlyses!

För navigationen kan fu använda "name completion". Tryck på tab när du skrivit in början av fil/mapp-namnet och se vad som händer.

Börjar namnet på ngn konstig vokal kan man i nödfall köra med något i stil med "?vrigt" om nu mappen heter övrigt. (? byts ut mot valfri bokstav av systemet)

  • Medlem
  • Höganäs
  • 2003-12-17 00:05
Citat:

Skrevs ursprungligen av mrubenson
För navigationen kan fu använda "name completion"....

Jo. Det funkar!
Men inte är det så smidigt, men det är klart: Terminalen är ju inte särskilt "Apple-ish"...;)

Tack

  • Oregistrerad
  • 2003-12-18 17:59

lösningen
set input-meta on
set output-meta off
fungerar ändast i bash, och inte ens där om man kör tex pine...
kör man däremot pico, får man fram åäö men det infogas också en radbrytning efter varje sådant tecken, så en lite mer komplett lösning efterlyses..

  • Medlem
  • Tyresö
  • 2003-12-18 22:23

Provate att starta X11 och en xterm. Där funkar pico perfekt med svenska tecken. Om jag kör pico i en Terminal så blir det precis som du beskriver, infogade radbrytningar och sånt.

  • Medlem
  • Tyresö
  • 2003-12-18 22:27

Aha, precis när jag skickat så fick jag det att funka i Terminalen också. Ta upp Höger musknapp | Window Setting | Emulation. Ta bort bocken på "Escape non-ACSII characters".

  • Oregistrerad
  • 2004-01-21 23:35

suck... Av nån anledning (jag meckade väl omkring lite med inställningarna iofs...) så har jag inga svenska tecken i Terminal.. Jovisst - de funkade precis när Panthern var nyinstallerad. Verkar inte spela nån roll hur vilka options jag än väljer i Fönsterinställningarna, åäö vägrar dyka upp. Allt jag ser är: \303\244\303\245\303\266

please help!!!

Citat:

Skrevs ursprungligen av sganslandt
lösningen
set input-meta on
set output-meta off
fungerar ändast i bash, och inte ens där om man kör tex pine...
kör man däremot pico, får man fram åäö men det infogas också en radbrytning efter varje sådant tecken, så en lite mer komplett lösning efterlyses..

Räcker inte detta?

  • Oregistrerad
  • 2004-01-22 16:56

Det räcker inte (med set grejorna ovan) men om jag kör zsh så är det inga probs... :-/
go figure...

1
Bevaka tråden