VPN i Server 10.3?

Tråden skapades och har fått 11 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Haparanda
  • 2003-11-15 19:36

Det fanns tydligen någon undangömd och buggig funktion för VPN i 10.2-servern men jag läser på 99mac att 10.3 innehåller VPN via IPSEC. Någon som kör detta? Erfarenheter?

Bara faktumet att VPN finns skulle få mig att omedelbart skaffa 10.3-server.

  • Medlem
  • Höganäs
  • 2003-11-15 19:50

VPN finns ju i klienten, men det är ju bara en klient...
Vet inte, men det borde rimligtvis ha lyfts upp och gjorts lika smidigt i serverversionen...
(Ett uppenbart icke-svar på din fråga, jag vet... Sorry!)
Ps. Vart i Tornedalen?

Ut & handla 10.3 server...

Jodå, det finns VPN.

L2TP över IPsec och/eller PPTP.

Har inte slagit på det (installerade 10.3 server på min 17" PB igår, och VPN in är inte det första jag leker med...).

VPN via PPTP har jag provat på klienten för att logga in mot våran VPN server som går på en Win 2000.
Det fungerar perfekt kan jag säga.
Inga som helst problem.

Tack för det Apple.

  • Medlem
  • Haparanda
  • 2003-11-16 11:18

Härligt, tack för bra svar. Ska genast ta ett snack med vår leverantör. VPN-stödet löser en hel rad med grejer för mig.

Det är detta jag gillar med Apple. Det kommer grejer inbyggda som gör att man slipper köpa dyra lösningar. För några år sedan rekommenderades jag att skaffa en LANRover för 25 tkr för att klara inringning till nätverket. Det löste sig genom att aktivera ARA-funktionen som är inbyggd i os9. Kostnad: 0:- Detta är dock en funktion som jag saknar i osx. Jag ska lägga ut en fråga om det som en ny diskussion. http://99mac.se/forum/showthread.php?s=&threadid=33934

Svar till Micke F: Haparanda.

Försöker få igång VPN mellan min 10.3 server och min 10.3 klient (klienten sitter på Chello/UPC och bakom en D-Link WLAN router).

Är det något man behöver trixa till?
El något man kanske glömt på serversidan, har konfiggat PPTP.
Får nämligen inget svar när jag kör VPN connect via Internet Connect.

  • Medlem
  • Haparanda
  • 2003-11-20 22:13

Fick just en rapport från en som startat upp VPN via IPSec. Klick, klick, klart. Funkade. Det ska inte behövas några särskilda krav på adsl-modem eller -abonnemang för att kunna koppla upp, sägs det.

Inget krångel alltså. Dags att kuta iväg med beställning av 10.3-licenser.

Citat:

Skrevs ursprungligen av Jürgen B
Försöker få igång VPN mellan min 10.3 server och min 10.3 klient (klienten sitter på Chello/UPC och bakom en D-Link WLAN router).

Är det något man behöver trixa till?
El något man kanske glömt på serversidan, har konfiggat PPTP.
Får nämligen inget svar när jag kör VPN connect via Internet Connect.

Många NAT-routrar har problem att adressöversätta PPTP/IPSec. Detta pga att de använder GRE eller ESP som är andra IP-protokoll än TCP och UDP. Dessa har inga portar, vilket många NAT-routrar hänger upp sig på. Vi utgående NAT mappar routrar generellt klientens source-port och mappar denna till den source-port routern väljer för den externa sessionen. På så sätt kan två klienter ansluta till samma server på internet med samma source-port (om slumpen skulle slumpa sig illa) och ändå fungera bra eftersom NAT-routern väljer olika source-portar för sessionen externt.
Men som sagt, när GRE och ESP skickas finns inte några portar. Då får routerna tuppjuck....
Dock börjar det bli mer och mer vanligt med senaste programvarorna till routrarna. En annan lösning är från klienttillverkarna som börjar implementera stöd för NAT-traversal vilket innebär att IPSec-paketen (finns inte för PPTP som inte är särkilt modernt...) inkapslas i UDP-paket, och på så sätt kan NAT:as. Kvarstår gör dock problematiken med två klienter bakom samma NAT-router som ansluter till samma VPN-server då NAT-T-standarden (tror det är någon slags standard) använder samma source- som destinationsport (4500). NAT-routern får alltså svårt att skilja dem åt. Och ändrar den source-porten falerar protkollet.

Tillägg: L2TP kör på UDP port 1701 med dynamisk sourceport. Mao NAT-vänligt.

Bra förklaring.. tack
L2TP gick mycket bättre..

uppe o snurrar.

Jag har confat VPN (L2TP/IPSec) men kan inte få det att starta. Det blinkar bara till på den gröna pluppen i Server Admin när jag klickar Start Service. Jag läste på Apple Discussions att man skulle lägga upp en preshared key, men var gör man det? Det finns ju bara ett fält för "IPSec shared secret" i Server Admin...

/Pär

Kan nån lista exakt vilka portar som måste öppnas i en brandvägg (ej den i OS X inbyggda) för att VPN via L2TP ska fungera?

1
Bevaka tråden