Förvalt mailprogram stannar inte

Tråden skapades och har fått 6 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Göteborg
  • 2016-09-27 18:17

Hej!

Har problemet att när jag väljer Outlook (2016) som förvald mailklient i Mail.app - Inställningar så behåller den inte Outlook.

Om jag inte väljer Outlook ur listan utan klickar "Annat" och sen väljer Outlook så öppnar den Outlook nästa gång jag klickar på en mailto-länk. Efter det går den tillbaka till Mail.app som förvald.

OS X 10.11

Några tips?

  • Medlem
  • Örnsköldsvik
  • 2016-09-27 18:30
  • Medlem
  • Göteborg
  • 2016-09-27 20:32

Ja? Det var ju precis det jag skrev i först stycket? Inställningen sparas dock inte!

  • Medlem
  • Göteborg
  • 2016-09-27 23:51

Vilken version av Outlook?

Jag testade just (också på OS X 10.11) med min gamla Outlook 2011 (version 14.6.6) och fick precis samma beteende som du. När jag ändrar i Mails inställningar att Outlook ska vara förvald mailklient så räcker det at jag stänger ner inställningspanelen och öppnar igen så har det återgått till Mail.app som förval.

Jag tänkte att man kanske behöver ha åtminstone ett mailkonto inlagt i Outlook (använder det normalt inte) så jag la in ett konto. I samma veva kryssade jag i motsvarande ruta i Outlooks Inställningar > Allmänt > Gör Outlook till standardprogram. Det var antagligen den sista åtgärden som gjorde susen, nu öppnar alla mailto-länkar Outlook. Det räcker tydligen inte att bara göra inställningen i Mail.app.

Nu ska jag bara ändra tillbaks...

  • Medlem
  • Göteborg
  • 2016-09-27 23:57

Och samma beteende när man ska ändra tillbaks. Måste kryssa ur inställningen i Outlook. När jag stängde Mail stod det i dess inställningar att Outlook var förvalt. Sedan kryssade jag ur inställningen i Outlook och stängde det programmet. Nästa gång jag tryckte på en mailto-länk öppnades Mail och i dess inställnngar står det att Mail är förvalt epostprogram, alltså utan att jag någonsin aktivt ändrade tillbaks inställningen i Mails inställningar.

Slutsats: Office 2011 nästlar sig in i OS X värre än OS X egna program

  • Medlem
  • Göteborg
  • 2016-09-30 08:40

Hej, förlåt för sent svar!

Med 2011 har jag också fått detta att fungera precis som du skriver, men det är Outlook 2016 som problemet blir på och där hittar jag ingen knapp i inställningar att göra det till standard.

  • Medlem
  • Göteborg
  • 2016-09-30 10:10

Ja, nu ser jag att du skrev att det gällde Outlook 2016.

Här är ett tips om att återställa databasen för LaunchServices till förvalda värden för alla filtyper/appar, ifall databasen blivit korrupt. Man får alltså göra om andra app-förval man gjort tidigare, men det verkar lösa problemet med Mail-inställningen i El Capitan
https://forums.developer.apple.com/thread/145...

1
Bevaka tråden