WD My Passport fungerar bara delvis - trasig nätdel eller är det kört?

Tråden skapades och har fått 11 svar. Det senaste inlägget skrevs .
1

Har en extern hårddisk, Western Digital My Passport 2TB USB 3.0 som jag kör till min Macbook Pro.

Satt och tömde ett CF-kort med semesterbilder imorse då plötsligt "Extern matades inte ut korrekt" dök upp och hårddisken försvann.

Började min felsökning:
- Koppla in/ut hårddisken
- Starta om datorn
- Testa annat USB-uttag
- Testa genom USB-hubb med extern strömförsörjning

Disken dyker upp i skivverktyg, men jag upplever att det tar längre tid än normalt. Den enda partitionen som finns täcker hela diskens kapacitet och den dyker inte upp på skrivbordet automatiskt. Testade att köra "lägg till på skrivbordet" och det fungerade! Däremot kan jag bara se mina tre huvudkataloger och katalogerna under det, inga filer. Infon om partitionen gällande utrymme etc. i skivverktyg verkar också stämma.

Känns ganska skönt att det inte verkar helt kört i alla fall, men frågan är ju då: hur går jag vidare?

Har läst runt lite om att många externa hårddiskar får problem med elektroniken som hör till kabinettet. Tyvärr verkar ingen riktigt beskriva symptomen som uppstår då. Kan det vara så, att kabinettet inte kan leverera tillräckligt med spänning så att disken inte klarar av att jobba ordentligt? Har inte vågat öppna detta än för att undvika att en ev. garanti bryts med det. Har inte testat i någon annan dator, men mina andra externa hårddiskar fungerar felfritt.

Vad tror ni? Är det kört eller låter min teori om kabinettet trovärdig?

Därför jag slutade med externa diskar, går sönder efter ett tag (ofta förr än senare), gick över till NAS och har inte haft några som helst problem sen dess. Dessutom i en NAS så kör man oftast med någon typ av RAID (inte 0) och kan därmed byta ut en felande disk om någon skulle rasa och fortfarande ha sin data intakt.

Elektroniken i externa USB/FW-diskar etc. verkar vara undermålig inkl. AC-adaptern, och kan om man har otur förstöra hårddisken i sig också.

Beroende på om du har backup eller inte och hur viktig din data är så kan du välja att prova med ny elektronik (om det finns tillgängligt), ny AC-adapter eller plocka ur disken ur kabinettet och sätta i den i ett annat kabinett.

Jag gav upp efter 7-8 rasade USB/FW-diskar innan jag gick över till NAS, skulle gjort det tidigare.

  • Medlem
  • Neverland
  • 2016-08-09 00:55

Ibland kan en ny USB-kabel göra underverk.

Just Western Digital verkar ha en vek USB-hona på vissa modeller. Jag har varit med om detta och man får ibland "rycka" lite i kontakten för att det ska funka. Med ibland menar jag fler gånger än en, men inte så ofta att jag sett det som alarmerande då jag hanterar närmare hundra sådana. Det har löst sig med lite "ryckande" och "vickande" i mina fall. Om så ej hade jag slaktat kabinettet och använt ett nytt.

  • Medlem
  • Helsingborg
  • 2016-08-09 09:50

Kom ihåg!

RAID är inte backup!

EDIT: inlägget var ämnat dig @keptang

Senast redigerat 2016-08-09 10:07
  • Medlem
  • 2016-08-09 10:03
Ursprungligen av olyckan:

Har en extern hårddisk, Western Digital My Passport 2TB USB 3.0 /.../ Vad tror ni? Är det kört eller låter min teori om kabinettet trovärdig?

Mycket trovärdig. Jag har plockat ut flera hårddiskar ur WD-kabinett och hårddiskarna har då visat sig fungera alldeles utmärkt.

Ursprungligen av illerG:

Kom ihåg!

RAID är inte backup!

Det finns inte så mycket RAID i en WD My Passport Ultra USB 3.0 2TB som TS har. Så det hjälper inte.

Men du har rätt.

  • Medlem
  • Helsingborg
  • 2016-08-09 10:07
Ursprungligen av keptang:

Det finns inte så mycket RAID i en WD My Passport Ultra USB 3.0 2TB som TS har. Så det hjälper inte.

Men du har rätt.

Inlägget var ämnat dig @keptang

Ursprungligen av illerG:

Inlägget var ämnat dig @keptang

Aldrig påstått att det är backup, när det kommer till backup så har jag dubbla hängslen och livrem, men det hjälper inte @olyckan.

  • Medlem
  • 2016-08-09 10:09
Ursprungligen av keptang:

Därför jag slutade med externa diskar, går sönder efter ett tag (ofta förr än senare), gick över till NAS och har inte haft några som helst problem sen dess. ...

Du har antagligen rätt. Ändå har jag i drygt tre år kört en billig USB3-Verbatimhårddisk från Kjell.com utan problem. Man ska ha tur som en tokig ibland (fast när man skriver detta lär man väl snart få ångra sina ord...).

Tack för svaren!

Öppnade upp chassit till disken nyss. Den ser inte ut som de andra 2,5"-diskar jag sett tidigare, utan USB 3.0-porten sitter här fast direkt på hårddisken - en renodlad USB-disk? Kan därmed inte använda den i ett kabinett från mina andra externa hårddiskar, som är vanliga 2,5" SATA-diskar...

Testade att ansluta disken utan chassi till datorn igen och den dök åter igen upp i Finder. Kan se alla filer, i det här fallet foton, men att läsa dem eller kopiera till datorns interna disk går sådär. Lyckades få ut några bilder, men nu går det trögt igen och överföringen fastnar på "Förbereder kopiering till "Skrivbord"...

Kopiera över delmängder. Prova på annan dator.

  • Medlem
  • 2016-08-09 12:48

Eller använd ett dataräddningsprogram som Photorec. Det är gratis och körs via Terminalen. Räddar mer än bara bilder, för övrigt. Programmet kan arbeta med eller utan fungerande filsystem (man väljer "Whole" när man väljer partition för att få med såväl existerande som raderade filer).

1
Bevaka tråden