Macbook Air 13" 2012 problem

Tråden skapades och har fått 7 svar. Det senaste inlägget skrevs .
1

Hej!

Jag har köpt en Macbook Air 13" 2012 som defekt som jag försökt få ordning på. Det är modell A1466 med i5 1.8, 4GB RAM och 128GB SSD.

Förra ägaren har haft problem med SSD och misstänkte att den var defekt. När jag fick hem den så hittar den inte SSD alls. Så jag har tagit ut den och installerat OS på en extern disk.

De andra problemen är att fläkten går för fullt hela tiden, belysningen i tangentbordet fungerar inte samt att den inte hittar batteriet.

Just nu är Montain Lion installerat via internet recovery på en extern SSD via USB3, då installationen av El Capitan krashar varje gång.

Det finns inga program som ligger och belastar CPU och allt annat verkar funka bra.

Jag har provat med syrrans batteri och då startar den utan laddare men med samma problem annars. Den hittar inte det batteriet heller. Laddaren lyser inte varken grönt eller orange med något av batterierna.

Är det någon här som skruvar själv med sin Mac och kan tipsa om vad jag bör prova? Det känns inte värt det att lämna in den för felsökning p.g.a åldern.

Jag har även resetat SMC och PRAM flera gånger utan resultat.

Senast redigerat 2016-04-29 19:17

Du har provat annat batteri? Har du kollat om alla tempratur sensorer funkar som dom ska?

Ursprungligen av skrotnisse92:

Du har provat annat batteri? Har du kollat om alla tempratur sensorer funkar som dom ska?

Ja jag har provat med syrrans batteri som funkar bra i hennes dator. Dock samma problem i min dator som med mitt eget batteri. Hur kollar jag temperatur sensorerna?

Ursprungligen av Zeecor:

Ja jag har provat med syrrans batteri som funkar bra i hennes dator. Dock samma problem i min dator som med mitt eget batteri. Hur kollar jag temperatur sensorerna?

Jag använder istat menus för att kontrollera sådant men det finns säkert något smartare sätt. Spontant känns det som att det skulle kunna förklara fläkthastigheten.

Imponerande då det är ändå lite jobb att byta batteri på två styckan MBA.

Efter lite (en jävla massa) skruvande så fungerar nästan allt. Jag skruvade ner den i småbitar och rengjorde allt och bytte kylpasta osv. Så antagligen var det glapp någonstans eller smuts i någon kontakt.

Fläktfelet kvarstår dock, samt att den är extremt slö. Kernel_task suger i sig ett par hundra procent CPU. Jag körde ett Apple Hardware Test som gav mig felkod på en temperatursensor i hårddisken. Kan det vara så jävligt att man måste ha en fungerande intern hårddisk för att använda datorn?

  • Skribent
  • Sollentuna
  • 2016-05-03 09:00
Ursprungligen av Zeecor:

Fläktfelet kvarstår dock, samt att den är extremt slö. Kernel_task suger i sig ett par hundra procent CPU. Jag körde ett Apple Hardware Test som gav mig felkod på en temperatursensor i hårddisken. Kan det vara så jävligt att man måste ha en fungerande intern hårddisk för att använda datorn?

Prova att sätta i den gamla trasiga disken. Temperatursensorn kanske får spel av att platsen är tom och nöjer sig med att det sitter något där.

Ursprungligen av Vassius:

Prova att sätta i den gamla trasiga disken. Temperatursensorn kanske får spel av att platsen är tom och nöjer sig med att det sitter något där.

Jag glömde nämna det, men disken sitter i igen. Det är ingen skillnad med eller utan intern disk.

Det lutar åt att försöka få tag på en ny disk men de är ju inte direkt billiga Jag har en adapter på väg från Kina som gör att man kan använda M.2 SATA SSD. Är det någon som har erfarenhet av en sån adapter?

Jag hittade en original SSD som tydligen är helt ny. Vid montering var det ingen skillnad förutom att datorn hittade SSDn. Så efter en sista genomgång så skruvade jag ihop den och tänkte lägga den på hyllan, men nu fungerar den Tyst och snabb och jag fick en firmware uppdatering till SSDn från Appstore så den nya ska väl hålla ett tag.

1
Bevaka tråden