Väcka iMac remote, via iPhone

Tråden skapades och har fått 47 svar. Det senaste inlägget skrevs .
  • Medlem
  • Östra Göinge
  • 2016-04-01 10:13

Någon som har fått det att fungera, att kunna väcka sin iMac som man lämnat i viloläge - via en iPhone?

Fick först ett tips om en app som heter WakeUp och skapade port forward för den i min router men får det inte att funka.

Läste då på annat håll om annat pgm/app som heter CloudPocket.
Har inte testat att installera den än.
Någon som har goda erfarenheter av den - eller har tips om ngt annat som funkar bra?

Börjar samtidigt fundera kring om en lösning för detta behov på ngt sätt kan äventyra min säkerhet vad gäller access till datorn... Obefogad tanke?

Mitt syfte att få till lösning för detta är att remote kunna nyttja framförallt Plex, där Plex-servern är placerad på just iMacen. (Mediafilerna på en NAS, som är konstant på.)

Mocha VNC lite vet jag fungerar. Men det kräver att datorn är ansluten via nätverkssladd och att "Vakna för nätverksåtkomst" är igång på datorn. Ska inte kräva ngn portforwarding, iaf inte inom samma nät.
Kan du inte köra direkt från NASen? Vilken har du?

  • Medlem
  • Östra Göinge
  • 2016-04-01 12:15
Ursprungligen av reboot81:

Mocha VNC lite vet jag fungerar. Men det kräver att datorn är ansluten via nätverkssladd och att "Vakna för nätverksåtkomst" är igång på datorn. Ska inte kräva ngn portforwarding, iaf inte inom samma nät.
Kan du inte köra direkt från NASen? Vilken har du?

OK, tack. Skall ladda hem den.

Datorn ansluten via nätverkssladd - yes det är den.

... "i a f inte inom samma nät". Menar du när man är i bostaden? Det är inte det jag menar i a f, utan anslutning när man är "ute på stan" eller hemma hos ngn. D v s 3G/4G respektive i någon annans trådlösa nätverk.

Tyvärr funkar inte min NAS som Plex mediaserver. Stöds inte. (Buffalo Linkstation LS220D.)

  • Medlem
  • Östra Göinge
  • 2016-04-01 12:54
Ursprungligen av Tommy66:

... "i a f inte inom samma nät". Menar du när man är i bostaden? Det är inte det jag menar i a f, utan anslutning när man är "ute på stan" eller hemma hos ngn. D v s 3G/4G respektive i någon annans trådlösa nätverk.

Nope. Dess Wake Up funkar inte med 3G. Åtminstone har jag inte lyckats. Månne ngn inställning som kan lösa det?
Inom samma nätverk, d v s i bostaden, finns funktionen och fungerar hos mig. Men det är alltså inte mitt behov.

  • Medlem
  • Malmö
  • 2016-04-01 13:14

Har du en hyfsat modern NAS så kan du ju sätta upp en VPN-tjänst på den. Då kan du ju ansluta till den VPN:en och väl ansluten köra WOL via valfri app.

Forwarda då port 9 till port 9 för datorns IP-adress, och sätt statisk adress på din dator.
http://www.noip.com/ kan vara till hjälp, utifall att ditt modem inte bibehåller externa IP-adressen.

  • Medlem
  • Östra Göinge
  • 2016-04-01 20:36
Ursprungligen av reboot81:

Forwarda då port 9 till port 9 för datorns IP-adress, och sätt statisk adress på din dator.
http://www.noip.com/ kan vara till hjälp, utifall att ditt modem inte bibehåller externa IP-adressen.

Du menar att ovanstående löser "3G"-behovet/scenariot?

Statisk adress på iMacen... får inte det negativa konsekvenser någonstans (i övrigt)?
T ex kräver att jag justerar andra saker - som jag använder datorn till?

Ursprungligen av Tommy66:

Du menar att ovanstående löser "3G"-behovet/scenariot?

Statisk adress på iMacen... får inte det negativa konsekvenser någonstans (i övrigt)?
T ex kräver att jag justerar andra saker - som jag använder datorn till?

Ja.
Nej.
Justerar vadå tex?

  • Medlem
  • Östra Göinge
  • 2016-04-02 08:04
Ursprungligen av reboot81:

Ja.
Nej.
Justerar vadå tex?

Statisk IP-adress på iMacen betyder att jag under Systeminställningar/Nätverk/Ethernet/TCP/IP ändrar Konfigurera IPv4 från Med DHCP till Av? Eller till Manuellt, följt av...?

Eller i routern.

  • Medlem
  • Östra Göinge
  • 2016-04-02 11:15
Ursprungligen av reboot81:

Eller i routern.

OK, någonstans i inställningarna enl nedan då?

Noterar nu att det finns en rubrik (i routerinställningarna, Telias router) som heter 3G/4G, det råkar inte vara så att det är där man skall ställa in något - som åstadkommer det jag är ute efter?

Nej det har inget med 3/4G att göra. Port forwarding heter det.

Vad har du för router/modem?

  • Medlem
  • Östra Göinge
  • 2016-04-02 11:25
Ursprungligen av reboot81:

Forwarda då port 9 till port 9 för datorns IP-adress,

Samt enl nedan då?

Sen har jag inte riktigt fått in i skallen vad som är min "dators/iMacs IP-adress" resp "mitt elektroniska face/id mot omvärlden"-ip.
Den ena hittar man ju på http://www.whatsmyip.org/.

  • Medlem
  • Östra Göinge
  • 2016-04-02 11:26
Ursprungligen av reboot81:

Nej det har inget med 3/4G att göra. Port forwarding heter det.

Vad har du för router/modem?

Technicolor, MediaAccess TG799vac.

  • Medlem
  • Östra Göinge
  • 2016-04-02 11:41

Många skärmdumpar nu...
Men såg ngt om "ping" när jag nyttjade Mocha VNC lite och försökte ansluta (väcka) med just 3G/iPhonen.
Ser Ping här - i routerinställningarna...

  • Medlem
  • Karlskoga
  • 2016-04-02 12:35

I Mac, gå till Äpplet - Systeminställningar - Nätverk. Klicka på Ethernet eller Airport (den du använder) till vänster, skriv ner dina värden där på IPadress, Nätmask och Router/Gateway.
Ändra DHCP till Manuellt, skriv in de uppgifter du tidigare noterade. Under Avancerat kan du behöva skriva in DNS igen (använd samma som under Router/Gateway).
I Routern gör du en Port Forward med port 9 till det IPnummer som du skrev in i Macen.
I routern bör du även reservera det IPnumret så det inte delas ut till någon annan. Helst skulle du ändra IPnumret på Macen (och i Port Forward) till ett nummer som ligger utanför DHCP-scoopet. Men du verkar inte så haj med tcp/ip...?

  • Medlem
  • Östra Göinge
  • 2016-04-02 19:55
Ursprungligen av kenjon:

I Mac, gå till Äpplet - Systeminställningar - Nätverk. Klicka på Ethernet eller Airport (den du använder) till vänster, skriv ner dina värden där på IPadress, Nätmask och Router/Gateway.
Ändra DHCP till Manuellt, skriv in de uppgifter du tidigare noterade. Under Avancerat kan du behöva skriva in DNS igen (använd samma som under Router/Gateway).
I Routern gör du en Port Forward med port 9 till det IPnummer som du skrev in i Macen.
I routern bör du även reservera det IPnumret så det inte delas ut till någon annan. Helst skulle du ändra IPnumret på Macen (och i Port Forward) till ett nummer som ligger utanför DHCP-scoopet. Men du verkar inte så haj med tcp/ip...?

Det är en helt korrekt iakttagelse! Har ytterst begränsade kunskaper när det kommer till detta. 😝

Inte vid datorn nu men skall se om jag kan få till det efter era försök att hjälpa mig ovan.

Har bekymmer lite generellt med detta för stunden. Web access till mina två månader gamla NAS funkar inte heller just nu. Funkade ett tag. Har hittat ett användarforum för den (Buffalo) men verkar inte vara ngn som riktigt kan hjälpa mig. Å kontaktar jag Telia, routerinställningarna, så lär de avsäga sig problemet. NASen klagade (efter ett tag...?) på saknad UpNP-aktivering men enl routerns inställningar så är det visst aktiverat.
Puhh. 🤔☹️😝

  • Medlem
  • Östra Göinge
  • 2016-04-03 13:43
Ursprungligen av kenjon:

I Routern gör du en Port Forward med port 9 till det IPnummer som du skrev in i Macen.

Ovanstående betyder, för mina routerinställningar...
Protocol: TCP?
WAN port: 9?
LAN port: "IPnummer som jag skrev in i iMacen"? D v s inte Routerns IP utan det som heter IP-adress under Systeminställningar/Nätverk?

Jag känner mig i skrivande stund annars slångt ifrån att få denna lilla detalj (att kunna väcka iMacen för NAS/Plex-åtkomst via 3G) att fungera... Detta då NASen inte längre kan ansluta "till resten av systemet" längre. Puuuhhhh.
Den syns under Delat i Finder men ansluter inte och när man manuellt klickar på Anslut som så får jag meddelande om att det inträffade ett problem vid anslutning å så följande:
Servern kanske inte finns eller är inte tillgänglig just nu. Kontrollera servernamnet eller IP-adressen samt din nätverksanslutning och försök sedan igen.
Jag har under ett par timmar letat avigt och rätt bland Systeminställningar, routerns inställningar och NASens (man kommer uppenbarligen åt den) men lyckas inte på ngt sätt att få det att funka igen.
Å det är ju ett betydligt större problem än huvudämnet för denna tråd - då jag alltså nu inte kommer åt några filer på NASen.
Å jag vet inte vart jag kan vända mig få att få hjälp heller - med tanke på att felkällan kan vara flera, enl min ringa kunskap.

Det jag skulle önska mest av allt (även utifrån att UPnP för NASen funkade från början) är att helt börja om med allt som har med IP/WebAccess att göra. Men det fattar jag inte heller hur jag skall kunna göra. Åtminstone inte utan att blåsa NASen fullständigt, vilket inte på ngt sätt känns lockande.

  • Medlem
  • Karlskoga
  • 2016-04-03 17:11

WANport och LANport ska båda vara 9. Du borde ha ett fält till där din iMacs IPadress ska skrivas in (till vilken adress port 9 ska skickas).
Är man osäker kan man välja både UDP och TCP...

För att komma åt din NAS måste du kolla vilka portar som används (kanske 80?). Sedan gör du samma som ovan med rätt portnummer och den IPadress som din NAS har.

WoL går via UDP så det verkar onödigt att aktivera TCP (TCP kräver en enhet som är igång).
För att detta ska fungera kräver det också att porten/portarna är öppna av ISPn och korrekt konfigurering av routern.

  • Medlem
  • Östra Göinge
  • 2016-04-03 23:26
Ursprungligen av kenjon:

WANport och LANport ska båda vara 9. Du borde ha ett fält till där din iMacs IPadress ska skrivas in (till vilken adress port 9 ska skickas).
Är man osäker kan man välja både UDP och TCP...

För att komma åt din NAS måste du kolla vilka portar som används (kanske 80?). Sedan gör du samma som ovan med rätt portnummer och den IPadress som din NAS har.

Ok, thanx.
Ska testa, jobba vidare med frågan imorgon afton.
Om jag förstår uppgifterna i min NAS rätt så är portnumret 9000. (Där finns ett till, femsiffrigt.)
Återigen ställer jag mig samtidigt frågan varför det plötsligen inte fungerar. I listan, routerinställningarna, så har jag tidigare (när det fram tills igår funkade) sett NASen.

Men men, om jag förstår det rätt så betyder manuellt inställd port forward inte några begränsningar i övrigt, d v s inga minus? (Att det oftast inte behövs är enbart en fråga om bekvämlighet?)

  • Medlem
  • Karlskoga
  • 2016-04-04 00:53
Ursprungligen av keptang:

WoL går via UDP så det verkar onödigt att aktivera TCP (TCP kräver en enhet som är igång).
För att detta ska fungera kräver det också att porten/portarna är öppna av ISPn och korrekt konfigurering av routern.

Visst, men han vill också ha igång sin NAS utåt, vilken troligen använder TCP. Så som jag skrev, är man inte säker använder man båda. Jag har 30-talet port forwarders, ska jag läsa på/testa alla för att se vilka som använder vilket tar det längre tid än att slå på båda. Visst, det kan ses som en något större säkerhetsrisk....
Vad jag har märkt hittills har det bara varit port 25 som mina ISPs har blockat.

  • Medlem
  • Karlskoga
  • 2016-04-04 00:57
Ursprungligen av Tommy66:

Ok, thanx.
Ska testa, jobba vidare med frågan imorgon afton.
Om jag förstår uppgifterna i min NAS rätt så är portnumret 9000. (Där finns ett till, femsiffrigt.)
Återigen ställer jag mig samtidigt frågan varför det plötsligen inte fungerar. I listan, routerinställningarna, så har jag tidigare (när det fram tills igår funkade) sett NASen.

Men men, om jag förstår det rätt så betyder manuellt inställd port forward inte några begränsningar i övrigt, d v s inga minus? (Att det oftast inte behövs är enbart en fråga om bekvämlighet?)

Har du haft UnP påslaget tidigare kan det vara förklaringen till att du har sett den då.
Minus är förstås att andra kan komma åt dina grejor, så tänk på att inte ha för enkla lösenord!

  • Medlem
  • Östra Göinge
  • 2016-04-04 21:20
Ursprungligen av keptang:

WoL går via UDP så det verkar onödigt att aktivera TCP (TCP kräver en enhet som är igång).
För att detta ska fungera kräver det också att porten/portarna är öppna av ISPn och korrekt konfigurering av routern.

Ursprungligen av kenjon:

Har du haft UnP påslaget tidigare kan det vara förklaringen till att du har sett den då.
Minus är förstås att andra kan komma åt dina grejor, så tänk på att inte ha för enkla lösenord!

Kjell & co är ju erkänt duktiga pedagoger när det kommer till mkt inom teknik.
Blev tipsad om deras "utdelning med NAS"-sida och där beskrivs det inte riktigt på samma sätt.
Där pekar man på att knyta routern till en dynamisk DNS-tjänst. (Steg 7 Utdelning med NAS, Kjell&co)
Typ www.dyn.com.

Ursprungligen av Tommy66:

Kjell & co är ju erkänt duktiga pedagoger när det kommer till mkt inom teknik.
Blev tipsad om deras "utdelning med NAS"-sida och där beskrivs det inte riktigt på samma sätt.
Där pekar man på att knyta routern till en dynamisk DNS-tjänst. (Steg 7 Utdelning med NAS, Kjell&co)
Typ www.dyn.com.

DNS-tjänst, tipsade om i inlägg nr i
6.
"Kjell" är en bra källa.

  • Medlem
  • Östra Göinge
  • 2016-04-05 19:52
Ursprungligen av kenjon:

WANport och LANport ska båda vara 9. Du borde ha ett fält till där din iMacs IPadress ska skrivas in (till vilken adress port 9 ska skickas).
Är man osäker kan man välja både UDP och TCP...

För att komma åt din NAS måste du kolla vilka portar som används (kanske 80?). Sedan gör du samma som ovan med rätt portnummer och den IPadress som din NAS har.

Om jag nu förstått allt rätt så har jag nu lyckats låsa NASens IP-adress genom att i routerinställningarna Add static leases.
Men kommer inte åt NASen, no. (Med felmeddelandet enl tidigare inlägg.)
Å det skall alltså lösas genom ovan, att göra en port forward även för NASen? Med portar som används... Å då uppstår frågan hur jag hittar vilka det är? I routern, under rubriken Devices, finns alla våra enheter uppräknade och en kolumn benämnd just Port i vilken varje enhet har endera siffran 1, 3 eller 4. NASen är ensam om siffran 1. Men har ändå känslan att det inte är den parametern du/ni avser?

I NASens mjukvara, under inställningar för Web Access, finns parametern Internt portnr för NAS följt av ett fyrsiffrigt nr. Samt likaledes ett femsiffrigt nr för parameternExtern port. Gissar att det är ngt av dessa värde som då skall användas för port forward, å att samma nuffra skall anges för såväl WAN port som LAN port med Destination NASens IP-adress?

Enl nämnda Kjelle-info så skall inget gällande port forward behövas, för att uppnå just ovan - att få NASen att ansluta till nätverket. Det skall räcka med att låsa NASens IP-adress. ?

Ursprungligen av kenjon:

Har du haft UnP påslaget tidigare kan det vara förklaringen till att du har sett den då.
Minus är förstås att andra kan komma åt dina grejor, så tänk på att inte ha för enkla lösenord!

... å sedan en tid tillbaka så är det alltså inte möjligt att köra Automatiska routerinställningar (i NAS-inställningarna) då det där hävdas att det inte är aktiverat (vilket alltså routern säger att det är).
Låter m a o, ur säkerhetsaspekten, som att UpNP då verkligen hade varit att föredra?

  • Medlem
  • Östra Göinge
  • 2016-04-05 21:57
Ursprungligen av Tommy66:

Om jag nu förstått allt rätt så har jag nu lyckats låsa NASens IP-adress genom att i routerinställningarna Add static leases.
Men kommer inte åt NASen, no. (Med felmeddelandet enl tidigare inlägg.)
Å det skall alltså lösas genom ovan, att göra en port forward även för NASen? Med portar som används... Å då uppstår frågan hur jag hittar vilka det är? I routern, under rubriken Devices, finns alla våra enheter uppräknade och en kolumn benämnd just Port i vilken varje enhet har endera siffran 1, 3 eller 4. NASen är ensam om siffran 1. Men har ändå känslan att det inte är den parametern du/ni avser?

I NASens mjukvara, under inställningar för Web Access, finns parametern Internt portnr för NAS följt av ett fyrsiffrigt nr. Samt likaledes ett femsiffrigt nr för parameternExtern port. Gissar att det är ngt av dessa värde som då skall användas för port forward, å att samma nuffra skall anges för såväl WAN port som LAN port med Destination NASens IP-adress?

Enl nämnda Kjelle-info så skall inget gällande port forward behövas, för att uppnå just ovan - att få NASen att ansluta till nätverket. Det skall räcka med att låsa NASens IP-adress. ?

Har lyckats återfå kontakten med NASen och är lycklig för det. Ikväll.
Fortsättning följer.
Inkl huruvida jag skall låsa NASens IP-adress. Återställde, tog bort så att det inte fanns ngn port forward - när jag gjorde det större omtag som gjorde att jag till slut var tillbaka i stabilt läge, kontakt med NASen.
Vågar eller orkar inte ändra mer just nu.

Å så blir det då till att ta sig an väckningsmöjligheten iMacen (fjärr/3G) igen.
Å där förstår jag då att jag skall skapa en port forward för VNC Lite från port 9 till port 9 - och med iMacens IP som destination.

  • Medlem
  • Karlskoga
  • 2016-04-06 11:40

Problem kan lösas på flera sätt. Antingen kan man ha en "cloud-tjänst" som sköter sej själv (typ Skype), kopplar upp sej mot en server på Nätet och håller uppkopplingen igång hela tiden. Eller så har du en Port Forward pekande på din NAS. Det senare kräver att du vet/har ställt in de IPadresser och portar som används. Tjänster som DynDNS hjälper dej att alltid uppdatera vilken IPadress din router har, men du måste ändå ställa Port Forward rätt.
Kul att du har kommit rätt med den del, via manuella inställningar, via Cloud eller UnP?

  • Medlem
  • Östra Göinge
  • 2016-04-07 21:56
Ursprungligen av kenjon:

Kul att du har kommit rätt med den del, via manuella inställningar, via Cloud eller UnP?

Problematiken med att jag inte hade kontakt med NASen och i ett läge inte ens dess mjukvara löstes genom:

1. Start av iMacen efter en dags vila. Då hittade mjukvaran sin NAS igen.
2. Återställning till fabriksinställningar NASen.

  • Medlem
  • Östra Göinge
  • 2016-04-07 22:30
Ursprungligen av kenjon:

WANport och LANport ska båda vara 9. Du borde ha ett fält till där din iMacs IPadress ska skrivas in (till vilken adress port 9 ska skickas).
Är man osäker kan man välja både UDP och TCP...

För att komma åt din NAS måste du kolla vilka portar som används (kanske 80?). Sedan gör du samma som ovan med rätt portnummer och den IPadress som din NAS har.

Webaccess till NASen funkar nu smutt.
Plex funkade redan innan port forward (Plexmediaservern finns på iMacen, mediafilerna på NASen) men efter ny port forward för NASen så funkar nu även accessen från NASens egen webaccessmjukvara (vilket betyder åtkomst till även filer som inte är mediaditon).
Kanon, tack.

Däremot är jag fortfarande inte riktigt klok på WakeUp/Sleep-funktionalitet.
Egentligen skulle jag nu nog skita i det och nöja mig med hur det fungerar men som gammal smålänning eller perfektionist så känns det ändå som att jag inte vill släppa det.

Jag har testat med både appen VCN lite och WakeUp.
Sleep-funktionaliteten har jag inte fått att funka på ngn av dem (connection failed) och då har jag ändå följt instruktionerna, tycker jag. Bl a genom att aktivera Fjärinloggning under Delning, i Macen.

Väckning tror jag att jag har fått till för man kan höra hur iMacen drar sin vanliga uppvakningssuck när man trycker på det kommandot i appen. Samtidigt vaknar inte iMacens skärm (vilket ju är klockrent) - och så bra funkar det kanske?

Men jag vet inte riktigt hur Vila/Sov-läge definieras i det här sammanhanget. För om jag aktivt klickar på Vila-kommandot under äpplet längst upp i vänstra hörnet på iMacen så lyckas jag åtminstone inte nu här ikväll få iMacen att reagera alls, via ngn av nämnda appars väcka-kommando.
Likaledes verkar det vara om jag i Inställningar Strömsparare drar ner Sätt datorn i viloläge till minimum, 1 minut. Får ingen reaktion på väckning då heller.

Å så då det för mig allra märkligaste, tror jag... När jag i dagarna hade satt nämnda inställning till 3 timmar (Dator i viloläge) så gick det att nå åtminstone Plex, även efter att det gått mer än 3 timmar sen någon rört iMacen. Å då var inställningen alltså inte satt på Aldrig, vilket ju annars hade känts som en logisk förklaring.
Eftersom det var först nu ikväll som jag fick till webaccess även med NASens egen mjukvara så har jag inte testat med ngt annat än Plex än.
Vakna för nätverksåtkomst är oxå ikryssad - men det känns ju som en inställning som är grundläggande i sammanhanget, att ingen app i världen hade kunnat åstadkomma ngt för en insomnad iMac annars.

Jag har för övrigt oxå gjort en port forward, enl dina instruktioner för port 9. Vilket ju då skulle vara bifflösaren för ovanstående, vad gäller apparna och väckning/sövning.

Bevaka tråden