El Capitan kopplar ifrån USB disk

Tråden skapades och har fått 30 svar. Det senaste inlägget skrevs .

Någon som har någon erfarenhet av att El Capitan kopplar ifrån USB diskar sporadiskt. Alltså samma som att rycka sladden några gånger om dagen. Haft samma problem sen tidiga betor till senaste 10.11.1.

Äldre osx fungerar så Apple har ändrat något på hur USB fungerar.

Datorn är en Mac Mini 2011 server.

Sitter disken direkt i datorn, eller via en hubb? Om det är via hubb, prova direkt i datorn.
Prova annan USB-port.
Prova annan USB-kabel.

Ursprungligen av Jesper Ohlsson:

Sitter disken direkt i datorn, eller via en hubb? Om det är via hubb, prova direkt i datorn.
Prova annan USB-port.
Prova annan USB-kabel.

Ingen hub, raki i dator. Har bytt USB port så får vi se. Jag vill inte köpa nya usb kablar, det är inget fel på den befintliga kabeln. Har fungerat utmärkt på Yosemite och neråt. Nedgraderar jag datorn till Yosemite försvinner problemet. Verkar som Apple har klantat till det, konstigt att det inte löstes i 10.11.1?

  • Medlem
  • Karlskoga
  • 2015-10-26 14:14

Du VET inte om kabeln är hel eller inte. Den KAN ha pajat samtidigt som du uppgraderade OS X.
Det är inte första gången det skrivs om utmatade hårddiskar och trasiga USBkablar här.... Det är ju lätt att testa!

  • Medlem
  • Helsingborg
  • 2015-10-26 14:23

Det kan lika gärna vara hårddisken som håller på att ge upp.

  • Medlem
  • ÖSTERVÅLA
  • 2015-10-26 14:42

Jag har en Firewiredisk som efter El Capitan ibland kopplas ned. Jag tror det är när datorn går i viloläge som detta kan uppträda. Efter viloläge när jag drar igång den så tappar den ibland den externa disken. Har inte undersökt så noga så det kan vara en slump.

  • Medlem
  • International user
  • 2015-10-26 14:49
Ursprungligen av sepatli:

Jag har en Firewiredisk som efter El Capitan ibland kopplas ned. Jag tror det är när datorn går i viloläge som detta kan uppträda. Efter viloläge när jag drar igång den så tappar den ibland den externa disken. Har inte undersökt så noga så det kan vara en slump.

Jag hade samma problem med två WD-diskar som jag körde på Yosemite med en iMac.
Gugglade och hittade en gratisapp som heter KeepDriveSpinning. Den löste mina problem.
Jag har inte kollat om jag klarar mig utan den nu när jag kör El Capitan.

Ursprungligen av andlin76:

Ingen hub, raki i dator. Har bytt USB port så får vi se. Jag vill inte köpa nya usb kablar, det är inget fel på den befintliga kabeln. Har fungerat utmärkt på Yosemite och neråt. Nedgraderar jag datorn till Yosemite försvinner problemet. Verkar som Apple har klantat till det, konstigt att det inte löstes i 10.11.1?

Felet kvarstår, disken frånkopplas. Felet ligger inte i min dator, dess usb-kablar eller usb diskar utan i hur El Capitan styr usb portarna. Apple har ändrat något som tyvärr ställer till elände för mig en en del andra användare. (Källa, Google)

Ursprungligen av kenjon:

Du VET inte om kabeln är hel eller inte. Den KAN ha pajat samtidigt som du uppgraderade OS X.
Det är inte första gången det skrivs om utmatade hårddiskar och trasiga USBkablar här.... Det är ju lätt att testa!

Nej, usb kablar går inte sönder av att uppgradera osx. Dessutom skrev ja ju att felet försvinner om jag nedgraderar.

Ursprungligen av illerG:

Det kan lika gärna vara hårddisken som håller på att ge upp.

Något udda hårdvarufel som bara visar sig i El Capitan isåfall... men vist. Väldigt långsökt men inte omöjligt.

Ursprungligen av Konrad:

Jag hade samma problem med två WD-diskar som jag körde på Yosemite med en iMac.
Gugglade och hittade en gratisapp som heter KeepDriveSpinning. Den löste mina problem.
Jag har inte kollat om jag klarar mig utan den nu när jag kör El Capitan.

Äntligen ett vettigt tips, ska prova. Tack!

Ursprungligen av sepatli:

Jag har en Firewiredisk som efter El Capitan ibland kopplas ned. Jag tror det är när datorn går i viloläge som detta kan uppträda. Efter viloläge när jag drar igång den så tappar den ibland den externa disken. Har inte undersökt så noga så det kan vara en slump.

Har stängt av alla energi spar funktioner under inställningar. Varken datorn, skärmen eller hårddiskarna somnar. Så just mitt problem har inget med energispar funktionen att göra.

  • Medlem
  • Karlskoga
  • 2015-10-26 23:44
Ursprungligen av andlin76:

Nej, usb kablar går inte sönder av att uppgradera osx. Dessutom skrev ja ju att felet försvinner om jag nedgraderar.

Jag skrev "samtidigt", inte "på grund av".
Jag har också USB-diskar inkopplade, funkar utan problem. Dock hade jag samma problem under Mavericks tidigare, men har försvunnit igen....

  • Medlem
  • International user
  • 2015-10-27 09:25
Ursprungligen av andlin76:

Äntligen ett vettigt tips, ska prova. Tack!

Berätta gärna hur det gick sen när du provat.

  • Medlem
  • Boston
  • 2015-10-27 17:05

Jag har delvis upplevt samma problem på min gamla MBP 17" men efter att ha bytt till en annan USB-port funkar det igen. Börjar fundera på om Apple har ökat känsligheten för dålig koppling i porten i och med El Capitan. Men kan å andra sidan inget om USB-protokollet så jag kan vara helt ute och cyklar...

Ursprungligen av Konrad:

Berätta gärna hur det gick sen när du provat.

Nej, tyvärr så blev det ingen skillnad. Googlar man runt lite ska det finnas sätt att "programera om" usb grässnittet i El Capitan. Jag hoppas dock mer på en quick fix.

Har resetat SMC, om 48h vet jag om det hjälpte.

Fix på gång i 10.11.2, kanske. USB är åtminstone en av punkterna som Apple ber utvecklarna testa i senaste beta-versionen.

"...According to Apple's release notes, focus areas for the beta include Graphics, Mail, Wi-Fi, Calendar, USB, Notes, Photos, and Spotlight..."

http://www.macrumors.com/2015/10/27/first-os-...

Ursprungligen av andlin76:

Har resetat SMC, om 48h vet jag om det hjälpte.

Nope, nu ger jag upp. Är ganska uppenbart är det är EL Capitan som inte funkar.

Ursprungligen av Jesper Ohlsson:

Fix på gång i 10.11.2, kanske. USB är åtminstone en av punkterna som Apple ber utvecklarna testa i senaste beta-versionen.

"...According to Apple's release notes, focus areas for the beta include Graphics, Mail, Wi-Fi, Calendar, USB, Notes, Photos, and Spotlight..."

http://www.macrumors.com/2015/10/27/first-os-...

Låter bra, känns som de får jobba lite på mer på "It just works"...

  • Medlem
  • Karlskoga
  • 2015-10-28 20:51

Eftersom inte alla har det problemet är det nog ett inkompatibilitetsproblem. Kan vara svårt att hitta....

  • Medlem
  • International user
  • 2015-10-29 14:06
Ursprungligen av kenjon:

Eftersom inte alla har det problemet är det nog ett inkompatibilitetsproblem. Kan vara svårt att hitta....

jag tror i mitt fall att det är relaterat till chassierna till mina diskar.
Det är några billiga skitchassin som heter Icy Box, tror jag. Kommer från Webbhallen.
Enda chansen att få dom att fungera var med "KeepDriveSpinning".

  • Medlem
  • Karlskoga
  • 2015-10-29 14:27

Jag har flera IcyBox, både chassis och dockor, fungerat utan problem.

  • Medlem
  • International user
  • 2015-10-29 14:28
Ursprungligen av kenjon:

Jag har flera IcyBox, både chassis och dockor, fungerat utan problem.

Dom är gjorda i Karlskoga, det är därför.

10.11.2 ligger ute som public beta. Efter ständiga frånkopplingar tar jag risken och installera...

Ursprungligen av andlin76:

10.11.2 ligger ute som public beta. Efter ständiga frånkopplingar tar jag risken och installera...

Nope, hjälpte inte ett dugg.

Nånn som fattar nått av det här, och tror att det skulle vara lösningen? Känns ganska komplicerat, och hur vet jag vad min dator heter? (Mac mini mitten 2011)

http://www.insanelymac.com/forum/topic/306777...

  • Medlem
  • Karlskoga
  • 2015-11-02 13:35

Titta under Äpplet, Om den här datorn.

Ursprungligen av kenjon:

Titta under Äpplet, Om den här datorn.

Yes, klickade man sig vidare stod det Mac mini5.3. Tack!

Nu resterade jag smc igen, bytte plats på usb diskarna. Känns som det håller längre. Om jag ändå kunde fatta vad det är som triggar att disken kopplas ifrån. Även min andra usb disk kopplas ifrån, fast den återansluter automatsikt igen. Vilka alternativ finns det, fundera på nas? Känns lite surt då det fungerade bra innan med 10.10.

  • Medlem
  • Karlskoga
  • 2015-11-02 21:52

Jag har 6 datorer med varsin USBansluten hårddisk för TM (nej, en har FW), och det funkar utan problem. Bara en som kör 10.11 dock, resten är nog kvar på 10.9. Så något är nog trasigt hos dej...

Bevaka tråden