Problem med ny SSD-hårddisk i Macbook

Tråden skapades och har fått 7 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Bollnäs
  • 2015-02-14 21:57

Har haft MacBook PRO sedan 2010. Den började hänga sig och bilden frös ett par gånger. Jag var tvungen att starta om datorn. Till slut fick jag upp en katalog med blinkande frågetecken. Startade om med alt-knapp och valde skivverktyg. Konstaterade att hårddisken inte syntes och drog slutsatsen att den kraschat.

Jag köpte en ny SSD-hårddisk (Samsung SSD 850 EVO, 250GB). Satte i den och kom återigen in till skivverktyg. Ser namnet på hårddisken och väljer Erase för att formatera. Jag får frågan om jag verkligen vill fortsätta. Efter att jag klickat fortsätt får jag ett meddelande som säger "Kan inte skriva till det sista blocket på enheten" och kan inte fortsätta.

Om jag väljer istället väljer att installera OS från skiva blir jag uppmanad att väljer plats för detta. Här syns då ingen hårddisk.

Det verkar vara som att man dator och den nya hårddisken inte vill finna varandra.

Vad ska jag göra?

  • Medlem
  • Karlskoga
  • 2015-02-15 11:19

Har du en GUID-partition på disken? Annars får du nog partitionera om den....

  • Medlem
  • Bollnäs
  • 2015-02-15 12:18
Ursprungligen av akigron:

Har haft MacBook PRO sedan 2010. Den började hänga sig och bilden frös ett par gånger. Jag var tvungen att starta om datorn. Till slut fick jag upp en katalog med blinkande frågetecken. Startade om med alt-knapp och valde skivverktyg. Konstaterade att hårddisken inte syntes och drog slutsatsen att den kraschat.

Jag köpte en ny SSD-hårddisk (Samsung SSD 850 EVO, 250GB). Satte i den och kom återigen in till skivverktyg. Ser namnet på hårddisken och väljer Erase för att formatera. Jag får frågan om jag verkligen vill fortsätta. Efter att jag klickat fortsätt får jag ett meddelande som säger "Kan inte skriva till det sista blocket på enheten" och kan inte fortsätta.

Om jag väljer istället väljer att installera OS från skiva blir jag uppmanad att väljer plats för detta. Här syns då ingen hårddisk.

Det verkar vara som att man dator och den nya hårddisken inte vill finna varandra.

Vad ska jag göra?

Vad är en GUID-partion? Så här såg det ut det i menyerna när jag skulle formatera. Jag ser hårddisken man kan inte göra många andra val. Många gråa oklickbara knappar osv.

  • Medlem
  • Karlskoga
  • 2015-02-15 12:28

På din andra bild, där det står Aktuell, ändra till 1 Partition, och välj GUID.
@Goflorp har skrivit en guide här på forumet om hur man partitionerar/formaterar för OSX.

  • Medlem
  • Bollnäs
  • 2015-02-15 14:54

Jag har provat ovanstående förslag, att partitionera, och får samma besked av datorn som innan, fast nu på engelska. "Radering av skiva misslyckades. Fel: POSIX reports: The operation couldn't be completed. Cannot allocate memory."

  • Medlem
  • International user
  • 2015-05-21 15:34
Ursprungligen av akigron:

Har haft MacBook PRO sedan 2010. Den började hänga sig och bilden frös ett par gånger. Jag var tvungen att starta om datorn. Till slut fick jag upp en katalog med blinkande frågetecken. Startade om med alt-knapp och valde skivverktyg. Konstaterade att hårddisken inte syntes och drog slutsatsen att den kraschat.

Jag köpte en ny SSD-hårddisk (Samsung SSD 850 EVO, 250GB). Satte i den och kom återigen in till skivverktyg. Ser namnet på hårddisken och väljer Erase för att formatera. Jag får frågan om jag verkligen vill fortsätta. Efter att jag klickat fortsätt får jag ett meddelande som säger "Kan inte skriva till det sista blocket på enheten" och kan inte fortsätta.

Om jag väljer istället väljer att installera OS från skiva blir jag uppmanad att väljer plats för detta. Här syns då ingen hårddisk.

Det verkar vara som att man dator och den nya hårddisken inte vill finna varandra.

Vad ska jag göra?

Jag har samma problem! Har Yosemite på en Bootbar USB sticka. Min hårddisk kommer upp likadant som din i skivverktyg men det går ej att varken radera eller partionera!

Är det TRIM? Är det för att SATA kabeln är trasig? Är det för att disken inte stöds? Är det för att apple på nåt sätt inte tillåter en att radera/formatera när den är ansluten till den interna sata kabeln? Måste man använda USB-SATA kabel externt för att kunna formatera?

  • Medlem
  • International user
  • 2015-05-22 09:02

Uppdatering:

Först när jag hade den ikopplad via den interna SATA kabeln så gick det alltså INTE att Varken Radera eller Partionera. Det blev samma felmeddelande som jag citerade i min första post. Då läste jag på ett annat macforum att det var en som skrev: Testa med en extern SATA-USB kabel. Sagt och gjort jag drog till Kjell och Company och köpte en. Det sjuka är att då gick det att radera och även Partionera så att SSDn visar sig som en Disk och en partion i Skivverktyg. Därefter installerade jag Yosemite på den när den var ansluten via kabeln. Det går då att boota upp med den kopplad extern och komma in i yosemite. Problemet är här att jag kan inte sätta in den i Macbooken och boota från SSDn. Då kommer den bara halvvägs i uppstarten när det är en horisontell "BAR" som fylls, samtidigt som applelogon visas. Den stannar i princip på 50% och står still i över en halvtimme.

Då valde jag att stänga ned med strömknappen, varav när jag sen bootar upp och väljer USB minnet så verkar det vara så att SSDn till och från inte finns med bland igenkända diskar när datorn bootar upp och man ska välja. Finns den med så kan man ändå bara komma halvvägs.

Nu har jag tänkt att testa Radera/partionera SSDn ansluten till extern kabel. För att ha den partionerad med GUID och HFS+. Därefter tänker jag ansluta den INTERNT i macbooken, och se om jag kan installera Yosemite från bootad USB sticka. Det är liksom här jag är nu.

MEN, ju mer jag testar in och ut ur macbookens interna( ja jag är less på att skruva nu ). Så misstänker jag att det kan vara SATA kabeln, den interna. Från apple som är kass/trasig/halvdålig. Det var nån på apples egna forum som nämde att en vanlig HDD är inte lika kinkig som en SSD. Så det kan vara så att bara för att en HDD Funkar med den interna kabeln så kan SSDn inte gilla en liiiite skadad kabel. Därför tänker jag i banor att få tag i en ny INTERN Sata kabel.

Detta är väl det jag kommit fram till än så länge:

1. SSDn verkar uppenbarligen funka. Det går att radera/partionera via extern kabel och jag kunde boota via extern kabel när jag hade yosemite på den.

2. HDDn funkar internt men den är påväg att dö för den är hur seg som helst.

Ja, nu har jag formaterat med SSDn ansluten till SATA-USB kabel. Det gick bra, det är GUID och HFS+. Nu har jag monterat SSD internt och bootat upp. Jag kunde endast välja mitt USB minne som källa eftersom det är USB minnet som har yosemite installern på sig. SSDn är ju tom. So far so good? Nu när jag kom in med USB stickan till installationsverktyget så valde jag därefter skivverktyget. Nu kunde jag se att SSDn finns där, den har GUID-Partionstabell. Och S.M.A.R.T.-Status: Kontrollerad. Samt att Skrivstatus är Läs och skrivbar. Alltså är väl det en SSD som är rätt formaterad och allt sånt? Nu ska vi se om jag kan installera Yosemite från USB stickan.
Nu fick jag felmeddelande när jag valde SSDn att Installera Yosemite. Det står:
"OS X Kunde inte installeras på den här datorn
Unable to unmount volume for repair.
Avbryt installationsprogrammet så startar datorn om. Försök sedan installera igen."

Jag testade starta om -> Samma fel igen.

Här är jag nu, vad kan det vara för fel? SSDn är Partionerad och rätt så. Men den "Unable to unmount volume for repair." Vad menas?

Senast redigerat 2015-05-22 09:24
  • Medlem
  • International user
  • 2015-05-22 23:27

PROBLEMET ÄR LÖST

Det var den Interna SATA kabeln som behövde bytas. En erfarenhet rikare. Så för er andra som har problem med en SSD när den är monterad internt, trots att den fungerar normalt om den är kopplad externt så kan det alltså vara så att SATA kabeln är lite skadad. I mitt fall var det även så att den vanliga HDDn funkade utan problem(trots att den höll på att ge upp och var jätteseg)

1
Bevaka tråden