Dålig hårddiskkabel?

Tråden skapades och har fått 7 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Göteborg
  • 2015-01-19 08:11

Har en MBP sent 2011 som plötsligt la av (skulle öppna en mapp i Finder när den frös...). Gick inte att starta igen (se bild).
Turligt nog hade jag en partition med ett äldre fungerande OS, som gick att bota i.
Reparerade skivan (det var lite rött) och nu är allt ok enligt skivverktyg, men jag kan inte starta i Macintosh HD utan bara den lilla partitionen.
Startade i target mode men Macintosh HD mountar inte och är grå i skivverktyget. Den är ok när man kör en kontroll men funkar inte.

Det känns ju väldigt konstigt att bara en del av hårddisken är paj såhär, och också kopplingen (som jag har hittat i några forum) att kabeln är paj känns också väldigt konstigt, då borde ju inget av hårddisken fungera? Partitioneringen är ju inte fysisk på samma sätt som en kabel...

Nån som har nåt konstruktivt tips för diagnostik eller är det bara att lämna in?

  • Medlem
  • Göteborg
  • 2015-01-19 12:00

HFS+ som är filsystemet som Apple använder i OSX är mycket ömtåligt och ibland när man "reparerar det" gör man bara saken värre. Du har nog rätt i att du kan utesluta något mekaniskt eller elektriskt fel mellan disk och dator.

Jag hade flyttat disken till en annan maskin och försökt att läsa ut den där, primärt kopplat med SATA eller i andra hand en USB-SATA adapter. Har du ingen annan dator så skaffa en ny disk, installera om OSX. Och läs den gamla disken externt. I värsta fall måste du använda någon programvara för att hämta ut gamla filer från den, i sådana fall får man vara tacksam för det man får tillbaka.

Vad är ditt primära mål? Få datorn att rulla eller få tillbaka filer?

  • Medlem
  • 2015-01-19 12:36

Om du vill rädda filer: http://www.cgsecurity.org/wiki/PhotoRec

Det är gratis och programmet körs i Terminalen. Det är potent.

  • Medlem
  • 2015-01-23 18:44

Jag hade exakt samma problem med min MBP mid 2012 och det var SATA kabeln som var trasig, bytte ut den mot en ny och nu fungerar den klockrent!

  • Medlem
  • Göteborg
  • 2015-01-23 18:53
Ursprungligen av Xaoi:

Jag hade exakt samma problem med min MBP mid 2012 och det var SATA kabeln som var trasig, bytte ut den mot en ny och nu fungerar den klockrent!

Intressant. Jag resonerade att TS kunde se för mycket om disken för att det skulle vara kabeln som spökade. Vi får se om et byte hjälper då.

TS: För att testa om det är kabeln, försök att läsa disken i annan maskin (Mac eller någon linux dist).

  • Medlem
  • 2015-01-23 18:58
Ursprungligen av beh:

Intressant. Jag resonerade att TS kunde se för mycket om disken för att det skulle vara kabeln som spökade. Vi får se om et byte hjälper då.

TS: För att testa om det är kabeln, försök att läsa disken i annan maskin (Mac eller någon linux dist).

Aa precis så resonerade jag också, men tydligen ska det vara ett ganska vanligt problem med just 2012 års modellen på MBP. Och det är ju inte helt omöjligt att det är kabeln som är trasig, den går att köpa "billigt" på eBay förövrigt

En 2011 MBP behöver man väl inte lämna in för att byta HDD? iFixit.com har bra guider på hur man gör. Passa även på att byta till en SSD när du ändå är igång.

  • Medlem
  • 2015-01-24 20:45
Ursprungligen av barbapappa_86:

En 2011 MBP behöver man väl inte lämna in för att byta HDD? iFixit.com har bra guider på hur man gör. Passa även på att byta till en SSD när du ändå är igång.

Nej det behövs inte, det är inte svårare än att knäppa en öl till maten!

1
Bevaka tråden