Imac med skogstokig grafik

Tråden skapades och har fått 9 svar. Det senaste inlägget skrevs .
1

Min 5 år gamla iMac 27" får efter ett tag nån heltokig grafik-bugg. Det blir liksom färgglatt pixligt över hela skärmen och flipprar mellan det och normal grafik, till viss del i takt med att saker rör på sig, exempelvis att man rör muspekaren. Själva muspekarbilden påverkas inte utan ligger liksom över grafikfelet. Det händer inte förrän efter ett antal timmars användande och datorn verkar funka som den ska liksom bakom grafikfelet, det är bara grafiken som gör den helt oanvändbar. När det väl börjat går det inte att få bort, men det försvinner direkt om jag startar om den. Det hände kort efter att jag installerade Yosemite och båda gångerna som det har hänt har jag varit inne i exposé i safari.
Jag antar att det kan vara grafikkortet som börjar ta slut, men jag tänker att det kanske kan bero på mjukvara eftersom det försvinner så fort jag startar om den utan att jag låter den kylas ner och det hände nån dag efter att jag skaffat Yosemite.
Eftersom felet inte verkar uppstå förrän efter flera timmars användande är det ganska svårt att försöka upprepa felet. Jag har inte hittat nåt sätt att få det att uppstå.
Nån som sett något liknande och har nån lösning eller nåt sätt att felsöka närmare?

  • Medlem
  • Örnsköldsvik
  • 2014-10-19 16:24

Låter som grafikkortet har problem.

Hej

Jag har samma problem med en 27" imac från 2011 och grafikkort AMD Radeon HD 6770M 512 MB. Det beter sig lika för mig dock kommer det ganska tidigt efter omstart men jag kan typ "sudda" bort det med ett Safari fönster eller liknande. verkar bara vara problem i typ Finder, jag har aldrig haft detta problem i något annat program. Detta startade även för mig efter installationen av Yosemite, dock var det inte under någon tidigare beta utan kom vid GM1. Har du gjort någon ominstallation eller liknande efter ditt inlägg? skulle vara kul att se om du hittat någon lösning eller om det är lika fortfarande.

//Johan

Ursprungligen av Laseranders:

Min 5 år gamla iMac 27" får efter ett tag nån heltokig grafik-bugg. Det blir liksom färgglatt pixligt över hela skärmen och flipprar mellan det och normal grafik, till viss del i takt med att saker rör på sig, exempelvis att man rör muspekaren. Själva muspekarbilden påverkas inte utan ligger liksom över grafikfelet. Det händer inte förrän efter ett antal timmars användande och datorn verkar funka som den ska liksom bakom grafikfelet, det är bara grafiken som gör den helt oanvändbar. När det väl börjat går det inte att få bort, men det försvinner direkt om jag startar om den. Det hände kort efter att jag installerade Yosemite och båda gångerna som det har hänt har jag varit inne i exposé i safari.
Jag antar att det kan vara grafikkortet som börjar ta slut, men jag tänker att det kanske kan bero på mjukvara eftersom det försvinner så fort jag startar om den utan att jag låter den kylas ner och det hände nån dag efter att jag skaffat Yosemite.
Eftersom felet inte verkar uppstå förrän efter flera timmars användande är det ganska svårt att försöka upprepa felet. Jag har inte hittat nåt sätt att få det att uppstå.
Nån som sett något liknande och har nån lösning eller nåt sätt att felsöka närmare?

Ursprungligen av jojjedude:

Hej

Jag har samma problem med en 27" imac från 2011 och grafikkort AMD Radeon HD 6770M 512 MB. Det beter sig lika för mig dock kommer det ganska tidigt efter omstart men jag kan typ "sudda" bort det med ett Safari fönster eller liknande. verkar bara vara problem i typ Finder, jag har aldrig haft detta problem i något annat program. Detta startade även för mig efter installationen av Yosemite, dock var det inte under någon tidigare beta utan kom vid GM1. Har du gjort någon ominstallation eller liknande efter ditt inlägg? skulle vara kul att se om du hittat någon lösning eller om det är lika fortfarande.

//Johan

Det har faktiskt inte hänt sen jag skrev mitt ursprungliga inlägg. Det är inget jätteproblem (än) iom att det tar rätt lång tid för det att sätta igång och jag kan fortfarande göra saker (exempelvis spara dokument) innan jag startar om för att få bort det. Jag skrev mest inlägget för att mota Olle i grind, ifall det blir ett större problem längre fram. Stannar det på den här nivån kan jag leva med det tills jag får råd med en ny dator.
Jag har en teori om att det är kopplat till spel, då jag tror att de gånger det hänt har varit efter att jag spelat Team Fortress 2. Spelet har fungerat utmärkt, men när jag efteråt startat safari och använt exposé har det satt igång (tror jag, det kan hända att jag minns fel). Jag har dock inte testat den teorin närmare.
Mitt problem låter inte identiskt med ditt, då mitt omfattar allt och liksom blinkar oregelbundet mellan normal grafik och pixelkaos över hela skärmen och går inte att få bort utan en omstart.

Nä det låter som det är olika. Jag har provat med en ominstallation till original OS (10.6.6) för att sedan uppdatera till en clean version av 10.10, och under 10.6.6 så funkade allt bara bra. Så det ligger nog på en drivrutin i mitt fall som inte funkar så bra med 10.10. Då problemet kom igen efter uppdateringen. Plockade även bort logg filer under /Var/Logs/DiagnosticReports/ och det gjorde så mitt felmeddelande försvann och datorn går nu att använda dock med grafik fel som kommer fram lite nu och då. Allt funkar också bättre i fullscreen mode.

Ursprungligen av Laseranders:

Det har faktiskt inte hänt sen jag skrev mitt ursprungliga inlägg. Det är inget jätteproblem (än) iom att det tar rätt lång tid för det att sätta igång och jag kan fortfarande göra saker (exempelvis spara dokument) innan jag startar om för att få bort det. Jag skrev mest inlägget för att mota Olle i grind, ifall det blir ett större problem längre fram. Stannar det på den här nivån kan jag leva med det tills jag får råd med en ny dator.
Jag har en teori om att det är kopplat till spel, då jag tror att de gånger det hänt har varit efter att jag spelat Team Fortress 2. Spelet har fungerat utmärkt, men när jag efteråt startat safari och använt exposé har det satt igång (tror jag, det kan hända att jag minns fel). Jag har dock inte testat den teorin närmare.
Mitt problem låter inte identiskt med ditt, då mitt omfattar allt och liksom blinkar oregelbundet mellan normal grafik och pixelkaos över hela skärmen och går inte att få bort utan en omstart.

Jag har samma problem. Såhär ser det ut hos mig allt som oftast. Det brukar räcka med att jag tar ett fönster och suddar med musen, men sedan kommer problemet tillbaka titt som tätt igen.
Vad är lösningen, tro?

  • Medlem
  • Helsingborg
  • 2014-11-12 11:49

Grafikkort som börjar ge upp.
Men kan lika gärna vara RAM som strular.

Märks det mer när man stressar grafik är det troligen det första.

Kör diagnostik och se om ni får något fel.

  • Medlem
  • Mjölby
  • 2014-11-12 20:52

Hade ett väldigt lustigt grafikfel på min iMac 27" men fick hjälp här med att testa om Voice Over i Hjälpmedelsmappen i Systeminställningar hade slagits på av misstag. Och si så var detn. Hade nog kommit mot den tgb-kombinationen. Sedan var allt frid och fröjd och jag annullerade snabbt som ögat en preliminärbeställning på en ny maskin. Tipset har på 99mac sparade mig 16 kkr då.

  • Medlem
  • Halmstad
  • 2014-11-12 23:35

Det kan också vara en bugg i mjukvara som helt enkelt stressar grafiken så mycket att det blir så där. Det har hänt mig att något fet-hängt datorn och detta fenomen uppstått, och sedan aldrig mera. Det behöver alltså inte vara att grafikkretsar ger upp, per se, bara att något orsakar detta.

  • Medlem
  • Stockholm
  • 2014-11-13 13:14

Om någon har så stora problem med detta att det funderar på att byta logikkort eller kassera maskinen skulle jag prova att installera en äldre version av OSX, speciellt om problemet börjat på allvar efter uppdatering till Yosemite. Verkar som Yosemite förvärrar dessa problem (belastar grafikkortet?). Kan vara värt att prova.

1
Bevaka tråden