OS X (Yosemite beta) byter namn på min enhet

Tråden skapades och har fått 15 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • 2014-09-28 09:50

Ja, som rubriken lyder så byter alltså OS X (Yosemite beta) namn på min enhet.

Den hette tidigare "m-macbook", men märkte för ett tag sedan att den hade bytt till "m-macbook (2)".
Orkade inte rätta till detta så körde med det ett tag innan jag gick och ändrade tillbaka till "m-macbook".
Sen efter det så har den bytt till "m-macbook (3)" och bara fortsatt, så nu är jag på "m-macbook (5)".

Någon som vet vad detta kan bero på? Är det en bugg i Yosemite eller är det något som hänt på tidigare versioner av OS X?
och framförallt, är det någon som har en eventuell lösning på mitt lilla problem? (förutom att gå tillbaka till Mavericks)

Den som löser mitt problem kan få en virtuell kram.

Och lite mer info ifall det kan vara till hjälp:
* Macbook pro (tidigt 2011)
* Yosemite Beta (lite osäker på vart jag hittar exakt versionsnummer, men kör den senaste uppdateringen genom appstore för oss som kör den publika versionen. Tror det är Developer Preview 7)
* Där jag gick för att prova att byta tillbaka var "Systeminställningar/Delning/Enhetens namn".

  • Medlem
  • Örnsköldsvik
  • 2014-09-28 09:58

Det där har funkat på samma vis länge, här har du en sida med info om hur man ändrar detta:
http://www.askdavetaylor.com/how_to_change_imac_mac_name_on_network/

  • Medlem
  • Sollentuna
  • 2014-09-28 09:58

Jag har samma beteende på en MacBook Air mid-2011. Fanns inte på 10.9.4. Men 10.10 är en beta så det bör ju lösa sig. Felanmälan du också till Apple.

  • Skribent
  • Sollentuna
  • 2014-09-28 10:53

Jag har haft samma problem med både MBP, rMBP, Mac Mini och Apple TV länge, innan Mavericks ens. Jag räknar inte med att det löser sig ens i skarpa versionen av Yosemite.

Jag har försökt hitta lösningar, men hittar bara folk med samma problem som inte lyckas lösa det.

Kan vara så att om datorn står inställd på DHCP och "leasen" inte gått ut så förnyar OSX IP-adressen med ett siffertillägg i namnet för att inte skapa konflikt på nätverket. Om någon förstod vad jag menar.

Ursprungligen av grenhall:

Kan vara så att om datorn står inställd på DHCP och "leasen" inte gått ut så förnyar OSX IP-adressen med ett siffertillägg i namnet för att inte skapa konflikt på nätverket. Om någon förstod vad jag menar.

Japp, jag undviker namnbyte på maskinerna mha fasta IPadresser.

  • Skribent
  • Sollentuna
  • 2014-09-28 11:03

Det handlar om DNS Service Discovery (DNS-SD) som går ut på att enheter broadcastar sitt namn på nätverket tillsammans med sina tillgängliga Bonjour-tjänster. Innan namnet broadcastas kollar enheten om namnet är upptaget. Om det är det så lägger den på en siffra i slutet.

Som jag har förstått det handlar det om att andra enheter cachar de broadcastade namnen, så när den rättmätige namninnehavaren frågar om dess namn är ledigt så kommer en annan enhet titta i sin cache och säga att det är upptaget.
Den enda möjliga lösningen jag har hittat är att tömma cachen i alla nätverksenheter samtidigt i princip. Hur exakt det ska gå till är oklart.

  • Skribent
  • Sollentuna
  • 2014-09-28 11:05
Ursprungligen av reboot81:

Japp, jag undviker namnbyte på maskinerna mha fasta IPadresser.

Jag har fast IP på min Mac Mini, men ändå heter den "mini (3)" nu för tiden.

  • Medlem
  • Sollentuna
  • 2014-09-28 11:11
Ursprungligen av Vassius:

Det handlar om DNS Service Discovery (DNS-SD) som går ut på att enheter broadcastar sitt namn på nätverket tillsammans med sina tillgängliga Bonjour-tjänster. Innan namnet broadcastas kollar enheten om namnet är upptaget. Om det är det så lägger den på en siffra i slutet.

Som jag har förstått det handlar det om att andra enheter cachar de broadcastade namnen, så när den rättmätige namninnehavaren frågar om dess namn är ledigt så kommer en annan enhet titta i sin cache och säga att det är upptaget.
Den enda möjliga lösningen jag har hittat är att tömma cachen i alla nätverksenheter samtidigt i princip. Hur exakt det ska gå till är oklart.

Då räcker det alltså med att en enhet har en buggig implementation för att alla andra som gör rätt ändå drabbas?

  • Skribent
  • Sollentuna
  • 2014-09-28 11:24
Ursprungligen av frazze:

Då räcker det alltså med att en enhet har en buggig implementation för att alla andra som gör rätt ändå drabbas?

Mycket möjligt, men jag misstänker att det är OS X som är boven i dramat. Alla drabbade som jag har sett kör Mac, men å andra sidan kanske det mest är där det märks i och med att Apple använder Bonjour väldigt flitigt och även visar datornamnet relativt tydligt.

Yosemite beta radar upp en massa iMac's (sig själv alltså - den burk jag har Yosemite på) i Finders sidebar under Delat: iMac (12) iMac (13) iMac (14) iMac (15) etc etc - it never ends

  • Medlem
  • Sollentuna
  • 2014-09-28 12:19
Ursprungligen av Demiurgen:

Yosemite beta radar upp en massa iMac's (sig själv alltså - den burk jag har Yosemite på) i Finders sidebar under Delat: iMac (12) iMac (13) iMac (14) iMac (15) etc etc - it never ends

Aha. Betan är alltså trasig!

Jepp, det som svajar har med nätverksbeteende att göra - det är några konstigheter och alla har med nätverk att göra. Varje ny version av OSX - sedan begynnelsen - har nätverksproblem. Det är numera en sådan självklarhet att det förväntas.
Nu gäller tydligen denna lag också iOS Nå - iOS 8.0.2 fixade tydligen det mesta.

Ursprungligen av frazze:

Aha. Betan är alltså trasig!

  • Avstängd
  • Bangkok Thailand
  • 2014-09-28 13:21

Jag löste det genom att göra som mattiL länkade till.
Men med skillnaden att jag gick först in på min användare och låste upp hänglåset.
Gick tillbaka och ändrade namn under delning,stängde sen hänglåset under min användare och sen dess har inte namnet ändrats.

  • Medlem
  • 2014-09-28 14:01
Ursprungligen av mattiL:

Det där har funkat på samma vis länge, här har du en sida med info om hur man ändrar detta:
http://www.askdavetaylor.com/how_to_change_imac_mac_name_on_network/

tack, men det är precis så jag ändrar det. sen efter en kort stund så ändrar den tillbaka.

dock inte testat att göra som @lappen71 gjort, så får prova det.

EDIT: nu provat det och det ändrar fortfarande tillbaka. men nu är det nere på (3) igen.

Senast redigerat 2014-09-28 21:16
  • Medlem
  • I skogen utanför Umeå
  • 2014-09-29 17:42

Hade det här problemet tidigare, men det försvan efter ett tag. Nu när jag läser här så förstår jag att det måste ha varit min D-Link kamera som ställde till det och att det var efter en uppdatering av kameran som det försvann.

1
Bevaka tråden