Koppla Cinema Display 27" till PC?

Tråden skapades och har fått 26 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Järfälla
  • 2014-08-08 15:03

Hej 99mac!

Jag har en PC med ett grafikkort som är GeForce GTX 660. Enligt specarna ska den ha Displayport:

GeForce GTX 660:

Display Support:
4 displaysMulti Monitor
4096x2160Maximum Digital Resolution3
2048x1536Maximum VGA Resolution
YesHDCP
YesHDMI4
One Dual Link DVI-I, One Dual Link DVI-D, One HDMI, One DisplayPortS <----- tandard Display Connectors
Internal

Frågan är vad jag behöver för adapter för att koppla en Cinema display 27" till mitt grafikkort och vart jag köper det? Kan någon hjälpa mig?

Jag verkar behöva en Displayport hane till minidisplayport hona.

Fungerar en sån här?

https://www.elfa.se/elfa3~se_sv/elfa/init.do?...

Eller vad rekommenderar ni att köra? Några nackdelar med att köra en sån liten "skit" adapter?

Tacksam för snabbt svar då skärmen anländer imorgon!

  • Medlem
  • Järfälla
  • 2014-08-08 17:17

ingen?

  • Medlem
  • Järfälla
  • 2014-08-09 14:52

Jag har nu köpt en mini displayport till displayport adapter men får ingen bild alls på min 27" cinemadisplay? varför inte? snälla hjälp!

Saknar du några drivrutiner? Det är din lösning som verkar fungera som jag tolkar det som om man googlar på det.

  • Medlem
  • Järfälla
  • 2014-08-09 15:58
Ursprungligen av barbapappa_86:

Saknar du några drivrutiner? Det är din lösning som verkar fungera som jag tolkar det som om man googlar på det.

Nope inte vad jag vet. Försökte ladda ner drivrutiner på apples hemsida men det står bara "Alert! Your computer doesn't need these drivers."

Och sen trycker man OK så stängs fönstret.

Läste något om att UEFI bios och Cinema display inte fungerar, det liksom visar INGEN bild alls. Ljud får jag ut ifrån skärmen utan något som helst problem, men bilden funkar ej! Vad bör jag göra?

  • Medlem
  • 2014-08-09 16:08

Du är helt säker på att det är en Cinema Display och inte en Thunderbolt Display?
Om jag minns rätt:
En Cinema Display fungerar i både MiniDisplay-port och Thunderbolt-port. Men Thunderbolt Display fungerar inte i en MiniDislay-port.
Det kan kanske vara lätt att blanda ihop då både skärmar och kontakter ser likadana ut?

Bara en tanke...

Kan vara adaptern som är kass. Vanligt om den är billig och av dålig kvalité.

  • Medlem
  • Järfälla
  • 2014-08-09 16:16
Ursprungligen av Dalle:

Du är helt säker på att det är en Cinema Display och inte en Thunderbolt Display?
Om jag minns rätt:
En Cinema Display fungerar i både MiniDisplay-port och Thunderbolt-port. Men Thunderbolt Display fungerar inte i en MiniDislay-port.
Det kan kanske vara lätt att blanda ihop då både skärmar och kontakter ser likadana ut?

Bara en tanke...

Helt säker på att det är en Cinema Display och ej thunderbolt! förra ägaren som jag köpte den av sa även att det ej var thunderbolt versionen.

  • Medlem
  • Järfälla
  • 2014-08-09 16:17
Ursprungligen av barbapappa_86:

Kan vara adaptern som är kass. Vanligt om den är billig och av dålig kvalité.

Vart hittar jag en bra adapter då? denna köpte jag på kjell & co:

http://www.kjell.com/sortiment/dator-kringutr...

  • Medlem
  • Järfälla
  • 2014-08-09 16:37

Är denna bättre tro?

http://www.dustinhome.se/product/5010465399/d...

och tror ni verkligen att det kommer att lösa problemet?

Ursprungligen av jontah:

Helt säker på att det är en Cinema Display och ej thunderbolt! förra ägaren som jag köpte den av sa även att det ej var thunderbolt versionen.

Bara för att vara riktigt, riktigt säker. Vad har du för portar bak på skärmen? Enligt Apple store ska

"cinema display has 3 USB 2.0 ports on the back, the thunderbolt display has 3 USB 2.0 ports, FireWire 800, an additional Thunderbolt port and an ethernet port"

Bara för att säljaren säger en sak är det ju inte nödvändigtvis sant...

Vilken upplösning försöker du skicka ut på skärmen? Om skärmen inte stöder just den upplösningen verkar skärmen bli helt svart. Testa med något lågt, t.ex. 1024x768 och se om du får bild öht.

Är du säker på att displayporten är aktiverad i datorn? Har du en annan skärm inkopplad samtidigt?

Jag hade börjat med att stänga av datorn, koppla in enbart displayportsadaptern och Cinema skärmen och se om man får någon bild när man bootar datorn.
Får man det och bilden försvinner när man kommer in i Windows kan man misstänka drivrutinsfel/upplösning. Får man däremot ingen bild när man bootar hade jag kopplat upp en annan bildskärm och kollat så att det inte finns en BIOS/UEFI-inställning som stänger av displayporten (lite långsökt när det är ett externt kort).

Annars kan det vara så att sladden in i skärmen är skadad. Testade du skärmen innan du köpte den? Så att du såg att den fungerade?

  • Medlem
  • Järfälla
  • 2014-08-09 17:40
Ursprungligen av HåkanE:

Bara för att vara riktigt, riktigt säker. Vad har du för portar bak på skärmen? Enligt Apple store ska

"cinema display has 3 USB 2.0 ports on the back, the thunderbolt display has 3 USB 2.0 ports, FireWire 800, an additional Thunderbolt port and an ethernet port"

Bara för att säljaren säger en sak är det ju inte nödvändigtvis sant...

Vilken upplösning försöker du skicka ut på skärmen? Om skärmen inte stöder just den upplösningen verkar skärmen bli helt svart. Testa med något lågt, t.ex. 1024x768 och se om du får bild öht.

3 USB 2.0 portar endast. Det spelar ingen roll, jag kan inte ens få bild på skärmen. Den liksom är helt svart. Kan inte göra något alls.

  • Medlem
  • Järfälla
  • 2014-08-09 17:44
Ursprungligen av suddgummi:

Är du säker på att displayporten är aktiverad i datorn? Har du en annan skärm inkopplad samtidigt?

Jag hade börjat med att stänga av datorn, koppla in enbart displayportsadaptern och Cinema skärmen och se om man får någon bild när man bootar datorn.
Får man det och bilden försvinner när man kommer in i Windows kan man misstänka drivrutinsfel/upplösning. Får man däremot ingen bild när man bootar hade jag kopplat upp en annan bildskärm och kollat så att det inte finns en BIOS/UEFI-inställning som stänger av displayporten (lite långsökt när det är ett externt kort).

Annars kan det vara så att sladden in i skärmen är skadad. Testade du skärmen innan du köpte den? Så att du såg att den fungerade?

Jag har testat med att koppla ur den befintliga skärmen jag har och bara köra displayporten. Men det funkade ej heller.

Nej! Hur aktiverar jag displayporten? Har googlat men inte hittat något.

Jag använder OSX och inte Windows. då jag kör en s.k. hackintosh.

Har testat det du skriver, får ej någon bild alls när jag bootar eller när jag är inne i OSX.

Jag har testat så att sladden fungerar. Jag har den inkopplad just nu till min Macbook Pro och det funkar fint.

Kikade i BIOS hittade ingen inställning till displayporten :/

Herregud.. Ja, inte så konstigt då att det är svårt att hjälpa dig. Att den kör OSX är bara en väldigt viktig detalj som du glömde nämna.

Hur som haver, vad är det du har använt för att kunna köra OSX på den?

  • Medlem
  • Järfälla
  • 2014-08-09 17:53
Ursprungligen av barbapappa_86:

Herregud.. Ja, inte så konstigt då att det är svårt att hjälpa dig. Att den kör OSX är bara en väldigt viktig detalj som du glömde nämna.

Hur som haver, vad är det du har använt för att kunna köra OSX på den?

Hehe trodde detta var ett Mac forum xD därför jag inte nämnde det. Sorry!!

Jag kör Chameleon bootloader just nu och har installerat OSX via ett usb. Rätt smidigt, men mycket krångel och mycket .kext filer man måste hålla på att greja med osv.

Finns massa info om det på www.insanelymac.com eller www.tonymacx86.com

Men jag får inte igång skärmen! Det är jätte frustrerande.

Ursprungligen av jontah:

Hehe trodde detta var ett Mac forum xD därför jag inte nämnde det. Sorry!!

Jag kör Chameleon bootloader just nu och har installerat OSX via ett usb. Rätt smidigt, men mycket krångel och mycket .kext filer man måste hålla på att greja med osv.

Men jag får inte igång skärmen! Det är jätte frustrerande.

Har du kollat i installeraren för drivrutiner om du hittar något om ditt grafikkort? Fungerar kortet med en annan port, typ DVI (kan du kanske testa med en annan skärm).

Tonymac är en bra sida du kan kika på, det bör vara andra som använder/har testat med samma kort som du har i din dator. Där står det säkert en del om drivrutiner om de inte redan finns i installeraren av drivrutiner.

Okej, det hade varit nyttigt att ha med i första posten.
Vilken version av OS X då?
Exakt vilket grafikkort är det?
Vad har du för drivrutiner?
Hur har du satt graphics enabler (ska vara "no"/0)?

Ursprungligen av jontah:

Jag har testat med att koppla ur den befintliga skärmen jag har och bara köra displayporten. Men det funkade ej heller.

Nej! Hur aktiverar jag displayporten? Har googlat men inte hittat något.

Jag använder OSX och inte Windows. då jag kör en s.k. hackintosh.

Har testat det du skriver, får ej någon bild alls när jag bootar eller när jag är inne i OSX.

Jag har testat så att sladden fungerar. Jag har den inkopplad just nu till min Macbook Pro och det funkar fint.

Kikade i BIOS hittade ingen inställning till displayporten :/

  • Medlem
  • Järfälla
  • 2014-08-09 18:01
Ursprungligen av barbapappa_86:

Har du kollat i installeraren för drivrutiner om du hittar något om ditt grafikkort? Fungerar kortet med en annan port, typ DVI (kan du kanske testa med en annan skärm).

Tonymac är en bra sida du kan kika på, det bör vara andra som använder/har testat med samma kort som du har i din dator. Där står det säkert en del om drivrutiner om de inte redan finns i installeraren av drivrutiner.

Japp min andra skärm är inkopplad via DVI-D och det funkar bra. JAg sitter på den och skriver just nu.

Jag har 2st skärmar, varav Cinema displayen är den skärmen som ej fungerar alls när jag kopplar in den via displayport till min dator.
JAg ställde frågan på diverse hackintosh forum och dem tror det är adaptern men dem visste inte riktigt vad det var. Dem ville att jag skulle köpa ny adapter först.

Har senaste drivisarna för allt, inklusive grafikkort, ljudkort m.m.

Men hur aktiverar jag displayporten i datorn?

Har andra lyckats få porten att lira med samma kort så är det nog som jag skrev, dvs adaptern. Vilken som helt bör duga (typ), men håll dig gärna till lite dyrare grejer än Claes Ohlssons, brukar vara av bättre kvalité.

Ursprungligen av jontah:

Japp min andra skärm är inkopplad via DVI-D och det funkar bra. JAg sitter på den och skriver just nu.

Jag har 2st skärmar, varav Cinema displayen är den skärmen som ej fungerar alls när jag kopplar in den via displayport till min dator.
JAg ställde frågan på diverse hackintosh forum och dem tror det är adaptern men dem visste inte riktigt vad det var. Dem ville att jag skulle köpa ny adapter först.

Har senaste drivisarna för allt, inklusive grafikkort, ljudkort m.m.

Men hur aktiverar jag displayporten i datorn?

Varifrån kommer dessa då?
Ditt 660 ska stödjas direkt av Apples drivrutiner i 10.8.3. Svara gärna på vilken version av OS X du har.

Jag har i Windows möjlighet att avaktivera utgångar på mitt Nvidiakort. Men i OS X vet jag inte om det går. Du gjorde ju inte klart att du körde OS X på en gång.

  • Medlem
  • Järfälla
  • 2014-08-09 18:37
Ursprungligen av suddgummi:

Varifrån kommer dessa då?
Ditt 660 ska stödjas direkt av Apples drivrutiner i 10.8.3. Svara gärna på vilken version av OS X du har.

Jag har i Windows möjlighet att avaktivera utgångar på mitt Nvidiakort. Men i OS X vet jag inte om det går. Du gjorde ju inte klart att du körde OS X på en gång.

Jag kör Mavericks OSX 10.9.4

Konstigt detta. Verkar ju vara adaptern isf.

  • Medlem
  • Järfälla
  • 2014-08-09 22:21

Ingen annan som vet något/har något förslag? funkar verkligen inte vill få igång den!

Prova med Windows och se om du får igång den där.

  • Medlem
  • Järfälla
  • 2014-08-09 23:55
Ursprungligen av keptang:

Prova med Windows och se om du får igång den där.

Det sjuka är att jag har försökt installera windows men det funkar bara inte. Det står att man måste formetera disken och jag har gjort det 1000 gånger men får alltid samma skit. Jag har till och med köpt windows 8 och allt. Har gjort en partition endast för windows 8.

  • Medlem
  • Järfälla
  • 2014-08-10 03:31

hittade denna: http://www.inet.se/produkt/8907008/kanex-dual...

svindyr adapter men verkar kunna vara lösningen till att det ska funka. Eftersom att DVI-D funkar, det vet jag. Har en skärm inkopplad till dVI-D redan. Denna adapter är sviiiiiiiiiiiindyr ja, men den är anpassad för Cinema Display också.

  • Medlem
  • Järfälla
  • 2014-08-10 03:36

Hittade detta:

http://www.tonymacx86.com/general-help/84286-...

En snubbe som har exakt samma problem som mig, men han verkar inte ha hittat någon solution till det heller..

1
Bevaka tråden